netifd: update to latest version
authorFelix Fietkau <nbd@openwrt.org>
Tue, 29 Jan 2013 14:40:04 +0000 (14:40 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 29 Jan 2013 14:40:04 +0000 (14:40 +0000)
fixes DNS servers on reload (#12910)
fixes ubus object race on reload or down/up (#12612)

SVN-Revision: 35383

package/network/config/netifd/Makefile
package/network/config/netifd/files/sbin/ifstatus
package/network/config/netifd/files/sbin/ifup

index af50d4d28ee983c1a74bae8374baddd9825d1ae2..b5dd767f7ee2c31aaea259233cd6bc9a2a077cd6 100644 (file)
@@ -1,13 +1,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netifd
-PKG_VERSION:=2013-01-29.1
+PKG_VERSION:=2013-01-29.2
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/netifd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=3ae15bc2b82fe32188f726ceabcb1883276a5aed
+PKG_SOURCE_VERSION:=4bb99d4eb462776336928392010b372236ac3c93
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 # PKG_MIRROR_MD5SUM:=
index 511cc1d8d92acc654550a694a5920326861cc4e5..8a951e6e15a9cb1a3a45966c6cc32dfccd35e409 100755 (executable)
@@ -10,4 +10,4 @@ ubus -S list "network.interface.$INTERFACE" >/dev/null || {
        echo "Interface $INTERFACE not found"
        exit 1
 }
-ubus call network.interface."$INTERFACE" status
+ubus call network.interface status "{ \"interface\" : \"$INTERFACE\" }"
index e6dbb3541778626e170044338093a64a9e4e0186..af3aaa8453ce93f52c2b89e743f43f9c509ad696 100755 (executable)
@@ -6,7 +6,7 @@ setup_wifi=
 if_call() {
        local interface="$1"
        for mode in $modes; do
-               ubus call $interface $mode
+               ubus call network.interface $mode "{ \"interface\" : \"$interface\" }"
        done
 }
 
@@ -38,7 +38,7 @@ done
 [ "$modes" = "down up" ] && ubus call network reload
 if [ -n "$ifup_all" ]; then
        for interface in `ubus -S list 'network.interface.*'`; do
-               if_call "$interface"
+               if_call "${interface##network.interface.}"
        done
        [ -n "$setup_wifi" ] && /sbin/wifi up
        exit
@@ -47,7 +47,7 @@ else
                echo "Interface $1 not found"
                exit
        }
-       if_call "network.interface.$1"
+       if_call "$1"
 fi
 
 if [ -n "$setup_wifi" ] && grep -sq config /etc/config/wireless; then