ar71xx: fix EnGenius ENS202EXT mtd definition
authorPiotr Dymacz <pepe2k@gmail.com>
Wed, 14 Jun 2017 13:23:35 +0000 (15:23 +0200)
committerPiotr Dymacz <pepe2k@gmail.com>
Thu, 29 Jun 2017 08:37:36 +0000 (10:37 +0200)
Use statically defined sizes for kernel and rootfs mtd partitions.
Vendor upgrade script writes both firmware parts independently which
ends up in a gap between kernel and rootfs images. This results in
incorrectly calculated rootfs_data start offset.

Also, fix IMAGE_SIZE, DEVICE_PACKAGES and drop redundant KERNEL
definition.

Fixes FS#835

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
target/linux/ar71xx/image/senao.mk

index 57e3610e5d5795f6431dd2273f1bae7e2c29023d..dbb7b69f94735ffe148e851fabd7d2b837f47532 100644 (file)
@@ -20,12 +20,12 @@ endef
 define Device/ens202ext
   DEVICE_TITLE := EnGenius ENS202EXT
   BOARDNAME := ENS202EXT
-  DEVICE_PACKAGES += rssileds
+  DEVICE_PACKAGES := rssileds
   KERNEL_SIZE := 1536k
-  KERNEL := kernel-bin | patch-cmdline | lzma | uImage lzma | check-size $$(KERNEL_SIZE)
-  IMAGE_SIZE := 12096k
+  IMAGE_SIZE := 13632k
   IMAGES += factory.bin
+  MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),320k(custom)ro,1536k(kernel),12096k(rootfs),2048k(failsafe)ro,64k(art)ro,13632k@0xa0000(firmware)
   IMAGE/factory.bin/squashfs := append-rootfs | pad-rootfs | senao-factory-image ens202ext $$$$@
-  MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),320k(custom)ro,13632k(firmware),2048k(failsafe)ro,64k(art)ro
+  IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
 endef
 TARGET_DEVICES += ens202ext