kernel: add usb-ohci-pci module
authorJohn Crispin <john@openwrt.org>
Wed, 1 Apr 2015 13:52:31 +0000 (13:52 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 1 Apr 2015 13:52:31 +0000 (13:52 +0000)
This add usb-ohci-pci module for USB1.x devices

Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
SVN-Revision: 45221

package/kernel/linux/modules/usb.mk

index b57ca9209fe1d24c5ef8e1231bada8b0a4e9aad4..316eb696b4098165cae0300ecfd86f2ed29dffa2 100644 (file)
@@ -352,6 +352,22 @@ endef
 $(eval $(call KernelPackage,usb-ohci,1))
 
 
+define KernelPackage/usb-ohci-pci
+  TITLE:=Support for PCI OHCI controllers
+  DEPENDS:=@PCI_SUPPORT @(!LINUX_3_3&&!LINUX_3_6) +kmod-usb-ohci
+  KCONFIG:=CONFIG_USB_OHCI_HCD_PCI
+  FILES:=$(LINUX_DIR)/drivers/usb/host/ohci-pci.ko
+  AUTOLOAD:=$(call AutoLoad,51,ohci-pci,1)
+  $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb2-pci/description
+ Kernel support for PCI OHCI controllers
+endef
+
+$(eval $(call KernelPackage,usb-ohci-pci))
+
+
 define KernelPackage/usb2-fsl
   TITLE:=Support for Freescale USB2 controllers
   DEPENDS:=@TARGET_mpc85xx