x86/geode: fixup FEATURE inheritance
authorPaul Spooren <mail@aparcar.org>
Mon, 23 Mar 2020 18:53:46 +0000 (08:53 -1000)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 23 Mar 2020 18:56:26 +0000 (18:56 +0000)
In the geode subtarget all default x86 features were overwritten via :=
instead of extending them via +=.

This patch fixes the inheritance and thereby the compilation of
x86/geode target.

Compile tested x86/geode.

Signed-off-by: Paul Spooren <mail@aparcar.org>
target/linux/x86/geode/target.mk

index f4c7b9564e6023a77d0dc0e431a198e8aef4a2ba..f69e8cada5aab611851cfd1117a07943b1e826d5 100644 (file)
@@ -1,5 +1,5 @@
 BOARDNAME:=AMD Geode based systems
-FEATURES:=pci usb gpio
+FEATURES += pci usb gpio
 DEFAULT_PACKAGES += \
                        kmod-crypto-hw-geode kmod-crypto-cbc \
                        kmod-ath5k kmod-ath9k \