ath79: add support for YunCore A770
authorPiotr Dymacz <pepe2k@gmail.com>
Sat, 9 Mar 2019 15:31:17 +0000 (16:31 +0100)
committerPiotr Dymacz <pepe2k@gmail.com>
Sat, 9 Mar 2019 15:31:17 +0000 (16:31 +0100)
YunCore A770 is a ceiling AC750 AP with 2 Fast Ethernet ports, PoE
(802.3at) support, based on QCA9531 + QCA9887.

Specification:

- 650/597/216 MHz (CPU/DDR/AHB)
- 128 MB of RAM (DDR2)
- 16 MB of flash (SPI NOR)
- 2x 10/100 Mbps Ethernet (PoE 802.3at support in WAN port)
- 2T2R 2.4 GHz (QCA9531), with ext. PA and LNA
- 1T1R 5 GHz (QCA9887), with ext. FEM (SKY85728-11)
- 2x regular LED, 1x RGB LED (all driven by GPIO)
- 1x button (reset)
- DC jack for main power input (12 V)
- UART header on PCB

Flash instruction:

1. First, gain root access to the device, following below steps:

- Login into web gui (default password/IP: admin/192.168.188.253).
- Go to 'Advanced' -> 'Management' -> 'System' and download backup of
  configuration (bakfile.bin).
- Open the file as tar.gz archive, edit/update 'shadow' file and change
  hash of root password to something known.
- Repack the archive, rename it back to 'bakfile.bin' and use to
  restore configuration of the device.
- After that, device will reboot and can be accessed over SSH.

2. Then, install OpenWrt:

- Login over SSH and issue command:
  fw_setenv bootcmd "bootm 0x9f050000 || bootm 0x9fe80000"
- Upload 'sysupgrade' image and install it (only if previous command
  succeeded) with command: 'sysupgrade -n -F openwrt-...'.

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/dts/qca9531_yuncore_a770.dts [new file with mode: 0644]
target/linux/ath79/image/generic.mk

index 0fa4bc73bb9d572f28b7a218941e01b43a8f34f0..a7b6a65e0f72f1ff9b8ca54a0fd1096cf75cc55c 100755 (executable)
@@ -171,6 +171,10 @@ wd,mynet-wifi-rangeextender)
        ucidef_set_led_rssi "rssimedium" "RSSIMED" "$boardname:blue:rssi-med" "wlan0" "33" "100"
        ucidef_set_led_rssi "rssihigh" "RSSIMAX" "$boardname:blue:rssi-max" "wlan0" "66" "100"
        ;;
+yuncore,a770)
+       ucidef_set_led_netdev "wan" "WAN" "$boardname:green:wan" "eth0"
+       ucidef_set_led_switch "lan" "LAN" "$boardname:green:lan" "switch0" "0x10"
+       ;;
 esac
 
 board_config_flush
index 9a7f2d6472b78b8a50f2e71e6a6db9c90f382205..76a1ffba409824c8ce402ad7234289379965c9c6 100755 (executable)
@@ -100,7 +100,8 @@ ath79_setup_interfaces()
        glinet,gl-x750|\
        tplink,tl-wr810n-v1|\
        tplink,tl-wr810n-v2|\
-       ubnt,routerstation)
+       ubnt,routerstation|\
+       yuncore,a770)
                ucidef_set_interfaces_lan_wan "eth1" "eth0"
                ;;
        glinet,gl-ar750s)
index 096064b7ce61fbf03d3d70466c5a7e8c2e2e0de8..53128cad65e7b667f8d087e7e3dbbc8ba73024a8 100644 (file)
@@ -150,6 +150,9 @@ case "$FIRMWARE" in
        ubnt,unifiac-pro)
                ath10kcal_extract "EEPROM" 20480 2116
                ;;
+       yuncore,a770)
+               ath10kcal_extract "art" 20480 2116
+               ;;
        esac
        ;;
 "ath10k/pre-cal-pci-0000:00:00.0.bin")
diff --git a/target/linux/ath79/dts/qca9531_yuncore_a770.dts b/target/linux/ath79/dts/qca9531_yuncore_a770.dts
new file mode 100644 (file)
index 0000000..18ad630
--- /dev/null
@@ -0,0 +1,126 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca953x.dtsi"
+
+/ {
+       model = "YunCore A770";
+       compatible = "yuncore,a770", "qca,qca9533";
+
+       aliases {
+               led-boot = &status;
+               led-failsafe = &status;
+               led-running = &status;
+               led-upgrade = &status;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               lan {
+                       label = "a770:green:lan";
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+               };
+
+               status: status {
+                       label = "a770:green:status";
+                       gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+                       default-state = "keep";
+               };
+
+               wan {
+                       label = "a770:green:wan";
+                       gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan2g {
+                       label = "a770:red:wlan2g";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy1tpt";
+               };
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       phy-handle = <&swphy4>;
+       mtd-mac-address = <&art 0x0>;
+};
+
+&eth1 {
+       mtd-mac-address = <&art 0x6>;
+};
+
+&pcie0 {
+       status = "okay";
+};
+
+&spi {
+       status = "okay";
+
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "u-boot-env";
+                               reg = <0x040000 0x010000>;
+                       };
+
+                       partition@50000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x050000 0xfa0000>;
+                       };
+
+                       art: partition@ff0000 {
+                               label = "art";
+                               reg = <0xff0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&uart {
+       status = "okay";
+};
+
+&wmac {
+       status = "okay";
+
+       mtd-cal-data = <&art 0x1000>;
+};
index fa504ee0fcdfc6377c41634a15fc63e2f94be4bb..c68e6a4a9070ce6b843ddf45006827be23a94136 100644 (file)
@@ -556,3 +556,11 @@ define Device/xiaomi_mi-router-4q
   IMAGE_SIZE := 14336k
 endef
 TARGET_DEVICES += xiaomi_mi-router-4q
+
+define Device/yuncore_a770
+  ATH_SOC := qca9531
+  DEVICE_TITLE := YunCore A770
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9887-ct
+  IMAGE_SIZE := 16000k
+endef
+TARGET_DEVICES += yuncore_a770