build: don't add -j for parallel builds with Make 4.2+
authorMatthias Schiffer <mschiffer@universe-factory.net>
Wed, 15 Jun 2016 16:56:17 +0000 (18:56 +0200)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Wed, 15 Jun 2016 17:26:17 +0000 (19:26 +0200)
Make usually passes -j and jobserver arguments as part of MAKEFLAGS. LEDE
removes MAKEFLAGS to have better control of the build, and re-adds the
jobserver arguments with -j to the Make commandline where desired.

Make 4.2+ behave differently with these arguments passed on the commandline
than in MAKEFLAGS: -j will override the jobserver argument and the job
count will be unlimited.

Moving the flags to MAKEFLAGS will need many packages to be changed and
tested; therefore, we opt for a less invasive change for now and just
remove -j for Make 4.2+, as the jobserver argument alone is enough to
enable parallel builds for these Make versions.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
include/host-build.mk
include/package.mk

index 456b418f86708aaa06db590336716fd21b6d8441..a494ceddf3b8bf8d2c494d41051968921d1f1636 100644 (file)
@@ -10,7 +10,7 @@ HOST_INSTALL_DIR ?= $(HOST_BUILD_DIR)/host-install
 HOST_BUILD_PARALLEL ?=
 
 ifneq ($(CONFIG_PKG_BUILD_USE_JOBSERVER),)
-  HOST_MAKE_J:=$(if $(MAKE_JOBSERVER),$(MAKE_JOBSERVER) -j)
+  HOST_MAKE_J:=$(if $(MAKE_JOBSERVER),$(MAKE_JOBSERVER) $(if $(filter 3.% 4.0 4.1,$(MAKE_VERSION)),-j))
 else
   HOST_MAKE_J:=-j$(CONFIG_PKG_BUILD_JOBS)
 endif
index 092811c2c2016a94dfb753ef86318849cc8183ff..fa5c4e7d5d8d1cf53283a441378caa2ebb0030c4 100644 (file)
@@ -17,7 +17,7 @@ PKG_USE_MIPS16 ?= 1
 PKG_IREMAP ?= 1
 
 ifneq ($(CONFIG_PKG_BUILD_USE_JOBSERVER),)
-  MAKE_J:=$(if $(MAKE_JOBSERVER),$(MAKE_JOBSERVER) -j)
+  MAKE_J:=$(if $(MAKE_JOBSERVER),$(MAKE_JOBSERVER) $(if $(filter 3.% 4.0 4.1,$(MAKE_VERSION)),-j))
 else
   MAKE_J:=-j$(CONFIG_PKG_BUILD_JOBS)
 endif