tools: host/include/getline.h: Remove
authorRosen Penev <rosenp@gmail.com>
Wed, 12 Apr 2017 20:18:49 +0000 (13:18 -0700)
committerFelix Fietkau <nbd@nbd.name>
Wed, 26 Apr 2017 08:29:39 +0000 (10:29 +0200)
Seems to be useful only for old and unsupported operating systems. Removed and adjusted the mtd-utils Makefile.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
tools/include/getline.h [deleted file]
tools/mtd-utils/Makefile

diff --git a/tools/include/getline.h b/tools/include/getline.h
deleted file mode 100644 (file)
index 7b320f7..0000000
+++ /dev/null
@@ -1,72 +0,0 @@
-/*-
- * Copyright (c) 2006 SPARTA, Inc.
- * All rights reserved.
- *
- * This software was developed by SPARTA ISSO under SPAWAR contract
- * N66001-04-C-6019 ("SEFOS").
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions
- * are met:
- * 1. Redistributions of source code must retain the above copyright
- *    notice, this list of conditions and the following disclaimer.
- * 2. Redistributions in binary form must reproduce the above copyright
- *    notice, this list of conditions and the following disclaimer in the
- *    documentation and/or other materials provided with the distribution.
- *
- * THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
- * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
- * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
- * ARE DISCLAIMED.  IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
- * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
- * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
- * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
- * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
- * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
- * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
- * SUCH DAMAGE.
- */
-
-#include <sys/types.h>
-#include <stdio.h>
-#include <stdlib.h>
-#include <string.h>
-
-#ifdef __FreeBSD__
-#include <osreldate.h>
-#endif
-
-#if !defined(__linux__) && !defined(__OpenBSD__) && !(defined(__APPLE__) && __DARWIN_C_LEVEL >= 200809L) && !(defined(__FreeBSD__) && __FreeBSD_version >= 800000)
-/*
- * Emulate glibc getline() via BSD fgetln().
- * Note that outsize is not changed unless memory is allocated.
- */
-static inline ssize_t
-getline(char **outbuf, size_t *outsize, FILE *fp)
-{
-       size_t len;
-
-#ifndef __CYGWIN__
-       char *buf;
-       buf = fgetln(fp, &len);
-#else
-       char buf[512];
-       fgets(buf, sizeof(buf), fp);    
-       len = strlen(buf);
-#endif
-       if (buf == NULL)
-               return (-1);
-
-       /* Assumes realloc() accepts NULL for ptr (C99) */
-       if (*outbuf == NULL || *outsize < len + 1) {
-               void *tmp = realloc(*outbuf, len + 1);
-               if (tmp == NULL)
-                       return (-1);
-               *outbuf = tmp;
-               *outsize = len + 1;
-       }
-       memcpy(*outbuf, buf, len);
-       (*outbuf)[len] = '\0';
-       return (len);
-}
-#endif
index 9e920bcb43b319726f2bc05ed8924d0122181fe7..7b4a91a73dee09b0c3cb005f953970d5ea658bf4 100644 (file)
@@ -19,7 +19,7 @@ include $(INCLUDE_DIR)/host-build.mk
 HOST_CFLAGS += -I$(STAGING_DIR_HOST)/include/e2fsprogs
 CFLAGS := $(HOST_CFLAGS) -I$(HOST_BUILD_DIR)/include -L$(HOST_BUILD_DIR) -L$(STAGING_DIR_HOST)/lib -DNO_NATIVE_SUPPORT
 ifneq ($(HOST_OS),Linux)
 HOST_CFLAGS += -I$(STAGING_DIR_HOST)/include/e2fsprogs
 CFLAGS := $(HOST_CFLAGS) -I$(HOST_BUILD_DIR)/include -L$(HOST_BUILD_DIR) -L$(STAGING_DIR_HOST)/lib -DNO_NATIVE_SUPPORT
 ifneq ($(HOST_OS),Linux)
-CFLAGS += -Dloff_t=off_t -D__BYTE_ORDER=BYTE_ORDER -include getline.h -include endian.h -I$(CURDIR)/include -include fls.h
+CFLAGS += -Dloff_t=off_t -D__BYTE_ORDER=BYTE_ORDER -include endian.h -I$(CURDIR)/include -include fls.h
 MTD_STATIC := 0
 else
 MTD_STATIC := 1
 MTD_STATIC := 0
 else
 MTD_STATIC := 1