dropbear: Make utmp and putuline support configurable via seperate config options
authorHans Dedecker <dedeckeh@gmail.com>
Wed, 27 Apr 2016 09:13:58 +0000 (11:13 +0200)
committerJo-Philipp Wich <jo@mein.io>
Thu, 28 Apr 2016 11:47:48 +0000 (13:47 +0200)
Utmp support tracks who is currenlty logged in by logging info to the file /var/run/utmp (supported by busybox)
Putuline support will use the utmp structure to write to the utmp file

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
package/network/services/dropbear/Config.in
package/network/services/dropbear/Makefile

index 3316c84e9e5f8d70a5aae11da22bac975e30b2c8..7c2edd79f23708f9ef01c6a62a54073b0c7a33ed 100644 (file)
@@ -32,4 +32,19 @@ config DROPBEAR_ECC
 
                Increases binary size by about 23 kB (MIPS).
 
+config DROPBEAR_UTMP
+       bool "Utmp support"
+       default n
+       depends on BUSYBOX_CONFIG_FEATURE_UTMP
+       help
+               This enables dropbear utmp support, the file /var/run/utmp is used to
+               track who is currently logged in.
+
+config DROPBEAR_PUTUTLINE
+       bool "Pututline support"
+       default n
+       depends on DROPBEAR_UTMP
+       help
+               Dropbear will use pututline() to write the utmp structure into the utmp file.
+
 endmenu
index 39ab04bb54c734489e9c5c42bb7bce1fa0b971b9..593e0a81bf654204903ac435727f71167b0664fd 100644 (file)
@@ -68,12 +68,11 @@ CONFIGURE_ARGS += \
        --enable-syslog \
        $(if $(CONFIG_SHADOW_PASSWORDS),,--disable-shadow) \
        --disable-lastlog \
-       --disable-utmp \
-       --disable-utmpx \
+       $(if $(CONFIG_DROPBEAR_UTMP),,--disable-utmp) \
        --disable-wtmp \
        --disable-wtmpx \
        --disable-loginfunc \
-       --disable-pututline \
+       $(if $(CONFIG_DROPBEAR_PUTUTLINE),,--disable-pututline) \
        --disable-pututxline \
        --disable-zlib \
        --enable-bundled-libtom