kernel: tpm: add Infineon i2c support
authorIan Pozella <Ian.Pozella@imgtec.com>
Mon, 6 Mar 2017 14:12:36 +0000 (14:12 +0000)
committerJohn Crispin <john@phrozen.org>
Mon, 13 Mar 2017 13:20:47 +0000 (14:20 +0100)
(based on openwrt "kernel: add tpm support")

Signed-off-by: Ian Pozella <Ian.Pozella@imgtec.com>
package/kernel/linux/modules/other.mk

index 40869c6bb0d8a2daef51d42d2e728ed7980288c2..8ea435ed8481734890f0e6c9e05bfa5eca69fa9d 100644 (file)
@@ -1003,3 +1003,18 @@ define KernelPackage/tpm-i2c-atmel/description
 endef
 
 $(eval $(call KernelPackage,tpm-i2c-atmel))
+
+define KernelPackage/tpm-i2c-infineon
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:= TPM I2C Infineon driver
+  DEPENDS:= +kmod-tpm +kmod-i2c-core
+  KCONFIG:= CONFIG_TCG_TIS_I2C_INFINEON
+  FILES:= $(LINUX_DIR)/drivers/char/tpm/tpm_i2c_infineon.ko
+  AUTOLOAD:= $(call AutoLoad,40,tpm_i2c_infineon,1)
+endef
+
+define KernelPackage/tpm-i2c-infineon/description
+       This enables the TPM Interface Specification 1.2 Interface (I2C - Infineon)
+endef
+
+$(eval $(call KernelPackage,tpm-i2c-infineon))