firewall3: update to git head
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 21 Feb 2013 22:33:44 +0000 (22:33 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 21 Feb 2013 22:33:44 +0000 (22:33 +0000)
- all uci rules are boxed in custom chains now, so a firewall stop leaves user rules intact
- properly handle selective ipv4 or ipv6 only firewall start/stop/restart actions
- support ip ranges (e.g. option src_ip '!192.168.1.1-192.168.1.100' -> -m iprange ! --src-range 192.168.1.1-192.168.1.100')
- support time options (e.g. option weekdays 'Mon Tue Sat' -> -m time --weekdays 1,2,6')

SVN-Revision: 35738

package/network/config/firewall3/Makefile
package/network/config/firewall3/files/firewall.init

index 063e554677ae29403f2dc092127fdb54a73add7c..5282613d65920e68dc429d6f56957a258f97d791 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=firewall3
-PKG_VERSION:=2013-02-17
+PKG_VERSION:=2013-02-21
 PKG_RELEASE:=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/firewall3.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=a32e331a11034403df2e26807df9195435b6fb8a
+PKG_SOURCE_VERSION:=fe3ecee341da8542aa25b962dcb8bcc628fcdd1e
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
 
index bddbadd880a0c4c74419ad3fd4342154f1434300..8c1dbd94caf6708a89212d5835bbe7c7429f8be6 100755 (executable)
@@ -15,3 +15,7 @@ start() {
 stop() {
        fw3 stop
 }
+
+restart() {
+       fw3 restart
+}