ar71xx: TL-WR1043ND support cleanup
authorGabor Juhos <juhosg@openwrt.org>
Tue, 8 Dec 2009 12:46:30 +0000 (12:46 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 8 Dec 2009 12:46:30 +0000 (12:46 +0000)
SVN-Revision: 18697

target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-2.6.28
target/linux/ar71xx/config-2.6.32
target/linux/ar71xx/files/arch/mips/ar71xx/mach-tl-wr1043nd.c
target/linux/ar71xx/files/arch/mips/include/asm/mach-ar71xx/ar71xx.h
target/linux/ar71xx/profiles/tp-link.mk
tools/firmware-utils/src/mktplinkfw.c

index 9178b0a9e6e4b466d0cc7a004223a3cae09e9220..3a640fa4b3a919d2d43b6b7aa6d0b89bdd4913f7 100755 (executable)
@@ -63,6 +63,9 @@ get_status_led() {
        tew-632brp)
                status_led="tew-632brp:green:status"
                ;;
+       tl-wr1043nd)
+               status_led="tl-wr1043nd:green:system"
+               ;;
        tl-wr741nd)
                status_led="tl-wr741nd:green:system"
                ;;
index 1c2e060067be1fd17bb68d0b22fd978f70f0f1ba..9eea471b3225ffdadeed2fe42cd553d1d0a778a1 100755 (executable)
@@ -67,6 +67,9 @@ ar71xx_board_name() {
        *TEW-632BRP)
                name="tew-632brp"
                ;;
+       *TL-WR1043ND)
+               name="tl-wr1043nd"
+               ;;
        *TL-WR741ND)
                name="tl-wr741nd"
                ;;
index b7e003a81d478dfd7a7b9bee46dda07daa0b0b65..728019969b49bc37e8a33682bd8b39a2a7022c76 100755 (executable)
@@ -75,7 +75,7 @@ platform_check_image() {
                }
                return 0
                ;;
-       tl-wr741nd | tl-wr941nd)
+       tl-wr741nd | tl-wr941nd | tl-wr1043nd)
                [ "$magic" != "0100" ] && {
                        echo "Invalid image type."
                        return 1
index 83587906eeb72db6495c6995f1483ed83949b837..fc17341d5dc1019b722a0f3ed6365bfa727cdb8c 100644 (file)
@@ -15,6 +15,7 @@ CONFIG_AR71XX_MACH_PB42=y
 CONFIG_AR71XX_MACH_PB44=y
 CONFIG_AR71XX_MACH_RB_4XX=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
+CONFIG_AR71XX_MACH_TL_WR1043ND=y
 CONFIG_AR71XX_MACH_TL_WR741ND=y
 CONFIG_AR71XX_MACH_TL_WR941ND=y
 CONFIG_AR71XX_MACH_UBNT=y
index f1a69bc0bc96552a36dd37d799c45699d1372956..671002f8dd75e7b26c044796793c03506f362f77 100644 (file)
@@ -16,6 +16,7 @@ CONFIG_AR71XX_MACH_PB42=y
 CONFIG_AR71XX_MACH_PB44=y
 CONFIG_AR71XX_MACH_RB_4XX=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
+CONFIG_AR71XX_MACH_TL_WR1043ND=y
 CONFIG_AR71XX_MACH_TL_WR741ND=y
 CONFIG_AR71XX_MACH_TL_WR941ND=y
 CONFIG_AR71XX_MACH_UBNT=y
index e67282e6daa84e22e0aae7b1e42eb9eef074bdc5..d4dcd5a33327af00d8eee8a604425cb95bae9c91 100644 (file)
@@ -50,7 +50,7 @@ static struct mtd_partition tl_wr1043nd_partitions[] = {
                .size           = 0x010000,
                .mask_flags     = MTD_WRITEABLE,
        } , {
-               .name           = "firmware",    
+               .name           = "firmware",
                .offset         = 0x020000,
                .size           = 0x7d0000,
        }
@@ -59,8 +59,8 @@ static struct mtd_partition tl_wr1043nd_partitions[] = {
 
 static struct flash_platform_data tl_wr1043nd_flash_data = {
 #ifdef CONFIG_MTD_PARTITIONS
-        .parts          = tl_wr1043nd_partitions,
-        .nr_parts       = ARRAY_SIZE(tl_wr1043nd_partitions),
+       .parts          = tl_wr1043nd_partitions,
+       .nr_parts       = ARRAY_SIZE(tl_wr1043nd_partitions),
 #endif
 };
 
@@ -116,11 +116,11 @@ static void __init tl_wr1043nd_setup(void)
        ar71xx_eth0_data.phy_mask = 0x0;
        ar71xx_eth0_data.speed = SPEED_1000;
        ar71xx_eth0_data.duplex = DUPLEX_FULL;
-       
+
        ar71xx_add_device_eth(0);
-       
+
        ar71xx_add_device_usb();
-       
+
        ar71xx_add_device_spi(NULL, tl_wr1043nd_spi_info,
                                        ARRAY_SIZE(tl_wr1043nd_spi_info));
 
index 575d1819cfc144c2de56796939402c9cee06a19a..48f6e0a654bfc08ea9acec1cb2b445f788da083f 100644 (file)
@@ -139,7 +139,7 @@ enum ar71xx_mach_type {
        AR71XX_MACH_TEW_632BRP, /* TRENDnet TEW-632BRP */
        AR71XX_MACH_TL_WR741ND, /* TP-LINK TL-WR741ND */
        AR71XX_MACH_TL_WR941ND, /* TP-LINK TL-WR941ND */
-       AR71XX_MACH_TL_WR1043ND,/* TP-LINK TL-WR1041ND */
+       AR71XX_MACH_TL_WR1043ND, /* TP-LINK TL-WR1041ND */
        AR71XX_MACH_UBNT_LSSR71, /* Ubiquiti LS-SR71 */
        AR71XX_MACH_UBNT_LSX,   /* Ubiquiti LSX */
        AR71XX_MACH_UBNT_RS,    /* Ubiquiti RouterStation */
index d62ab8a7c61454e3c8e839edff9f50c43128d092..8df005075bc7319c1ea43af4114df447a286583c 100644 (file)
@@ -50,7 +50,7 @@ $(eval $(call Profile,TLWR941NDV2))
 
 define Profile/TLWR1043NDV1
        NAME:=TP-LINK TL-WR1043ND v1
-       PACKAGES:=kmod-ath9k hostapd-mini
+       PACKAGES:=kmod-ath9k hostapd-mini kmod-usb-core kmod-usb2
 endef
 
 define Profile/TLWR1043NDV1/Description
index 08f345e7f51bf48bb719ae211282d4fc8c161680..7bb877cffcf647bfbc27faeed9e34290efd245de 100644 (file)
@@ -37,7 +37,7 @@
 #define HWID_TL_WR841ND_V3     0x08410003
 #define HWID_TL_WR841ND_V5     0x08410005
 #define HWID_TL_WR941ND_V2     0x09410002
-#define HWID_TL_WR1043ND_V1    0x10430001
+#define HWID_TL_WR1043ND_V1    0x10430001
 
 #define MD5SUM_LEN     16