mac80211: switch to upstream owl-loader driver
authorChristian Lamparter <chunkeey@gmail.com>
Sat, 16 Nov 2019 16:08:07 +0000 (17:08 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 30 Nov 2019 12:21:20 +0000 (13:21 +0100)
The Owl Loader (named after the codename that Atheros gave
these devices back in the day) has been accepted upstream.

This patch removes the "misc" driver OpenWrt had and adds
the remaining differences against the version that ships
with 5.4-rc1 into a separate "120-owl-loader-compat.patch"
file that can be cut down once AR71XX is being dealt with.

Note: I decided to keep the existing (kmod-)owl-loader
package name around for now. The kernel module file in
the kmod package will be called ath9k_pci_owl_loader.ko
though.

Acked-by: Hauke Mehrtens <hauke@hauke-m.de>
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
package/kernel/linux/modules/wireless.mk
package/kernel/mac80211/ath.mk
package/kernel/mac80211/patches/ath/101-ath9k-use-iowrite32-over-__raw_writel.patch [new file with mode: 0644]
package/kernel/mac80211/patches/ath/120-owl-loader-compat.patch [new file with mode: 0644]
target/linux/generic/files/drivers/misc/owl-loader.c [deleted file]
target/linux/generic/hack-4.14/835-misc-owl_loader.patch [deleted file]
target/linux/generic/hack-4.19/835-misc-owl_loader.patch [deleted file]
target/linux/generic/hack-4.9/835-misc-owl_loader.patch [deleted file]

index 7b1c6635674b6b9fc1de39a4e173bccdc13b3462..72e2bf477b2f8340e9970c60c97a7ebe5a300dab 100644 (file)
@@ -41,24 +41,3 @@ define KernelPackage/net-rtl8192su/description
 endef
 
 $(eval $(call KernelPackage,net-rtl8192su))
-
-
-define KernelPackage/owl-loader
-  SUBMENU:=$(WIRELESS_MENU)
-  TITLE:=Owl loader for initializing Atheros PCI(e) Wifi chips
-  DEPENDS:=@PCI_SUPPORT
-  KCONFIG:=CONFIG_OWL_LOADER
-  FILES:=$(LINUX_DIR)/drivers/misc/owl-loader.ko
-  AUTOLOAD:=$(call AutoProbe,owl-loader)
-endef
-
-define KernelPackage/owl-loader/description
-  Kernel module that helps to initialize certain Qualcomm
-  Atheros' PCI(e) Wifi chips, which have the init data
-  (which contains the PCI device ID for example) stored
-  together with the calibration data in the file system.
-
-  This is necessary for devices like the Cisco Meraki Z1.
-endef
-
-$(eval $(call KernelPackage,owl-loader))
index 64aac41b4d2ce777f587967ae00a6946ff5bc820..788131b7517b76d819b96a2cee076266a63bf2f5 100644 (file)
@@ -1,6 +1,6 @@
 PKG_DRIVERS += \
        ath ath5k ath6kl ath6kl-sdio ath6kl-usb ath9k ath9k-common ath9k-htc ath10k \
-       carl9170
+       carl9170 owl-loader
 
 PKG_CONFIG_DEPENDS += \
        CONFIG_PACKAGE_ATH_DEBUG \
@@ -38,6 +38,7 @@ config-$(CONFIG_PACKAGE_ATH_SPECTRAL) += ATH9K_COMMON_SPECTRAL ATH10K_SPECTRAL
 config-$(CONFIG_PACKAGE_ATH_DYNACK) += ATH9K_DYNACK
 config-$(call config_package,ath9k) += ATH9K
 config-$(call config_package,ath9k-common) += ATH9K_COMMON
+config-$(call config_package,owl-loader) += ATH9K_PCI_NO_EEPROM
 config-$(CONFIG_TARGET_ar71xx) += ATH9K_AHB
 config-$(CONFIG_TARGET_ath79) += ATH9K_AHB
 config-$(CONFIG_TARGET_ipq40xx) += ATH10K_AHB
@@ -274,3 +275,20 @@ define KernelPackage/carl9170
   FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ath/carl9170/carl9170.ko
   AUTOLOAD:=$(call AutoProbe,carl9170)
 endef
+
+define KernelPackage/owl-loader
+  $(call KernelPackage/mac80211/Default)
+  TITLE:=Owl loader for initializing Atheros PCI(e) Wifi chips
+  DEPENDS:=@PCI_SUPPORT +kmod-ath9k
+  FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath9k/ath9k_pci_owl_loader.ko
+  AUTOLOAD:=$(call AutoProbe,ath9k_pci_owl_loader)
+endef
+
+define KernelPackage/owl-loader/description
+  Kernel module that helps to initialize certain Qualcomm
+  Atheros' PCI(e) Wifi chips, which have the init data
+  (which contains the PCI device ID for example) stored
+  together with the calibration data in the file system.
+
+  This is necessary for devices like the Cisco Meraki Z1.
+endef
diff --git a/package/kernel/mac80211/patches/ath/101-ath9k-use-iowrite32-over-__raw_writel.patch b/package/kernel/mac80211/patches/ath/101-ath9k-use-iowrite32-over-__raw_writel.patch
new file mode 100644 (file)
index 0000000..dade5cf
--- /dev/null
@@ -0,0 +1,40 @@
+From bd8eca2c0f5542c5b20b1c2cc506b8b8a46018df Mon Sep 17 00:00:00 2001
+From: Christian Lamparter <chunkeey@gmail.com>
+Date: Sun, 24 Nov 2019 15:22:55 +0100
+Subject: [PATCH] ath9k: use iowrite32 over __raw_writel
+To: linux-wireless@vger.kernel.org
+Cc: QCA ath9k Development <ath9k-devel@qca.qualcomm.com>,
+    Kalle Valo <kvalo@codeaurora.org>,
+    Hauke Mehrtens <hauke@hauke-m.de>,
+    Mathias Kresin <dev@kresin.me>,
+    Martin Blumenstingl <martin.blumenstingl@googlemail.com>
+
+This patch changes the ath9k_pci_owl_loader to use the
+same iowrite32 memory accessor that ath9k_pci is using
+to communicate with the PCI(e) chip.
+
+This will fix endian issues that came up during testing
+with loaned AVM Fritz!Box 7360 (Lantiq MIPS SoCs + AR9287).
+
+Fixes: 5a4f2040fd07 ("ath9k: add loader for AR92XX (and older) pci(e)")
+Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
+---
+ drivers/net/wireless/ath/ath9k/ath9k_pci_owl_loader.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/drivers/net/wireless/ath/ath9k/ath9k_pci_owl_loader.c b/drivers/net/wireless/ath/ath9k/ath9k_pci_owl_loader.c
+index 956fa7828d0c..56d1a7764b9f 100644
+--- a/drivers/net/wireless/ath/ath9k/ath9k_pci_owl_loader.c
++++ b/drivers/net/wireless/ath/ath9k/ath9k_pci_owl_loader.c
+@@ -83,7 +83,7 @@ static int ath9k_pci_fixup(struct pci_dev *pdev, const u16 *cal_data,
+                       val = swahb32(val);
+               }
+-              __raw_writel(val, mem + reg);
++              iowrite32(val, mem + reg);
+               usleep_range(100, 120);
+       }
+-- 
+2.24.0
+
diff --git a/package/kernel/mac80211/patches/ath/120-owl-loader-compat.patch b/package/kernel/mac80211/patches/ath/120-owl-loader-compat.patch
new file mode 100644 (file)
index 0000000..afd5e3e
--- /dev/null
@@ -0,0 +1,53 @@
+From: Christian Lamparter <chunkeey@gmail.com>
+Date: Sat, 16 Nov 2019 19:25:24 +0100
+Subject: [PATCH] owl_loader: compatibility patch
+
+This patch includes OpenWrt specific changes that are
+not included in the upstream owl-loader.
+
+This includes a platform data handling changes for ar71xx.
+
+Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
+
+--- a/drivers/net/wireless/ath/ath9k/ath9k_pci_owl_loader.c
++++ b/drivers/net/wireless/ath/ath9k/ath9k_pci_owl_loader.c
+@@ -104,6 +104,7 @@
+ {
+       struct pci_dev *pdev = (struct pci_dev *)context;
+       struct owl_ctx *ctx = (struct owl_ctx *)pci_get_drvdata(pdev);
++      struct ath9k_platform_data *pdata = dev_get_platdata(&pdev->dev);
+       struct pci_bus *bus;
+       complete(&ctx->eeprom_load);
+@@ -121,6 +122,16 @@
+               goto release;
+       }
++      if (pdata) {
++              memcpy(pdata->eeprom_data, fw->data, fw->size);
++
++              /*
++               * eeprom has been successfully loaded - pass the data to ath9k
++               * but remove the eeprom_name, so it doesn't try to load it too.
++               */
++              pdata->eeprom_name = NULL;
++      }
++
+       if (ath9k_pci_fixup(pdev, (const u16 *)fw->data, fw->size))
+               goto release;
+@@ -138,8 +149,14 @@
+ static const char *owl_get_eeprom_name(struct pci_dev *pdev)
+ {
+       struct device *dev = &pdev->dev;
++      struct ath9k_platform_data *pdata;
+       char *eeprom_name;
++      /* try the existing platform data first */
++      pdata = dev_get_platdata(dev);
++      if (pdata && pdata->eeprom_name)
++              return pdata->eeprom_name;
++
+       dev_dbg(dev, "using auto-generated eeprom filename\n");
+       eeprom_name = devm_kzalloc(dev, EEPROM_FILENAME_LEN, GFP_KERNEL);
diff --git a/target/linux/generic/files/drivers/misc/owl-loader.c b/target/linux/generic/files/drivers/misc/owl-loader.c
deleted file mode 100644 (file)
index a4e55ad..0000000
+++ /dev/null
@@ -1,246 +0,0 @@
-/*
- * Initialize Owl Emulation Devices
- *
- * Copyright (C) 2016 Christian Lamparter <chunkeey@googlemail.com>
- * Copyright (C) 2016 Martin Blumenstingl <martin.blumenstingl@googlemail.com>
- *
- * This program is free software; you can redistribute it and/or modify it
- * under the terms of the GNU General Public License version 2 as published
- * by the Free Software Foundation.
- *
- * Some devices (like the Cisco Meraki Z1 Cloud Managed Teleworker Gateway)
- * need to be able to initialize the PCIe wifi device. Normally, this is done
- * during the early stages of booting linux, because the necessary init code
- * is read from the memory mapped SPI and passed to pci_enable_ath9k_fixup.
- * However,this isn't possible for devices which have the init code for the
- * Atheros chip stored on NAND. Hence, this module can be used to initialze
- * the chip when the user-space is ready to extract the init code.
- */
-#include <linux/module.h>
-#include <linux/version.h>
-#include <linux/completion.h>
-#include <linux/etherdevice.h>
-#include <linux/firmware.h>
-#include <linux/pci.h>
-#include <linux/delay.h>
-#include <linux/platform_device.h>
-#include <linux/ath9k_platform.h>
-
-struct owl_ctx {
-       struct completion eeprom_load;
-};
-
-#define EEPROM_FILENAME_LEN 100
-
-#define AR5416_EEPROM_MAGIC 0xa55a
-
-static int ath9k_pci_fixup(struct pci_dev *pdev, const u16 *cal_data,
-                          size_t cal_len)
-{
-       void __iomem *mem;
-       const void *cal_end = (void *)cal_data + cal_len;
-       const struct {
-               u16 reg;
-               u16 low_val;
-               u16 high_val;
-       } __packed *data;
-       u16 cmd;
-       u32 bar0;
-       bool swap_needed = false;
-
-       if (*cal_data != AR5416_EEPROM_MAGIC) {
-               if (*cal_data != swab16(AR5416_EEPROM_MAGIC)) {
-                       dev_err(&pdev->dev, "invalid calibration data\n");
-                       return -EINVAL;
-               }
-
-               dev_dbg(&pdev->dev, "calibration data needs swapping\n");
-               swap_needed = true;
-       }
-
-       dev_info(&pdev->dev, "fixup device configuration\n");
-
-       mem = pcim_iomap(pdev, 0, 0);
-       if (!mem) {
-               dev_err(&pdev->dev, "ioremap error\n");
-               return -EINVAL;
-       }
-
-       pci_read_config_dword(pdev, PCI_BASE_ADDRESS_0, &bar0);
-       pci_write_config_dword(pdev, PCI_BASE_ADDRESS_0,
-                              pci_resource_start(pdev, 0));
-       pci_read_config_word(pdev, PCI_COMMAND, &cmd);
-       cmd |= PCI_COMMAND_MASTER | PCI_COMMAND_MEMORY;
-       pci_write_config_word(pdev, PCI_COMMAND, cmd);
-
-       /* set pointer to first reg address */
-       for (data = (const void *) (cal_data + 3);
-            (const void *) data <= cal_end && data->reg != (u16)~0;
-            data++) {
-               u32 val;
-               u16 reg;
-
-               reg = data->reg;
-               val = data->low_val;
-               val |= ((u32)data->high_val) << 16;
-
-               if (swap_needed) {
-                       reg = swab16(reg);
-                       val = swahb32(val);
-               }
-
-#ifdef CONFIG_LANTIQ
-               val = swab32(val);
-#endif
-
-               __raw_writel(val, mem + reg);
-               udelay(100);
-       }
-
-       pci_read_config_word(pdev, PCI_COMMAND, &cmd);
-       cmd &= ~(PCI_COMMAND_MASTER | PCI_COMMAND_MEMORY);
-       pci_write_config_word(pdev, PCI_COMMAND, cmd);
-
-       pci_write_config_dword(pdev, PCI_BASE_ADDRESS_0, bar0);
-       pcim_iounmap(pdev, mem);
-
-       pci_disable_device(pdev);
-
-       return 0;
-}
-
-static void owl_fw_cb(const struct firmware *fw, void *context)
-{
-       struct pci_dev *pdev = (struct pci_dev *) context;
-       struct owl_ctx *ctx = (struct owl_ctx *) pci_get_drvdata(pdev);
-       struct ath9k_platform_data *pdata = dev_get_platdata(&pdev->dev);
-       struct pci_bus *bus;
-
-       complete(&ctx->eeprom_load);
-
-       if (!fw) {
-               dev_err(&pdev->dev, "no eeprom data received.\n");
-               goto release;
-       }
-
-       /* also note that we are doing *u16 operations on the file */
-       if (fw->size > sizeof(pdata->eeprom_data) || fw->size < 0x200 ||
-           (fw->size & 1) == 1) {
-               dev_err(&pdev->dev, "eeprom file has an invalid size.\n");
-               goto release;
-       }
-
-       if (pdata) {
-               memcpy(pdata->eeprom_data, fw->data, fw->size);
-
-               /*
-                * eeprom has been successfully loaded - pass the data to ath9k
-                * but remove the eeprom_name, so it doesn't try to load it too.
-                */
-               pdata->eeprom_name = NULL;
-       }
-
-       if (ath9k_pci_fixup(pdev, (const u16 *) fw->data, fw->size))
-               goto release;
-
-       pci_lock_rescan_remove();
-       bus = pdev->bus;
-       pci_stop_and_remove_bus_device(pdev);
-       /*
-        * the device should come back with the proper
-        * ProductId. But we have to initiate a rescan.
-        */
-       pci_rescan_bus(bus);
-       pci_unlock_rescan_remove();
-
-release:
-       release_firmware(fw);
-}
-
-static const char *owl_get_eeprom_name(struct pci_dev *pdev)
-{
-       struct device *dev = &pdev->dev;
-       struct ath9k_platform_data *pdata;
-       char *eeprom_name;
-
-       /* try the existing platform data first */
-       pdata = dev_get_platdata(dev);
-       if (pdata && pdata->eeprom_name)
-               return pdata->eeprom_name;
-
-       dev_dbg(dev, "using auto-generated eeprom filename\n");
-
-       eeprom_name = devm_kzalloc(dev, EEPROM_FILENAME_LEN, GFP_KERNEL);
-       if (!eeprom_name)
-               return NULL;
-
-       /* this should match the pattern used in ath9k/init.c */
-       scnprintf(eeprom_name, EEPROM_FILENAME_LEN, "ath9k-eeprom-pci-%s.bin",
-                 dev_name(dev));
-
-       return eeprom_name;
-}
-
-static int owl_probe(struct pci_dev *pdev,
-                   const struct pci_device_id *id)
-{
-       struct owl_ctx *ctx;
-       const char *eeprom_name;
-       int err = 0;
-
-       if (pcim_enable_device(pdev))
-               return -EIO;
-
-       pcim_pin_device(pdev);
-
-       eeprom_name = owl_get_eeprom_name(pdev);
-       if (!eeprom_name) {
-               dev_err(&pdev->dev, "no eeprom filename found.\n");
-               return -ENODEV;
-       }
-
-       ctx = kzalloc(sizeof(*ctx), GFP_KERNEL);
-       if (!ctx) {
-               dev_err(&pdev->dev, "failed to alloc device context.\n");
-               return -ENOMEM;
-       }
-       init_completion(&ctx->eeprom_load);
-
-       pci_set_drvdata(pdev, ctx);
-       err = request_firmware_nowait(THIS_MODULE, true, eeprom_name,
-                                     &pdev->dev, GFP_KERNEL, pdev, owl_fw_cb);
-       if (err) {
-               dev_err(&pdev->dev, "failed to request caldata (%d).\n", err);
-               kfree(ctx);
-       }
-       return err;
-}
-
-static void owl_remove(struct pci_dev *pdev)
-{
-       struct owl_ctx *ctx = pci_get_drvdata(pdev);
-
-       if (ctx) {
-               wait_for_completion(&ctx->eeprom_load);
-               pci_set_drvdata(pdev, NULL);
-               kfree(ctx);
-       }
-}
-
-static const struct pci_device_id owl_pci_table[] = {
-       { PCI_VDEVICE(ATHEROS, 0xff1c) }, /* PCIe */
-       { PCI_VDEVICE(ATHEROS, 0xff1d) }, /* PCI */
-       { },
-};
-MODULE_DEVICE_TABLE(pci, owl_pci_table);
-
-static struct pci_driver owl_driver = {
-       .name           = "owl-loader",
-       .id_table       = owl_pci_table,
-       .probe          = owl_probe,
-       .remove         = owl_remove,
-};
-module_pci_driver(owl_driver);
-MODULE_AUTHOR("Christian Lamparter <chunkeey@googlemail.com>");
-MODULE_DESCRIPTION("Initializes Atheros' Owl Emulation devices");
-MODULE_LICENSE("GPL v2");
diff --git a/target/linux/generic/hack-4.14/835-misc-owl_loader.patch b/target/linux/generic/hack-4.14/835-misc-owl_loader.patch
deleted file mode 100644 (file)
index bf7f7d5..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-From dd36f935973d91644449bd9749f6062a2bed821b Mon Sep 17 00:00:00 2001
-From: Christian Lamparter <chunkeey@googlemail.com>
-Date: Fri, 7 Jul 2017 17:26:46 +0200
-Subject: misc: owl-loader for delayed Atheros ath9k fixup
-
-Some devices (like the Cisco Meraki Z1 Cloud Managed Teleworker Gateway)
-need to be able to initialize the PCIe wifi device. Normally, this is done
-during the early stages of booting linux, because the necessary init code
-is read from the memory mapped SPI and passed to pci_enable_ath9k_fixup.
-However,this isn't possible for devices which have the init code for the
-Atheros chip stored on NAND in an UBI volume. Hence, this module can be
-used to initialze the chip when the user-space is ready to extract the
-init code.
-
-Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
-Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
----
- drivers/misc/Kconfig  | 12 ++++++++++++
- drivers/misc/Makefile |  1 +
- 2 files changed, 13 insertions(+)
-
---- a/drivers/misc/Kconfig
-+++ b/drivers/misc/Kconfig
-@@ -151,6 +151,18 @@ config SGI_IOC4
-         If you have an SGI Altix with an IOC4-based card say Y.
-         Otherwise say N.
-+config OWL_LOADER
-+      tristate "Owl loader for initializing Atheros PCI(e) Wifi chips"
-+      depends on PCI
-+      ---help---
-+      This kernel module helps to initialize certain Qualcomm
-+      Atheros' PCI(e) Wifi chips, which have the init data
-+      (which contains the PCI device ID for example) stored
-+      together with the calibration data in the file system.
-+
-+      This is necessary for devices like the Cisco Meraki Z1, say M.
-+      Otherwise say N.
-+
- config TIFM_CORE
-       tristate "TI Flash Media interface support"
-       depends on PCI
---- a/drivers/misc/Makefile
-+++ b/drivers/misc/Makefile
-@@ -13,6 +13,7 @@ obj-$(CONFIG_ATMEL_TCLIB)    += atmel_tclib
- obj-$(CONFIG_DUMMY_IRQ)               += dummy-irq.o
- obj-$(CONFIG_ICS932S401)      += ics932s401.o
- obj-$(CONFIG_LKDTM)           += lkdtm.o
-+obj-$(CONFIG_OWL_LOADER)      += owl-loader.o
- obj-$(CONFIG_TIFM_CORE)               += tifm_core.o
- obj-$(CONFIG_TIFM_7XX1)               += tifm_7xx1.o
- obj-$(CONFIG_PHANTOM)         += phantom.o
diff --git a/target/linux/generic/hack-4.19/835-misc-owl_loader.patch b/target/linux/generic/hack-4.19/835-misc-owl_loader.patch
deleted file mode 100644 (file)
index bf0fa59..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-From dd36f935973d91644449bd9749f6062a2bed821b Mon Sep 17 00:00:00 2001
-From: Christian Lamparter <chunkeey@googlemail.com>
-Date: Fri, 7 Jul 2017 17:26:46 +0200
-Subject: misc: owl-loader for delayed Atheros ath9k fixup
-
-Some devices (like the Cisco Meraki Z1 Cloud Managed Teleworker Gateway)
-need to be able to initialize the PCIe wifi device. Normally, this is done
-during the early stages of booting linux, because the necessary init code
-is read from the memory mapped SPI and passed to pci_enable_ath9k_fixup.
-However,this isn't possible for devices which have the init code for the
-Atheros chip stored on NAND in an UBI volume. Hence, this module can be
-used to initialze the chip when the user-space is ready to extract the
-init code.
-
-Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
-Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
----
- drivers/misc/Kconfig  | 12 ++++++++++++
- drivers/misc/Makefile |  1 +
- 2 files changed, 13 insertions(+)
-
---- a/drivers/misc/Kconfig
-+++ b/drivers/misc/Kconfig
-@@ -164,6 +164,18 @@ config SGI_IOC4
-         If you have an SGI Altix with an IOC4-based card say Y.
-         Otherwise say N.
-+config OWL_LOADER
-+      tristate "Owl loader for initializing Atheros PCI(e) Wifi chips"
-+      depends on PCI
-+      ---help---
-+      This kernel module helps to initialize certain Qualcomm
-+      Atheros' PCI(e) Wifi chips, which have the init data
-+      (which contains the PCI device ID for example) stored
-+      together with the calibration data in the file system.
-+
-+      This is necessary for devices like the Cisco Meraki Z1, say M.
-+      Otherwise say N.
-+
- config TIFM_CORE
-       tristate "TI Flash Media interface support"
-       depends on PCI
---- a/drivers/misc/Makefile
-+++ b/drivers/misc/Makefile
-@@ -14,6 +14,7 @@ obj-$(CONFIG_ATMEL_TCLIB)    += atmel_tclib
- obj-$(CONFIG_DUMMY_IRQ)               += dummy-irq.o
- obj-$(CONFIG_ICS932S401)      += ics932s401.o
- obj-$(CONFIG_LKDTM)           += lkdtm/
-+obj-$(CONFIG_OWL_LOADER)      += owl-loader.o
- obj-$(CONFIG_TIFM_CORE)               += tifm_core.o
- obj-$(CONFIG_TIFM_7XX1)               += tifm_7xx1.o
- obj-$(CONFIG_PHANTOM)         += phantom.o
diff --git a/target/linux/generic/hack-4.9/835-misc-owl_loader.patch b/target/linux/generic/hack-4.9/835-misc-owl_loader.patch
deleted file mode 100644 (file)
index 07cd4e5..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-From dd36f935973d91644449bd9749f6062a2bed821b Mon Sep 17 00:00:00 2001
-From: Christian Lamparter <chunkeey@googlemail.com>
-Date: Fri, 7 Jul 2017 17:26:46 +0200
-Subject: misc: owl-loader for delayed Atheros ath9k fixup
-
-Some devices (like the Cisco Meraki Z1 Cloud Managed Teleworker Gateway)
-need to be able to initialize the PCIe wifi device. Normally, this is done
-during the early stages of booting linux, because the necessary init code
-is read from the memory mapped SPI and passed to pci_enable_ath9k_fixup.
-However,this isn't possible for devices which have the init code for the
-Atheros chip stored on NAND in an UBI volume. Hence, this module can be
-used to initialze the chip when the user-space is ready to extract the
-init code.
-
-Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
-Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
----
- drivers/misc/Kconfig  | 12 ++++++++++++
- drivers/misc/Makefile |  1 +
- 2 files changed, 13 insertions(+)
-
---- a/drivers/misc/Kconfig
-+++ b/drivers/misc/Kconfig
-@@ -151,6 +151,18 @@ config SGI_IOC4
-         If you have an SGI Altix with an IOC4-based card say Y.
-         Otherwise say N.
-+config OWL_LOADER
-+      tristate "Owl loader for initializing Atheros PCI(e) Wifi chips"
-+      depends on PCI
-+      ---help---
-+      This kernel module helps to initialize certain Qualcomm
-+      Atheros' PCI(e) Wifi chips, which have the init data
-+      (which contains the PCI device ID for example) stored
-+      together with the calibration data in the file system.
-+
-+      This is necessary for devices like the Cisco Meraki Z1, say M.
-+      Otherwise say N.
-+
- config TIFM_CORE
-       tristate "TI Flash Media interface support"
-       depends on PCI
---- a/drivers/misc/Makefile
-+++ b/drivers/misc/Makefile
-@@ -12,6 +12,7 @@ obj-$(CONFIG_ATMEL_TCLIB)    += atmel_tclib
- obj-$(CONFIG_DUMMY_IRQ)               += dummy-irq.o
- obj-$(CONFIG_ICS932S401)      += ics932s401.o
- obj-$(CONFIG_LKDTM)           += lkdtm.o
-+obj-$(CONFIG_OWL_LOADER)      += owl-loader.o
- obj-$(CONFIG_TIFM_CORE)               += tifm_core.o
- obj-$(CONFIG_TIFM_7XX1)               += tifm_7xx1.o
- obj-$(CONFIG_PHANTOM)         += phantom.o