ramips: add support for TRENDnet TEW-638APB V2
authorPavlo Samko <bulldozerbsg@gmail.com>
Fri, 9 Jun 2017 11:02:56 +0000 (14:02 +0300)
committerMathias Kresin <dev@kresin.me>
Sat, 17 Jun 2017 13:38:19 +0000 (15:38 +0200)
This patch add support for the TRENDnet TEW-638APB V2.

Specification:
- SoC: Ralink SoC RT3052F
- Flash: 4MB
- RAM: 32MB
- Ethernet: 1x LAN (100 Mbps)
- Wireless: 2.4GHz b/g/n, 2x external antenna
- Buttons: 1x Reset, 1x WPS
- LEDs: Power (green), Ethernet (green), WPS (green and orange),
  Wireless (green)
- UART: 1x UART on PCB (3.3V, GND, RX, TX) - 57600 8N1

Installation

via vendor firmware:
- upload sysupgrade.bin image

via TFTP:
- stop uboot into tftp-load into option "2"
- upload sysupgrade.bin image

Signed-off-by: Pavlo Samko <bulldozerbsg@gmail.com>
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/TEW-638APB-V2.dts [new file with mode: 0644]
target/linux/ramips/image/rt305x.mk

index 3cd7ff60491e4db5f50b1f128e2243f76a816d46..214db9df380bb985cdbb7415bc058195d1b0e71b 100755 (executable)
@@ -276,6 +276,10 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0:lan" "1:lan" "2:lan" "3:lan" "4:wan" "8@eth0"
                ;;
+       tew-638apb-v2)
+               ucidef_add_switch "switch0" \
+                       "4:lan" "6@eth0"
+               ;;
        tew-691gr|\
        tew-692gr|\
        wlr-6000)
index 26d7f627cd2fa68879107a33bf7df5a02b946c15..4c8f709efb7c1ccad616a969f412051c96ebbef2 100644 (file)
@@ -212,6 +212,7 @@ get_status_led() {
                ;;
        mzk-ex300np|\
        rt-n10-plus|\
+       tew-638apb-v2|\
        tew-691gr|\
        tew-692gr|\
        ur-326n4g|\
index c8865fc2989a7ef0ebf007062d3db4a0d4b69d63..e146d1c4767d79711abd127d13c24e78055d3167 100755 (executable)
@@ -472,6 +472,9 @@ ramips_board_detect() {
        *"SL-R7205"*)
                name="sl-r7205"
                ;;
+       *"TEW-638APB v2")
+               name="tew-638apb-v2"
+               ;;
        *"TEW-691GR")
                name="tew-691gr"
                ;;
index dce4c1a327080c681610cee75c92ff03386d423c..07530837d6e6cf20b4948638829d804d22c677f5 100755 (executable)
@@ -139,6 +139,7 @@ platform_check_image() {
        sap-g3200u3|\
        sk-wb8|\
        sl-r7205|\
+       tew-638apb-v2|\
        tew-691gr|\
        tew-692gr|\
        tew-714tru|\
diff --git a/target/linux/ramips/dts/TEW-638APB-V2.dts b/target/linux/ramips/dts/TEW-638APB-V2.dts
new file mode 100644 (file)
index 0000000..3c9b129
--- /dev/null
@@ -0,0 +1,97 @@
+/dts-v1/;
+
+#include "rt3050.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "trendnet,tew-638apb-v2", "ralink,rt3050-soc";
+       model = "TRENDnet TEW-638APB v2";
+
+       cfi@1f000000 {
+               compatible = "cfi-flash";
+               reg = <0x1f000000 0x400000>;
+               bank-width = <2>;
+               device-width = <2>;
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+
+               partition@30000 {
+                       label = "u-boot-env";
+                       reg = <0x30000 0x10000>;
+                       read-only;
+               };
+
+               factory: partition@40000 {
+                       label = "factory";
+                       reg = <0x40000 0x10000>;
+                       read-only;
+               };
+
+               partition@50000 {
+                       label = "firmware";
+                       reg = <0x50000 0x3b0000>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 10 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio0 0 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_WPS_BUTTON>;
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               wps {
+                       label = "tew-638apb-v2:orange:wps";
+                       gpios = <&gpio0 11 GPIO_ACTIVE_LOW>;
+               };
+
+               wps2 {
+                       label = "tew-638apb-v2:green:wps";
+                       gpios = <&gpio0 14 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "uartf";
+                       ralink,function = "gpio";
+               };
+       };
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0x4>;
+};
+
+&esw {
+       mediatek,portmap = <0x2f>;
+};
+
+&wmac {
+       ralink,mtd-eeprom = <&factory 0>;
+};
index dc09765c7cac576ebc6a15036a4411124b0f4b73..628b84b2fd767975376baaf1b07c0f4f53dddc88 100644 (file)
@@ -651,6 +651,16 @@ define Device/sl-r7205
 endef
 TARGET_DEVICES += sl-r7205
 
+define Device/tew-638apb-v2
+  DTS := TEW-638APB-V2
+  BLOCKSIZE := 64k
+  IMAGE_SIZE := $(ralink_default_fw_size_4M)
+  IMAGE/sysupgrade.bin := $$(sysupgrade_bin) | umedia-header 0x026382 | \
+        append-metadata | check-size $$$$(IMAGE_SIZE)
+  DEVICE_TITLE := TRENDnet TEW-638APB v2
+endef
+TARGET_DEVICES += tew-638apb-v2
+
 define Device/tew-714tru
   DTS := TEW-714TRU
   DEVICE_TITLE := TRENDnet TEW-714TRU