kernel: add kmod-usb-net-pl package
authorRoman Spychała <roed@onet.eu>
Tue, 25 Apr 2017 11:07:37 +0000 (13:07 +0200)
committerJohn Crispin <john@phrozen.org>
Thu, 25 May 2017 07:22:42 +0000 (09:22 +0200)
Kernel support for Prolific PL-2301/2302/25A1 based cables

Signed-off-by: Roman Spychała <roed@onet.eu>
package/kernel/linux/modules/usb.mk

index b0375dcb612bc7ed12364117b1b9574e997dae23..ee5b954381397550aa09a8630bdbe419a73ae00a 100644 (file)
@@ -1322,6 +1322,19 @@ endef
 
 $(eval $(call KernelPackage,usb-net-kalmia))
 
+define KernelPackage/usb-net-pl
+  TITLE:=Prolific PL-2301/2302/25A1 based cables
+  KCONFIG:=CONFIG_USB_NET_PLUSB
+  FILES:=$(LINUX_DIR)/drivers/net/usb/plusb.ko
+  AUTOLOAD:=$(call AutoProbe,plusb)
+  $(call AddDepends/usb-net)
+endef
+
+define KernelPackage/usb-net-pl/description
+ Kernel support for Prolific PL-2301/2302/25A1 based cables
+endef
+
+$(eval $(call KernelPackage,usb-net-pl))
 
 define KernelPackage/usb-hid
   TITLE:=Support for USB Human Input Devices