ead: fix compile errors with recent kernels
authorFelix Fietkau <nbd@openwrt.org>
Sat, 20 Jul 2013 12:56:07 +0000 (12:56 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 20 Jul 2013 12:56:07 +0000 (12:56 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 37482

package/network/services/ead/Makefile
package/network/services/ead/src/libbridge.h

index 5633a315a119b063a1bd69c1400d074ffb7706a2..a3bfb1c077e8903112a53284cc98947deb3a9217 100644 (file)
@@ -33,7 +33,6 @@ endef
 CONFIGURE_PATH = tinysrp
 
 TARGET_CFLAGS += \
-       -I$(LINUX_DIR)/include \
        -I$(PKG_BUILD_DIR) \
        -I$(PKG_BUILD_DIR)/tinysrp \
        $(TARGET_CPPFLAGS)
index 6b70e46f6d976d0d8b7c33c9c4a821b8047a96d5..13c8c64c62b28e2b0f7b5b6ed48d7c1d7cd9057a 100644 (file)
@@ -21,6 +21,7 @@
 
 #include <sys/socket.h>
 #include <linux/if.h>
+#include <linux/in6.h>
 #include <linux/if_bridge.h>
 
 /* defined in net/if.h but that conflicts with linux/if.h... */