kernel: update linux 3.6 to 3.6.4
authorGabor Juhos <juhosg@openwrt.org>
Sun, 28 Oct 2012 18:59:39 +0000 (18:59 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 28 Oct 2012 18:59:39 +0000 (18:59 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 33982

include/kernel-version.mk
target/linux/generic/patches-3.6/643-bridge_remove_ipv6_dependency.patch
target/linux/generic/patches-3.6/653-disable_netlink_trim.patch
target/linux/generic/patches-3.6/655-increase_skb_pad.patch
target/linux/generic/patches-3.6/721-phy_packets.patch

index e7e52192d14be38a0d439417486be141217d5c21..378d100a6acec91f990b41e17e12aaa709ffbba5 100644 (file)
@@ -41,8 +41,8 @@ endif
 ifeq ($(LINUX_VERSION),3.3.8)
   LINUX_KERNEL_MD5SUM:=21068f0fd262b9b3670947f7892e1d6b
 endif
-ifeq ($(LINUX_VERSION),3.6.3)
-  LINUX_KERNEL_MD5SUM:=d4892b696956e5ce7b84464d721b6565
+ifeq ($(LINUX_VERSION),3.6.4)
+  LINUX_KERNEL_MD5SUM:=a9ef3e479b47ef31d5a6c71a49aacf52
 endif
 
 # disable the md5sum check for unknown kernel versions
index 035bbf8bc5fe9e14a8d0212ed5ce864651a14618..5bf629b5e4617a34b9fb9bfed97ceed8f8053537 100644 (file)
@@ -49,7 +49,7 @@
  
  int ipv6_get_lladdr(struct net_device *dev, struct in6_addr *addr,
                    unsigned char banned_flags)
-@@ -4808,6 +4807,9 @@ int __init addrconf_init(void)
+@@ -4811,6 +4810,9 @@ int __init addrconf_init(void)
  
        ipv6_addr_label_rtnl_register();
  
@@ -59,7 +59,7 @@
        return 0;
  errout:
        rtnl_af_unregister(&inet6_ops);
-@@ -4826,6 +4828,9 @@ void addrconf_cleanup(void)
+@@ -4829,6 +4831,9 @@ void addrconf_cleanup(void)
        struct net_device *dev;
        int i;
  
index bfd297b12d808d439ee98ad4cb6e929e1e824f94..274d0d2f8e8f252faf1277ecba613a138d3abe2c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/netlink/af_netlink.c
 +++ b/net/netlink/af_netlink.c
-@@ -880,25 +880,7 @@ void netlink_detachskb(struct sock *sk,
+@@ -882,25 +882,7 @@ void netlink_detachskb(struct sock *sk,
  
  static struct sk_buff *netlink_trim(struct sk_buff *skb, gfp_t allocation)
  {
index 69b259f95eaf90810ca6e3045227ce5d6bfb2b9d..c67a6a479769d1dca3d8011d459a428b8fe3461b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -1626,7 +1626,7 @@ static inline int pskb_network_may_pull(
+@@ -1623,7 +1623,7 @@ static inline int pskb_network_may_pull(
   * NET_IP_ALIGN(2) + ethernet_header(14) + IP_header(20/40) + ports(8)
   */
  #ifndef NET_SKB_PAD
index e8578de57a3e4c4015a506f2f84c479cd364a643..3a0fdc95b36938d7374879da44156e24fe4b0afb 100644 (file)
@@ -34,7 +34,7 @@
  #define IF_GET_IFACE  0x0001          /* for querying only */
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -1656,6 +1656,10 @@ static inline int pskb_trim(struct sk_bu
+@@ -1653,6 +1653,10 @@ static inline int pskb_trim(struct sk_bu
        return (len < skb->len) ? __pskb_trim(skb, len) : 0;
  }
  
@@ -45,7 +45,7 @@
  /**
   *    pskb_trim_unique - remove end from a paged unique (not cloned) buffer
   *    @skb: buffer to alter
-@@ -1758,16 +1762,6 @@ static inline struct sk_buff *dev_alloc_
+@@ -1755,16 +1759,6 @@ static inline struct sk_buff *dev_alloc_
  }