uclibc++: only disable SSP for ppc
authorSteven Barth <cyrus@openwrt.org>
Fri, 19 Jun 2015 14:36:37 +0000 (14:36 +0000)
committerSteven Barth <cyrus@openwrt.org>
Fri, 19 Jun 2015 14:36:37 +0000 (14:36 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
SVN-Revision: 46067

package/libs/uclibc++/Makefile

index a726a1edad52c34cf88b6075555c85f0da3bdfd2..8374db5322c0c572a7174359ab5c3b64e7261f39 100644 (file)
@@ -44,7 +44,11 @@ UCLIBC_TARGET_ARCH:=$(shell echo $(ARCH) | sed -e s'/-.*//' \
        -e 's/mipsel.*/mips/' \
 )
 
-TARGET_CFLAGS += $(FPIC) -fno-stack-protector
+ifeq ($(ARCH),powerpc)
+TARGET_CFLAGS += -fno-stack-protector
+endif
+
+TARGET_CFLAGS += $(FPIC)
 
 ifneq ($(CONFIG_CCACHE),)
 TARGET_CXX=$(TARGET_CXX_NOCACHE)