ar71xx: Add support to Powerline ac TP-Link WPA8630
authorHenryk Heisig <hyniu@o2.pl>
Sun, 30 Oct 2016 16:57:27 +0000 (17:57 +0100)
committerJohn Crispin <john@phrozen.org>
Mon, 31 Oct 2016 16:13:37 +0000 (17:13 +0100)
Signed-off-by: Henryk Heisig <hyniu@o2.pl>
12 files changed:
target/linux/ar71xx/base-files/etc/board.d/01_leds
target/linux/ar71xx/base-files/etc/board.d/02_network
target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-4.4
target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
target/linux/ar71xx/files/arch/mips/ath79/Makefile
target/linux/ar71xx/files/arch/mips/ath79/mach-wpa8630.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
target/linux/ar71xx/image/tp-link.mk

index a32ca9101e4a9602ab3d1560b07efeeab338e6ba..01308b5f57c89b1c5d16712103a10f108ee0cda1 100755 (executable)
@@ -638,6 +638,11 @@ wnr612-v2)
        ucidef_set_led_switch "lan1" "LAN1" "netgear:green:lan1" "switch0" "0x02" "0x0f"
        ucidef_set_led_switch "lan2" "LAN2" "netgear:green:lan2" "switch0" "0x04" "0x0f"
        ;;
+wpa8630)
+       ucidef_set_led_netdev "wlan5" "WLAN5" "$board:green:wlan5" "wlan0"
+       ucidef_set_led_netdev "wlan" "WLAN" "$board:green:wlan" "wlan1"
+       ucidef_set_led_netdev "lan" "LAN" "$board:green:lan" "eth0"
+       ;;
 wpn824n)
        ucidef_set_led_netdev "wan-amber" "WAN (amber)" "netgear:amber:wan" "eth0"
        ucidef_set_led_wlan "wlan" "WLAN" "netgear:blue:wlan" "phy0tpt"
index ab7404d4f3230ed98dce61c135750bf5a8d66769..e6489af8766faa0193509d10945f12c1b5fe6b55 100755 (executable)
@@ -398,6 +398,10 @@ ar71xx_setup_interfaces()
                ucidef_add_switch_port_attr "switch0" 2 led 9
                ucidef_add_switch_port_attr "switch0" 5 led 2
                ;;
+       wpa8630)
+               ucidef_add_switch "switch0" \
+                       "0@eth0" "2:lan:3" "3:lan:2" "4:lan:1" "5:lan:4"
+               ;;
        wpj344)
                ucidef_add_switch "switch0" \
                        "0@eth0" "3:lan" "2:wan"
index 475cb803971a5fc003d089bd91273d75ba8a5f37..8b038e47eefc0e9d78a2739168bc24fe79c5a8be 100644 (file)
@@ -43,7 +43,8 @@ get_status_led() {
        ap83|\
        mr12|\
        mr16|\
-       nbg6616)
+       nbg6616|\
+       wpa8630)
                status_led="$board:green:power"
                ;;
        ap96)
index 5a48b06a3654f526a15039cff916789823e04b6c..c95cfb9ec4d013ff035047400d39f25f720ef3c3 100644 (file)
@@ -90,6 +90,10 @@ case "$FIRMWARE" in
        unifiac-pro)
                ath10kcal_extract "EEPROM" 20480 2116
                ;;
+       wpa8630)
+               ath10kcal_extract "ART" 20480 2116
+               ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +1)
+               ;;
        esac
        ;;
 "ath10k/cal-pci-0000:01:00.0.bin")
index f51d7db9c1b3623a6cafe59d1f39cfb6fb82ab69..d7c4131f7bb10643b4dc660981b9f2e7943a4bcb 100755 (executable)
@@ -1129,6 +1129,9 @@ ar71xx_board_detect() {
        *"WNR1000 V2")
                name="wnr1000-v2"
                ;;
+       *WPA8630)
+               name="wpa8630"
+               ;;
        *WPN824N)
                name="wpn824n"
                ;;
index 9c0f3f3bc57d05d6e8c273b55a3fff768947bc81..3c7976d6bf387266c3ea4134cefee79e1685ac10 100755 (executable)
@@ -386,7 +386,8 @@ platform_check_image() {
        tl-wr842n-v3|\
        tl-wr941nd-v5|\
        tl-wr941nd-v6|\
-       tl-wr941nd)
+       tl-wr941nd|\
+       wpa8630)
                local magic_ver="0100"
 
                case "$board" in
index 4e3f5a4beb86872d755511f7de65698e9ac9cf94..64c3604371f1e163626325a55495174c4a597f1f 100644 (file)
@@ -194,6 +194,7 @@ CONFIG_ATH79_MACH_WNR2000_V3=y
 CONFIG_ATH79_MACH_WNR2000_V4=y
 CONFIG_ATH79_MACH_WNR2200=y
 CONFIG_ATH79_MACH_WP543=y
+CONFIG_ATH79_MACH_WPA8630=y
 CONFIG_ATH79_MACH_WPE72=y
 CONFIG_ATH79_MACH_WPJ342=y
 CONFIG_ATH79_MACH_WPJ344=y
index 86df292dd867064a3183ee332a8ba20c52ad0362..60f6d9a978387cc3841cea5ad79fab70645d003c 100644 (file)
@@ -1707,3 +1707,14 @@ config ATH79_MACH_DAP_2695_A1
        select ATH79_DEV_LEDS_GPIO
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
+
+config ATH79_MACH_WPA8630
+       bool "TP-Link WPA8630 support"
+       select SOC_QCA956X
+       select ATH79_DEV_AP9X_PCI if PCI
+       select ATH79_DEV_ETH
+       select ATH79_DEV_GPIO_BUTTONS
+       select ATH79_DEV_LEDS_GPIO
+       select ATH79_DEV_M25P80
+       select ATH79_DEV_WMAC
+
index 4b927bcc3b55fd47c88502de75b503f9535e8926..cbfd7a450664014396ce58f54929c63a33a0e547 100644 (file)
@@ -200,6 +200,7 @@ obj-$(CONFIG_ATH79_MACH_WNR2000_V3)         += mach-wnr2000-v3.o
 obj-$(CONFIG_ATH79_MACH_WNR2000_V4)            += mach-wnr2000-v4.o
 obj-$(CONFIG_ATH79_MACH_WNR2200)               += mach-wnr2200.o
 obj-$(CONFIG_ATH79_MACH_WP543)                 += mach-wp543.o
+obj-$(CONFIG_ATH79_MACH_WPA8630)               += mach-wpa8630.o
 obj-$(CONFIG_ATH79_MACH_WPE72)                 += mach-wpe72.o
 obj-$(CONFIG_ATH79_MACH_WPJ342)                        += mach-wpj342.o
 obj-$(CONFIG_ATH79_MACH_WPJ344)                        += mach-wpj344.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-wpa8630.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-wpa8630.c
new file mode 100644 (file)
index 0000000..d86adaf
--- /dev/null
@@ -0,0 +1,164 @@
+/*
+ *  TP-Link WPA8630 board support
+ *
+ *  Copyright (C) 2016 Henryk Heisig <hyniu@o2.pl>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+#include <linux/platform_device.h>
+#include <linux/ath9k_platform.h>
+#include <linux/ar8216_platform.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-m25p80.h"
+#include "machtypes.h"
+#include "pci.h"
+#include "dev-ap9x-pci.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-spi.h"
+#include "dev-wmac.h"
+
+#define WPA8630_KEYS_POLL_INTERVAL     20
+#define WPA8630_KEYS_DEBOUNCE_INTERVAL (3 * WPA8630_KEYS_POLL_INTERVAL)
+
+#define WPA8630_GPIO_LED_POWER         1
+#define WPA8630_GPIO_LED_LAN           5
+#define WPA8630_GPIO_LED_WLAN          19
+#define WPA8630_GPIO_LED_WLAN5         21
+
+#define WPA8630_GPIO_BTN_RESET         2
+#define WPA8630_GPIO_BTN_RFKILL                8
+#define WPA8630_GPIO_BTN_0             6
+#define WPA8630_GPIO_BTN_1             7
+
+#define WPA8630_MAC0_OFFSET            0x0000
+#define WPA8630_WMAC_CALDATA_OFFSET    0x1000
+#define WPA8630_PCI_CALDATA_OFFSET     0x5000
+
+static struct flash_platform_data wpa8630_flash_data = {
+       .type = "s25fl064k",
+};
+
+static struct gpio_led wpa8630_leds_gpio[] __initdata = {
+       {
+               .name           = "wpa8630:green:power",
+               .gpio           = WPA8630_GPIO_LED_POWER,
+               .active_low     = 1,
+       },
+       {
+               .name           = "wpa8630:green:lan",
+               .gpio           = WPA8630_GPIO_LED_LAN,
+               .active_low     = 1,
+       },
+       {
+               .name           = "wpa8630:green:wlan",
+               .gpio           = WPA8630_GPIO_LED_WLAN,
+               .active_low     = 1,
+       },
+       {
+               .name           = "wpa8630:green:wlan5",
+               .gpio           = WPA8630_GPIO_LED_WLAN5,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button wpa8630_gpio_keys[] __initdata = {
+       {
+               .desc                   = "Reset button",
+               .type                   = EV_KEY,
+               .code                   = KEY_RESTART,
+               .debounce_interval      = WPA8630_KEYS_DEBOUNCE_INTERVAL,
+               .gpio                   = WPA8630_GPIO_BTN_RESET,
+               .active_low             = 1,
+       },
+       {
+               .desc                   = "RFKILL button",
+               .type                   = EV_KEY,
+               .code                   = KEY_RFKILL,
+               .debounce_interval      = WPA8630_KEYS_DEBOUNCE_INTERVAL,
+               .gpio                   = WPA8630_GPIO_BTN_RFKILL,
+               .active_low             = 1,
+       },
+       {
+               .desc                   = "LED",
+               .type                   = EV_KEY,
+               .debounce_interval      = WPA8630_KEYS_DEBOUNCE_INTERVAL,
+               .gpio                   = WPA8630_GPIO_BTN_0,
+               .active_low             = 1,
+       },
+       {
+               .desc                   = "Pair",
+               .type                   = EV_KEY,
+               .debounce_interval      = WPA8630_KEYS_DEBOUNCE_INTERVAL,
+               .gpio                   = WPA8630_GPIO_BTN_1,
+               .active_low             = 1,
+       },
+};
+
+/* GMAC0 of the QCA8337 switch is connected to the QCA9563 SoC via SGMII */
+static struct ar8327_pad_cfg wpa8630_qca8337_pad0_cfg = {
+       .mode = AR8327_PAD_MAC_SGMII,
+       .sgmii_delay_en = true,
+};
+
+static struct ar8327_platform_data wpa8630_qca8337_data = {
+       .pad0_cfg = &wpa8630_qca8337_pad0_cfg,
+       .port0_cfg = {
+               .force_link = 1,
+               .speed = AR8327_PORT_SPEED_1000,
+               .duplex = 1,
+               .txpause = 1,
+               .rxpause = 1,
+       },
+};
+
+static struct mdio_board_info wpa8630_mdio0_info[] = {
+       {
+               .bus_id = "ag71xx-mdio.0",
+               .phy_addr = 0,
+               .platform_data = &wpa8630_qca8337_data,
+       },
+};
+
+static void __init wpa8630_setup(void)
+{
+       u8 *mac = (u8 *) KSEG1ADDR(0x1f00fc00);
+       u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+
+       ath79_register_m25p80(&wpa8630_flash_data);
+
+       ath79_init_mac(ath79_eth0_data.mac_addr,
+               art + WPA8630_MAC0_OFFSET, 0);
+
+       platform_device_register(&ath79_mdio0_device);
+
+       mdiobus_register_board_info(wpa8630_mdio0_info,
+                                   ARRAY_SIZE(wpa8630_mdio0_info));
+
+       /* GMAC0 is connected to an AR8337 switch */
+       ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_SGMII;
+       ath79_eth0_data.mii_bus_dev = &ath79_mdio0_device.dev;
+       ath79_eth0_data.phy_mask = ~BIT(4);
+       ath79_init_mac(ath79_eth0_data.mac_addr, mac, 0);
+
+       ath79_register_eth(0);
+
+       ath79_register_wmac(art + WPA8630_WMAC_CALDATA_OFFSET, mac);
+
+       ap91_pci_init(art + WPA8630_PCI_CALDATA_OFFSET, NULL);
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(wpa8630_leds_gpio),
+                               wpa8630_leds_gpio);
+
+       ath79_register_gpio_keys_polled(-1, WPA8630_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(wpa8630_gpio_keys),
+                                       wpa8630_gpio_keys);
+}
+
+MIPS_MACHINE(ATH79_MACH_WPA8630, "WPA8630", "TP-Link WPA8630",
+       wpa8630_setup);
index 1243409159c8571c22bdace25250a06a7f23c540..d252a2bc443c80bdcc1f45fc5a30c57a39bc60f4 100644 (file)
@@ -258,6 +258,7 @@ enum ath79_mach_type {
        ATH79_MACH_WNR2200,                     /* NETGEAR WNR2200 */
        ATH79_MACH_WNR612_V2,                   /* NETGEAR WNR612 v2 */
        ATH79_MACH_WP543,                       /* Compex WP543 */
+       ATH79_MACH_WPA8630,                     /* TP-Link WPA8630 */
        ATH79_MACH_WPE72,                       /* Compex WPE72 */
        ATH79_MACH_WPJ342,                      /* Compex WPJ342 */
        ATH79_MACH_WPJ344,                      /* Compex WPJ344 */
index 58ea1f3556433eaf303380e9baab05603fd6ab60..b494411db755eb1106982c51921f6423991030bb 100644 (file)
@@ -913,3 +913,15 @@ define Device/tl-wa7210n-v2
     CONSOLE := ttyATH0,115200
 endef
 TARGET_DEVICES += tl-wa7210n-v2
+
+define Device/wpa8630
+    $(Device/tplink-8mlzma)
+    DEVICE_TITLE := TP-LINK WPA8630
+    DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca988x
+    BOARDNAME := WPA8630
+    DEVICE_PROFILE := WPA8630
+    TPLINK_HWID := 0x86300001
+    MTDPARTS = spi0.0:64k(u-boot)ro,1280k(kernel),6720k(rootfs),64k(mib0)ro,64k(ART)ro,8000k@0x10000(firmware)
+    IMAGE/sysupgrade.bin := append-rootfs | mktplinkfw sysupgrade -a 0x10000
+endef
+TARGET_DEVICES += wpa8630