ath79: add support for TP-Link WR841N/ND v11
authorJohann Neuhauser <johann@it-neuhauser.de>
Mon, 13 Aug 2018 13:28:51 +0000 (15:28 +0200)
committerMathias Kresin <dev@kresin.me>
Tue, 14 Aug 2018 08:19:37 +0000 (10:19 +0200)
Specification:
- SoC: Atheros AR9533
- Flash: 4 MB
- RAM: 32 MB
- Ethernet: 4x LAN (100M) / 1x WAN (100M)
- WiFi: 2.4G 300M

Flash instruction:
  Flash factory image from stock WebUI.

Signed-off-by: Johann Neuhauser <johann@it-neuhauser.de>
target/linux/ath79/dts/qca9533_tplink_tl-wr841-v11.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9533_tplink_tl-wr841.dtsi
target/linux/ath79/image/tiny-tp-link.mk

diff --git a/target/linux/ath79/dts/qca9533_tplink_tl-wr841-v11.dts b/target/linux/ath79/dts/qca9533_tplink_tl-wr841-v11.dts
new file mode 100644 (file)
index 0000000..7d1cce2
--- /dev/null
@@ -0,0 +1,30 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9533_tplink_tl-wr841.dtsi"
+
+/ {
+       compatible = "tplink,tl-wr841-v11", "qca,qca9533";
+       model = "TP-Link TL-WR841N/ND Version 11";
+
+       aliases {
+               led-status = &system_led;
+       };
+};
+
+&gpio_leds {
+       system_led: system {
+               label = "tp-link:green:system";
+               gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+               default-state = "off";
+       };
+
+       wan_orange {
+               label = "tp-link:orange:wan";
+               gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+               default-state = "off";
+       };
+};
index 4a913a9d769c990c3d085358179b31776a14fc48..3621b7e1e8f5c2a980d15aa24afd65a766f000ae 100644 (file)
@@ -11,7 +11,7 @@
                bootargs = "console=ttyS0,115200n8";
        };
 
-       leds {
+       gpio_leds: leds {
                compatible = "gpio-leds";
 
                wifi {
index 23d875ade5a10e30e7e7d32fcc87c492c65a320f..c1777809fc1b8b88e4eae05b649df13f07cd9216 100644 (file)
@@ -126,6 +126,17 @@ define Device/tplink_tl-wr841-v9
 endef
 TARGET_DEVICES += tplink_tl-wr841-v9
 
+define Device/tplink_tl-wr841-v11
+  $(Device/tplink-4mlzma)
+  ATH_SOC := qca9533
+  DEVICE_TITLE := TP-LINK TL-WR841N/ND v11
+  TPLINK_HWID := 0x08410011
+  IMAGES += factory-us.bin factory-eu.bin
+  IMAGE/factory-us.bin := append-rootfs | mktplinkfw factory -C US
+  IMAGE/factory-eu.bin := append-rootfs | mktplinkfw factory -C EU
+endef
+TARGET_DEVICES += tplink_tl-wr841-v11
+
 define Device/tplink_tl-wr941-v4
   $(Device/tplink-4m)
   ATH_SOC := ar7240