ramips: add support for DLINK DWR-921-C3
authorPawel Dembicki <paweldembicki@gmail.com>
Thu, 22 Mar 2018 20:47:17 +0000 (21:47 +0100)
committerMathias Kresin <dev@kresin.me>
Wed, 4 Apr 2018 06:42:46 +0000 (08:42 +0200)
The DWR-921-C3 Wireless Routers with LTE embedded modem is based on the
MT7620N SoC.

Specification:

  * MediaTek MT7620N (580 Mhz)
  * 64 MB of RAM
  * 16 MB of FLASH
  * 802.11bgn radio
  * 5x 10/100 Mbps Ethernet (1 WAN and 4 LAN)
  * 2x external, detachable (LTE) antennas
  * UART header on PCB (57600 8n1)
  * 6x LED (GPIO-controlled)
  * 1x bi-color Signal Strength LED (GPIO-controlled)
  * 2x button
  * JBOOT bootloader

Installation:
Apply factory image via d-link http web-gui.

How to revert to OEM firmware:
1.) Push the reset button and turn on the power. Wait until LED start
    blinking (~10sec.)
2.) Upload original factory image via JBOOT http (IP: 192.168.123.254)
3.) If http doesn't work, it can be done with curl command:
    curl -F FN=@XXXXX.bin http://192.168.123.254/upg
    where XXXXX.bin is name of firmware file.

Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
target/linux/ramips/image/mt7620.mk

index 185a081c906ce6cf97e9b39cc3f0d5481aab3a41..75cd8184e2c52f475aabbce5a270a67db2ed8694 100644 (file)
@@ -178,6 +178,14 @@ define Device/dlink_dwr-921-c1
 endef
 TARGET_DEVICES += dlink_dwr-921-c1
 
+define Device/dlink_dwr-921-c3
+  $(Device/dlink_dwr-921-c1)
+  DEVICE_TITLE := D-Link DWR-921 C3
+  DLINK_ROM_ID := DLK6E2414009
+  SUPPORTED_DEVICES := dlink,dwr-921-c1
+endef
+TARGET_DEVICES += dlink_dwr-921-c3
+
 define Device/e1700
   DTS := E1700
   IMAGES += factory.bin