kernel: Fix F2FS module dependencies
authorShane Peelar <lookatyouhacker@gmail.com>
Fri, 24 Mar 2017 15:49:45 +0000 (11:49 -0400)
committerJohn Crispin <john@phrozen.org>
Mon, 27 Mar 2017 06:11:20 +0000 (08:11 +0200)
F2FS depends on the crc32_generic module (NOT crc32c_generic)

Signed-off-by: Shane Peelar <lookatyouhacker@gmail.com>
package/kernel/linux/modules/fs.mk

index 4d69d9b1408da1d09fd80d6c77fb70f026d0b0ba..610d1b58a1ae453409eea2704c5037074f86c4ae 100644 (file)
@@ -200,6 +200,7 @@ $(eval $(call KernelPackage,fs-ext4))
 define KernelPackage/fs-f2fs
   SUBMENU:=$(FS_MENU)
   TITLE:=F2FS filesystem support
+  DEPENDS:= +kmod-crypto-hash +kmod-crypto-crc32
   KCONFIG:= \
        CONFIG_F2FS_FS \
        CONFIG_F2FS_STAT_FS=y \