ar71xx: TL-WA7210n v2 support
authorJohn Crispin <john@openwrt.org>
Tue, 24 Feb 2015 12:00:50 +0000 (12:00 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 24 Feb 2015 12:00:50 +0000 (12:00 +0000)
This patch adds support for TP-Link TL-WA7210n[0]

[0] http://www.tplink.com/en/products/details/?model=TL-WA7210N

Signed-off-by: Hendrik Frenzel <hfrenzel@scunc.net>
SVN-Revision: 44526

target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
target/linux/ar71xx/base-files/etc/uci-defaults/02_network
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-3.18
target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wa7210n-v2.c [new file with mode: 0644]
target/linux/ar71xx/generic/profiles/tp-link.mk
target/linux/ar71xx/image/Makefile
target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
tools/firmware-utils/src/mktplinkfw.c

index a4838d6474f4d9212886678e6eafef0a6fb25b5d..a83a4fc50e59e7990b17f27796a432c73a2cbd05 100644 (file)
@@ -298,6 +298,15 @@ tl-mr3420-v2)
        ucidef_set_led_usbdev "usb" "USB" "tp-link:green:3g" "1-1"
        ;;
 
+tl-wa7210n-v2)
+       ucidef_set_led_netdev "lan" "LAN" "tp-link:green:lan" "eth0"
+       ucidef_set_rssimon "wlan0" "40000" "1"
+       ucidef_set_led_rssi "rssilow" "RSSILOW" "tp-link:green:signal1" "wlan0" "1" "100" "0" "13"
+       ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "tp-link:green:signal2" "wlan0" "26" "100" "-25" "13"
+       ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "tp-link:green:signal3" "wlan0" "51" "100" "-50" "13"
+       ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "tp-link:green:signal4" "wlan0" "76" "100" "-75" "13"
+       ;;
+
 tl-wa750re)
        ucidef_set_led_netdev "lan" "LAN" "tp-link:orange:lan" "eth0"
        ucidef_set_led_wlan "wlan" "WLAN" "tp-link:orange:wlan" "phy0tpt"
index efc212ecc724576167f73be475c41adc8b8bdae0..fdefb5abefd480ede9f748455043a554c14fdc52 100644 (file)
@@ -325,6 +325,7 @@ tl-mr3020 |\
 tl-mr3040 |\
 tl-mr3040-v2 |\
 tl-wa701nd-v2 |\
+tl-wa7210n-v2 |\
 tl-wa750re |\
 tl-wa850re |\
 tl-wa830re-v2 |\
index 6247f86fb084e9ce2fc196f2744e0e4c4e7adad5..52acc6b39edf0a9008248b3f510d6a3673f4a443 100755 (executable)
@@ -130,6 +130,9 @@ tplink_board_detect() {
        "075000"*)
                model="TP-Link TL-WA750RE"
                ;;
+       "721000"*)
+               model="TP-Link TL-WA7210N"
+               ;;
        "751000"*)
                model="TP-Link TL-WA7510N"
                ;;
@@ -651,6 +654,9 @@ ar71xx_board_detect() {
        *"TL-WA701ND v2")
                name="tl-wa701nd-v2"
                ;;
+       *"TL-WA7210N v2")
+               name="tl-wa7210n-v2"
+               ;;
        *TL-WA750RE)
                name="tl-wa750re"
                ;;
index f81c0ff72e2d3feed1291dd2068f199f4256dd6d..15fcf8915f113ed639a260bcd611246ca2a886a6 100755 (executable)
@@ -312,6 +312,7 @@ platform_check_image() {
        tl-mr3420 | \
        tl-mr3420-v2 | \
        tl-wa701nd-v2 | \
+       tl-wa7210n-v2 | \
        tl-wa7510n | \
        tl-wa750re | \
        tl-wa850re | \
index eefbf051707d5f835d4f80272b7b265833f9da1f..9386b4ef940110d76f738532a850ffe3922731da 100644 (file)
@@ -98,6 +98,7 @@ CONFIG_ATH79_MACH_TL_MR13U=y
 CONFIG_ATH79_MACH_TL_MR3020=y
 CONFIG_ATH79_MACH_TL_MR3X20=y
 CONFIG_ATH79_MACH_TL_WA701ND_V2=y
+CONFIG_ATH79_MACH_TL_WA7210N_V2=y
 CONFIG_ATH79_MACH_TL_WA830RE_V2=y
 CONFIG_ATH79_MACH_TL_WA901ND=y
 CONFIG_ATH79_MACH_TL_WA901ND_V2=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wa7210n-v2.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wa7210n-v2.c
new file mode 100644 (file)
index 0000000..276353a
--- /dev/null
@@ -0,0 +1,125 @@
+/*
+ *  TP-LINK TL-WA7210N v2.1 board support
+ *
+ *  Copyright (C) 2011 dongyuqi <729650915@qq.com>
+ *  Copyright (C) 2011-2012 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2014 Nicolas Braud-Santoni <nicolas@braud-santoni.eu>
+ *  Copyright (C) 2014 Alexander List <alex@graz.funkfeuer.at>
+ *  Copyright (C) 2015 Hendrik Frenzel <hfrenzel@scunc.net>
+ *
+ *  rebased on TL-WA7510Nv1 support,
+ *    Copyright (C) 2012 Stefan Helmert <helst_listen@aol.de>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/platform_device.h>
+#include <linux/gpio.h>
+
+#include <asm/mach-ath79/ar71xx_regs.h>
+#include <asm/mach-ath79/ath79.h>
+
+#include "dev-dsa.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+#include "pci.h"
+
+#include "common.h"
+
+#define TL_WA7210N_V2_GPIO_BTN_RESET    11
+#define TL_WA7210N_V2_KEYS_POLL_INT     20
+#define TL_WA7210N_V2_KEYS_DEBOUNCE_INT (3 * TL_WA7210N_V2_KEYS_POLL_INT)
+
+#define TL_WA7210N_V2_GPIO_LED_LAN  17
+#define TL_WA7210N_V2_GPIO_LED_SIG1 0
+#define TL_WA7210N_V2_GPIO_LED_SIG2 1
+#define TL_WA7210N_V2_GPIO_LED_SIG3 27
+#define TL_WA7210N_V2_GPIO_LED_SIG4 26
+
+#define  TL_WA7210N_V2_GPIO_LNA_EN 28
+
+static const char *tl_wa7210n_v2_part_probes[] = {
+       "tp-link",
+       NULL,
+};
+
+static struct gpio_keys_button tl_wa7210n_v2_gpio_keys[] __initdata = {
+       {
+               .desc              = "reset",
+               .type              = EV_KEY,
+               .code              = KEY_RESTART,
+               .debounce_interval = TL_WA7210N_V2_KEYS_DEBOUNCE_INT,
+               .gpio              = TL_WA7210N_V2_GPIO_BTN_RESET,
+               .active_low        = 0,
+       },
+};
+
+static struct gpio_led tl_wa7210n_v2_leds_gpio[] __initdata = {
+       {
+               .name       = "tp-link:green:lan",
+               .gpio       = TL_WA7210N_V2_GPIO_LED_LAN,
+               .active_low = 1,
+       }, {
+               .name       = "tp-link:green:signal1",
+               .gpio       = TL_WA7210N_V2_GPIO_LED_SIG1,
+               .active_low = 0,
+       }, {
+               .name       = "tp-link:green:signal2",
+               .gpio       = TL_WA7210N_V2_GPIO_LED_SIG2,
+               .active_low = 0,
+       }, {
+               .name       = "tp-link:green:signal3",
+               .gpio       = TL_WA7210N_V2_GPIO_LED_SIG3,
+               .active_low = 1,
+       }, {
+               .name       = "tp-link:green:signal4",
+               .gpio       = TL_WA7210N_V2_GPIO_LED_SIG4,
+               .active_low = 1,
+       },
+};
+
+static struct flash_platform_data tl_wa7210n_v2_flash_data = {
+       .part_probes    = tl_wa7210n_v2_part_probes,
+};
+
+static void __init tl_wa7210n_v2_setup(void)
+{
+       u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
+       u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
+
+       ath79_register_gpio_keys_polled(-1, TL_WA7210N_V2_KEYS_POLL_INT,
+                       ARRAY_SIZE(tl_wa7210n_v2_gpio_keys),
+                       tl_wa7210n_v2_gpio_keys);
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(tl_wa7210n_v2_leds_gpio),
+                       tl_wa7210n_v2_leds_gpio);
+
+       ath79_gpio_function_enable(TL_WA7210N_V2_GPIO_LNA_EN);
+
+       ath79_setup_ar933x_phy4_switch(false, false);
+
+       ath79_init_mac(ath79_eth0_data.mac_addr, mac, -1);
+       ath79_init_mac(ath79_eth1_data.mac_addr, mac, 1);
+
+       ath79_register_eth(0);
+       ath79_register_eth(1);
+
+       ath79_register_mdio(0, 0x0);
+
+       ath79_register_wmac(ee, mac);
+
+       ath79_register_m25p80(&tl_wa7210n_v2_flash_data);
+
+       ath79_register_pci();
+}
+
+MIPS_MACHINE(ATH79_MACH_TL_WA7210N_V2, "TL-WA7210N-v2", "TP-LINK TL-WA7210N v2",
+       tl_wa7210n_v2_setup);
index 5922f673998f00f5d317b0168bcfe72600a31f07..0174a431b13d31d6b2f3b3a91b40ae90267fee3b 100644 (file)
@@ -160,6 +160,16 @@ define Profile/TLWA701/Description
 endef
 $(eval $(call Profile,TLWA701))
 
+define Profile/TLWA7210
+        NAME:=TP-LINK TL-WA7210N
+        PACKAGES:=rssileds kmod-ledtrig-netdev
+endef
+
+define Profile/TLWA7210/Description
+        Package set optimized for the TP-LINK TL-WA7210N.
+endef
+$(eval $(call Profile,TLWA7210))
+
 define Profile/TLWA730RE
        NAME:=TP-LINK TL-WA730RE
        PACKAGES:=
index c9af0d4981870f3c9b08d41ee42bbce99d79f93e..caab40412fad4107c7d8b3eacb727382b9769201 100644 (file)
@@ -1394,6 +1394,7 @@ $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLMR3040V2,tl-mr3040-v2,TL-MR3040
 $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLMR3220V2,tl-mr3220-v2,TL-MR3220-v2,ttyATH0,115200,0x32200002,1,4Mlzma))
 $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLMR3420V2,tl-mr3420-v2,TL-MR3420-v2,ttyS0,115200,0x34200002,1,4Mlzma))
 $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWA701NV2,tl-wa701nd-v2,TL-WA701ND-v2,ttyATH0,115200,0x07010002,1,4Mlzma))
+$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWA7210NV2,tl-wa7210n-v2,TL-WA7210N-v2,ttyATH0,115200,0x72100002,1,4Mlzma))
 $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWR703,tl-wr703n-v1,TL-WR703N,ttyATH0,115200,0x07030101,1,4Mlzma))
 $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWR710,tl-wr710n-v1,TL-WR710N,ttyATH0,115200,0x07100001,1,8Mlzma))
 $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWR720NV3,tl-wr720n-v3,TL-WR720N-v3,ttyATH0,115200,0x07200103,1,4Mlzma))
@@ -1481,6 +1482,7 @@ $(eval $(call MultiProfile,TLMR3040,TLMR3040V1 TLMR3040V2))
 $(eval $(call MultiProfile,TLMR3220,TLMR3220V1 TLMR3220V2))
 $(eval $(call MultiProfile,TLMR3420,TLMR3420V1 TLMR3420V2))
 $(eval $(call MultiProfile,TLWA701,TLWA701NV1 TLWA701NV2))
+$(eval $(call MultiProfile,TLWA7210,TLWA7210NV2))
 $(eval $(call MultiProfile,TLWA730RE,TLWA730REV1))
 $(eval $(call MultiProfile,TLWA801,TLWA801NV1 TLWA801NV2))
 $(eval $(call MultiProfile,TLWA830,TLWA830RV1 TLWA830RV2))
index ce839f4b012f6dd01dd6b1ed03223bffee45e86c..832df9e6cac5f7e9378f26d933da37a0c3214bcd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -16,22 +16,188 @@
+@@ -16,22 +16,189 @@
  
  enum ath79_mach_type {
        ATH79_MACH_GENERIC = 0,
 +      ATH79_MACH_TL_MR3420_V2,        /* TP-LINK TL-MR3420 v2 */
 +      ATH79_MACH_TL_WA701ND_V2,       /* TP-LINK TL-WA701ND v2 */
 +      ATH79_MACH_TL_WA750RE,          /* TP-LINK TL-WA750RE */
++       ATH79_MACH_TL_WA7210N_V2,       /* TP-LINK TL-WA7210N v2 */
 +      ATH79_MACH_TL_WA7510N_V1,       /* TP-LINK TL-WA7510N v1*/
 +      ATH79_MACH_TL_WA850RE,          /* TP-LINK TL-WA850RE */
 +      ATH79_MACH_TL_WA860RE,          /* TP-LINK TL-WA860RE */
  config ATH79_MACH_AP121
        bool "Atheros AP121 reference board"
        select SOC_AR933X
-@@ -11,62 +75,960 @@ config ATH79_MACH_AP121
+@@ -11,62 +75,970 @@ config ATH79_MACH_AP121
        select ATH79_DEV_M25P80
        select ATH79_DEV_USB
        select ATH79_DEV_WMAC
 +      select ATH79_DEV_M25P80
 +      select ATH79_DEV_USB
 +      select ATH79_DEV_WMAC
++
++config ATH79_MACH_TL_WA7210N_V2
++       bool "TP-LINK TL-WA7210N v2 support"
++       select SOC_AR724X
++       select ATH79_DEV_AP9X_PCI if PCI
++       select ATH79_DEV_ETH
++       select ATH79_DEV_LEDS_GPIO
++       select ATH79_DEV_GPIO_BUTTONS
++       select ATH79_DEV_M25P80
++       select ATH79_DEV_WMAC
  
 -config ATH79_MACH_AP136
 -      bool "Atheros AP136/AP135 reference board"
  endif
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -38,9 +38,117 @@ obj-$(CONFIG_ATH79_ROUTERBOOT)             += route
+@@ -38,9 +38,118 @@ obj-$(CONFIG_ATH79_ROUTERBOOT)             += route
  #
  # Machines
  #
 +obj-$(CONFIG_ATH79_MACH_TL_MR3X20)    += mach-tl-mr3x20.o
 +obj-$(CONFIG_ATH79_MACH_TL_WAX50RE)     += mach-tl-wax50re.o
 +obj-$(CONFIG_ATH79_MACH_TL_WA701ND_V2)        += mach-tl-wa701nd-v2.o
++obj-$(CONFIG_ATH79_MACH_TL_WA7210N_V2)        += mach-tl-wa7210n-v2.o
 +obj-$(CONFIG_ATH79_MACH_TL_WA830RE_V2)        += mach-tl-wa830re-v2.o
 +obj-$(CONFIG_ATH79_MACH_TL_WA901ND)   += mach-tl-wa901nd.o
 +obj-$(CONFIG_ATH79_MACH_TL_WA901ND_V2)        += mach-tl-wa901nd-v2.o
index 0a5e4c32825f3d3e2de0d35d2817d517342c347a..4817e58f020e5863f25856afcb65b1af6869be77 100644 (file)
@@ -41,6 +41,7 @@
 #define HWID_TL_MR3420_V2      0x34200002
 #define HWID_TL_WA701N_V1      0x07010001
 #define HWID_TL_WA701N_V2      0x07010002
+#define HWID_TL_WA7210N_V2     0x72100002
 #define HWID_TL_WA7510N_V1     0x75100001
 #define HWID_TL_WA801ND_V1     0x08010001
 #define HWID_TL_WA830RE_V1     0x08300010
@@ -259,6 +260,11 @@ static struct board_info boards[] = {
                .hw_id          = HWID_TL_WA701N_V2,
                .hw_rev         = 1,
                .layout_id      = "4Mlzma",
+       }, {
+               .id             = "TL-WA7210N",
+               .hw_id          = HWID_TL_WA7210N_V2,
+               .hw_rev         = 2,
+               .layout_id      = "4Mlzma",
        }, {
                .id             = "TL-WA7510N",
                .hw_id          = HWID_TL_WA7510N_V1,