This patch provides an image suitable for the alix2*, alix3, and alix6 headless ...
authorDaniel Dickinson <crazycshore@gmail.com>
Fri, 13 May 2011 06:06:42 +0000 (06:06 +0000)
committerDaniel Dickinson <crazycshore@gmail.com>
Fri, 13 May 2011 06:06:42 +0000 (06:06 +0000)
Note that the Alix6 uses GPIO 27 to disable wireless transmit (W_DIS#), whereas on all other versions this is used to actuate the speaker.

GPIO 1 : SIM select (Alix6)
GPIO 6 : LED1
GPIO 25 : LED2
GPIO 27 : LED3 or RFKILL (Alix6)

GPIO 24 : Soft switch 1

No kernel version bump.  Added i2c-scx200-acb for lm-sensors support.

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
SVN-Revision: 26879

target/linux/x86/Makefile
target/linux/x86/generic/profiles/Alix.mk
target/linux/x86/image/Config.in

index e0a216d1b1872fcc869356bd10b318e68c0991fc..829d422377e190e861a0cb5e46351bd07cb5cbe8 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext4 vdi vmdk pcmcia targz
-SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos
+SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos alix2
 
 LINUX_VERSION:=2.6.37.6
 
index c7d9f3253dd69afdd297159e16b6feae2b560c53..e69de29bb2d1d6434b8b29ae775ad8c2e48c5391 100644 (file)
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Alix
-  NAME:=PCEngines Alix
-  PACKAGES:=kmod-via-rhine kmod-leds-alix
-endef
-
-define Profile/Alix/Description
-        Package set compatible with the PCEngines Alix. Contains VIA Rhine III VT6105M and LED support
-endef
-$(eval $(call Profile,Alix))
index 19f0cb342df8c05c76d3ee8d280b61746fae69a2..4847dd4ae56b3e32d7a673443cedee273619cd0a 100644 (file)
@@ -21,6 +21,7 @@ config X86_GRUB_BAUDRATE
        int "Serial port baud rate"
        depends X86_GRUB_IMAGES
        default 19200 if TARGET_x86_generic_Soekris45xx || TARGET_x86_generic_Soekris48xx || TARGET_x86_net5501
+       default 38400 if TARGET_x86_alix2
        default 115200 if TARGET_x86_geos
        default 38400