tools/pkg-config: Update to 0.29.2
authorDaniel Engberg <daniel.engberg.lists@pyret.net>
Tue, 8 Aug 2017 06:14:28 +0000 (08:14 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 9 Aug 2017 21:20:56 +0000 (23:20 +0200)
* Update pkg-config to 0.29.2
* Remove patch as it's upstreamed

Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
tools/pkg-config/Makefile
tools/pkg-config/patches/001-glib-gdate-suppress-string-format-literal-warning.patch [deleted file]

index 4575c4d44e7aee20a11b7c2fdbfa2eccb06b7b37..17a8737be16a1fee95ff052ae349e4f35b33aba9 100644 (file)
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pkg-config
-PKG_VERSION:=0.29.1
+PKG_VERSION:=0.29.2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://pkgconfig.freedesktop.org/releases/
-PKG_HASH:=beb43c9e064555469bd4390dcfd8030b1536e0aa103f08d7abf7ae8cac0cb001
+PKG_HASH:=6fc69c01688c9458a57eb9a1664c9aba372ccda420a02bf4429fe610e7e7d591
 
 HOST_BUILD_PARALLEL:=1
 
diff --git a/tools/pkg-config/patches/001-glib-gdate-suppress-string-format-literal-warning.patch b/tools/pkg-config/patches/001-glib-gdate-suppress-string-format-literal-warning.patch
deleted file mode 100644 (file)
index 6849299..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/glib/glib/gdate.c
-+++ b/glib/glib/gdate.c
-@@ -2439,6 +2439,9 @@ win32_strftime_helper (const GDate     *d,
-  *
-  * Returns: number of characters written to the buffer, or 0 the buffer was too small
-  */
-+#pragma GCC diagnostic push
-+#pragma GCC diagnostic ignored "-Wformat-nonliteral"
-+
- gsize     
- g_date_strftime (gchar       *s, 
-                  gsize        slen, 
-@@ -2549,3 +2552,5 @@ g_date_strftime (gchar       *s,
-   return retval;
- #endif
- }
-+
-+#pragma GCC diagnostic pop