ramips: fix bogus MTK_SOC (typo)
authorDaniel Golle <daniel@makrotopia.org>
Wed, 10 Jul 2019 17:28:35 +0000 (19:28 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 10 Jul 2019 17:28:35 +0000 (19:28 +0200)
Belkin F7C027 is clearly Rt5350 SoC, as shown on internal
photographs filed for FCC approval[1].

[1]: https://fcc.io/K7S/F7C027

Fixes commit 3b0264eddbc
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/ramips/dts/rt5350_belkin_f7c027.dts [new file with mode: 0644]
target/linux/ramips/dts/rt5352_belkin_f7c027.dts [deleted file]
target/linux/ramips/image/rt305x.mk

diff --git a/target/linux/ramips/dts/rt5350_belkin_f7c027.dts b/target/linux/ramips/dts/rt5350_belkin_f7c027.dts
new file mode 100644 (file)
index 0000000..f3bf00e
--- /dev/null
@@ -0,0 +1,143 @@
+/dts-v1/;
+
+#include "rt5350.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "belkin,f7c027", "ralink,rt5350-soc";
+       model = "Belkin F7C027";
+
+       aliases {
+               led-boot = &led_status_orange;
+               led-failsafe = &led_status_orange;
+               led-running = &led_status_orange;
+               led-upgrade = &led_status_orange;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               status {
+                       label = "f7c027:blue:status";
+                       gpios = <&gpio0 7 GPIO_ACTIVE_LOW>;
+               };
+
+               power {
+                       label = "f7c027:blue:power";
+                       gpios = <&gpio0 9 GPIO_ACTIVE_LOW>;
+               };
+
+               led_status_orange: orange {
+                       label = "f7c027:orange:status";
+                       gpios = <&gpio0 11 GPIO_ACTIVE_LOW>;
+               };
+
+               relay {
+                       label = "f7c027:device:relay";
+                       gpios = <&gpio0 13 GPIO_ACTIVE_HIGH>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys-polled";
+               poll-interval = <20>;
+
+               top {
+                       label = "restore";
+                       gpios = <&gpio0 10 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+
+               power {
+                       label = "power";
+                       gpios = <&gpio0 12 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RFKILL>;
+               };
+
+               sensor {
+                       label = "sensor";
+                       gpios = <&gpio0 14 GPIO_ACTIVE_LOW>;
+                       linux,code = <BTN_0>;
+               };
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       m25p80@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <10000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x30000>;
+                               read-only;
+                       };
+
+                       partition@30000 {
+                               label = "u-boot-env";
+                               reg = <0x30000 0x10000>;
+                               read-only;
+                       };
+
+                       factory: partition@40000 {
+                               label = "factory";
+                               reg = <0x40000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@50000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x50000 0x770000>;
+                       };
+
+                       partition@7c0000 {
+                               label = "firmware2";
+                               reg = <0x7c0000 0x770000>;
+                       };
+
+                       partition@f30000 {
+                               label = "belkin_settings";
+                               reg = <0xf30000 0xa0000>;
+                       };
+
+                       partition@fd0000 {
+                               label = "unknown";
+                               reg = <0xfd0000 0x10000>;
+                       };
+
+                       partition@fe0000 {
+                               label = "nvram";
+                               reg = <0xfe0000 0x10000>;
+                       };
+
+                       partition@ff0000 {
+                               label = "user_factory";
+                               reg = <0xff0000 0x10000>;
+                       };
+               };
+       };
+};
+
+&wmac {
+       ralink,mtd-eeprom = <&factory 0>;
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "i2c", "jtag", "uartf";
+                       ralink,function = "gpio";
+               };
+       };
+};
diff --git a/target/linux/ramips/dts/rt5352_belkin_f7c027.dts b/target/linux/ramips/dts/rt5352_belkin_f7c027.dts
deleted file mode 100644 (file)
index f3bf00e..0000000
+++ /dev/null
@@ -1,143 +0,0 @@
-/dts-v1/;
-
-#include "rt5350.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-/ {
-       compatible = "belkin,f7c027", "ralink,rt5350-soc";
-       model = "Belkin F7C027";
-
-       aliases {
-               led-boot = &led_status_orange;
-               led-failsafe = &led_status_orange;
-               led-running = &led_status_orange;
-               led-upgrade = &led_status_orange;
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               status {
-                       label = "f7c027:blue:status";
-                       gpios = <&gpio0 7 GPIO_ACTIVE_LOW>;
-               };
-
-               power {
-                       label = "f7c027:blue:power";
-                       gpios = <&gpio0 9 GPIO_ACTIVE_LOW>;
-               };
-
-               led_status_orange: orange {
-                       label = "f7c027:orange:status";
-                       gpios = <&gpio0 11 GPIO_ACTIVE_LOW>;
-               };
-
-               relay {
-                       label = "f7c027:device:relay";
-                       gpios = <&gpio0 13 GPIO_ACTIVE_HIGH>;
-               };
-       };
-
-       keys {
-               compatible = "gpio-keys-polled";
-               poll-interval = <20>;
-
-               top {
-                       label = "restore";
-                       gpios = <&gpio0 10 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RESTART>;
-               };
-
-               power {
-                       label = "power";
-                       gpios = <&gpio0 12 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RFKILL>;
-               };
-
-               sensor {
-                       label = "sensor";
-                       gpios = <&gpio0 14 GPIO_ACTIVE_LOW>;
-                       linux,code = <BTN_0>;
-               };
-       };
-};
-
-&spi0 {
-       status = "okay";
-
-       m25p80@0 {
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <10000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "u-boot";
-                               reg = <0x0 0x30000>;
-                               read-only;
-                       };
-
-                       partition@30000 {
-                               label = "u-boot-env";
-                               reg = <0x30000 0x10000>;
-                               read-only;
-                       };
-
-                       factory: partition@40000 {
-                               label = "factory";
-                               reg = <0x40000 0x10000>;
-                               read-only;
-                       };
-
-                       partition@50000 {
-                               compatible = "denx,uimage";
-                               label = "firmware";
-                               reg = <0x50000 0x770000>;
-                       };
-
-                       partition@7c0000 {
-                               label = "firmware2";
-                               reg = <0x7c0000 0x770000>;
-                       };
-
-                       partition@f30000 {
-                               label = "belkin_settings";
-                               reg = <0xf30000 0xa0000>;
-                       };
-
-                       partition@fd0000 {
-                               label = "unknown";
-                               reg = <0xfd0000 0x10000>;
-                       };
-
-                       partition@fe0000 {
-                               label = "nvram";
-                               reg = <0xfe0000 0x10000>;
-                       };
-
-                       partition@ff0000 {
-                               label = "user_factory";
-                               reg = <0xff0000 0x10000>;
-                       };
-               };
-       };
-};
-
-&wmac {
-       ralink,mtd-eeprom = <&factory 0>;
-};
-
-&pinctrl {
-       state_default: pinctrl0 {
-               gpio {
-                       ralink,group = "i2c", "jtag", "uartf";
-                       ralink,function = "gpio";
-               };
-       };
-};
index ee1e39ac5c8e4ae00d277ad3096616df2f9ba257..2ba5e254e6eab029ed0346bc3ec5479e581ebbbc 100644 (file)
@@ -274,7 +274,7 @@ endef
 TARGET_DEVICES += belkin_f5d8235-v2
 
 define Device/belkin_f7c027
-  MTK_SOC := rt5352
+  MTK_SOC := rt5350
   IMAGE_SIZE := 7616k
   DEVICE_VENDOR := Belkin
   DEVICE_MODEL := F7C027