fix eglibc compile
authorJohn Crispin <john@openwrt.org>
Wed, 3 Apr 2013 10:01:10 +0000 (10:01 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 3 Apr 2013 10:01:10 +0000 (10:01 +0000)
add librt dependency/link flag to procd when using eglibc thanks to jow for the help

Signed-off-by: Etienne CHAMPETIER <etienne.champetier@free.fr>
SVN-Revision: 36188

package/procd/Makefile

index 762fb5f18fd1dbb4940a982d9f53169ad8c8e38f..53c102a7cb1f4791356bd3b9c8a497aae22aaeb0 100644 (file)
@@ -21,10 +21,12 @@ PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
+TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
+
 define Package/procd
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+ubusd +ubus +libjson-script
+  DEPENDS:=+ubusd +ubus +libjson-script +USE_EGLIBC:librt
   TITLE:=OpenWrt system process manager
 endef