kernel: bump 4.9 to 4.9.135
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 22 Oct 2018 09:46:59 +0000 (11:46 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 22 Oct 2018 13:28:31 +0000 (15:28 +0200)
Refreshed all patches.

Fixes:
- CVE-2018-10883

Compile-tested on: ar71xx, layerscape
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/layerscape/patches-4.9/401-mtd-spi-nor-support-layerscape.patch
target/linux/layerscape/patches-4.9/810-iommu-support-layerscape.patch

index 0c0ccd6023f6b78e4c5ab187616f426fda2786fa..4365bee05c4f648056fa60738ec131017d0dba29 100644 (file)
@@ -3,11 +3,11 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .124
-LINUX_VERSION-4.9 = .134
+LINUX_VERSION-4.9 = .135
 LINUX_VERSION-4.14 = .77
 
 LINUX_KERNEL_HASH-3.18.124 = 25d2a5abd627534a1e51d028890c184aad8e628c345c5fe0cc0f9d7c31b7a5a3
-LINUX_KERNEL_HASH-4.9.134 = 6dfbe8d122021c874945c0f2ebeace2248e58eed93c10ce61e4a134e70997a77
+LINUX_KERNEL_HASH-4.9.135 = e023b0bbe9ea7fc56aa57210342dd18ea3e0900ee207226df1523c6d7df154ce
 LINUX_KERNEL_HASH-4.14.77 = 0496f4e194cadbe23f27e6f4b9c3cd264448983780b73b30f7f05c92273fa6f8
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index fed6711e5520e363b9eff19287ba2652768c8d2c..4c07f2f28378fa2833a3cc96d7164d7ecf19157c 100644 (file)
@@ -775,7 +775,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        { "w25q32", INFO(0xef4016, 0, 64 * 1024,  64, SECT_4K) },
        {
                "w25q32dw", INFO(0xef6016, 0, 64 * 1024,  64,
-@@ -1197,6 +1226,53 @@ static const struct flash_info *spi_nor_
+@@ -1202,6 +1231,53 @@ static const struct flash_info *spi_nor_
                id[0], id[1], id[2]);
        return ERR_PTR(-ENODEV);
  }
@@ -829,7 +829,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
  static int spi_nor_read(struct mtd_info *mtd, loff_t from, size_t len,
                        size_t *retlen, u_char *buf)
-@@ -1416,7 +1492,7 @@ static int macronix_quad_enable(struct s
+@@ -1421,7 +1497,7 @@ static int macronix_quad_enable(struct s
   * Write status Register and configuration register with 2 bytes
   * The first byte will be written to the status register, while the
   * second byte will be written to the configuration register.
@@ -838,7 +838,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
   */
  static int write_sr_cr(struct spi_nor *nor, u16 val)
  {
-@@ -1464,6 +1540,24 @@ static int spansion_quad_enable(struct s
+@@ -1469,6 +1545,24 @@ static int spansion_quad_enable(struct s
        return 0;
  }
  
@@ -863,7 +863,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  static int set_quad_mode(struct spi_nor *nor, const struct flash_info *info)
  {
        int status;
-@@ -1610,9 +1704,25 @@ int spi_nor_scan(struct spi_nor *nor, co
+@@ -1615,9 +1709,25 @@ int spi_nor_scan(struct spi_nor *nor, co
                write_sr(nor, 0);
                spi_nor_wait_till_ready(nor);
        }
@@ -889,7 +889,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        mtd->priv = nor;
        mtd->type = MTD_NORFLASH;
        mtd->writesize = 1;
-@@ -1646,6 +1756,8 @@ int spi_nor_scan(struct spi_nor *nor, co
+@@ -1651,6 +1761,8 @@ int spi_nor_scan(struct spi_nor *nor, co
                nor->flags |= SNOR_F_USE_FSR;
        if (info->flags & SPI_NOR_HAS_TB)
                nor->flags |= SNOR_F_HAS_SR_TB;
@@ -898,7 +898,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
  #ifdef CONFIG_MTD_SPI_NOR_USE_4K_SECTORS
        /* prefer "small sector" erase if possible */
-@@ -1685,9 +1797,15 @@ int spi_nor_scan(struct spi_nor *nor, co
+@@ -1690,9 +1802,15 @@ int spi_nor_scan(struct spi_nor *nor, co
        /* Some devices cannot do fast-read, no matter what DT tells us */
        if (info->flags & SPI_NOR_NO_FR)
                nor->flash_read = SPI_NOR_NORMAL;
@@ -917,7 +917,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                ret = set_quad_mode(nor, info);
                if (ret) {
                        dev_err(dev, "quad mode not supported\n");
-@@ -1700,6 +1818,9 @@ int spi_nor_scan(struct spi_nor *nor, co
+@@ -1705,6 +1823,9 @@ int spi_nor_scan(struct spi_nor *nor, co
  
        /* Default commands */
        switch (nor->flash_read) {
index d467a913dba70b0291bd3db9b934dba31254ed3b..5dbeb0c45dde7cbb08d16d09bb9fc13ae28a81b7 100644 (file)
@@ -25,7 +25,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
 
 --- a/drivers/iommu/amd_iommu.c
 +++ b/drivers/iommu/amd_iommu.c
-@@ -373,6 +373,8 @@ static struct iommu_group *acpihid_devic
+@@ -379,6 +379,8 @@ static struct iommu_group *acpihid_devic
  
        if (!entry->group)
                entry->group = generic_device_group(dev);
@@ -34,7 +34,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
        return entry->group;
  }
-@@ -3160,9 +3162,10 @@ static bool amd_iommu_capable(enum iommu
+@@ -3166,9 +3168,10 @@ static bool amd_iommu_capable(enum iommu
        return false;
  }
  
@@ -47,7 +47,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        struct unity_map_entry *entry;
        int devid;
  
-@@ -3171,41 +3174,56 @@ static void amd_iommu_get_dm_regions(str
+@@ -3177,41 +3180,56 @@ static void amd_iommu_get_dm_regions(str
                return;
  
        list_for_each_entry(entry, &amd_iommu_unity_map, list) {
@@ -118,7 +118,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  {
        struct dma_ops_domain *dma_dom = to_dma_ops_domain(to_pdomain(domain));
        unsigned long start, end;
-@@ -3229,9 +3247,9 @@ static const struct iommu_ops amd_iommu_
+@@ -3235,9 +3253,9 @@ static const struct iommu_ops amd_iommu_
        .add_device = amd_iommu_add_device,
        .remove_device = amd_iommu_remove_device,
        .device_group = amd_iommu_device_group,