base-files: make user_add() populate the shadow db as well
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 5 Jun 2012 17:40:32 +0000 (17:40 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 5 Jun 2012 17:40:32 +0000 (17:40 +0000)
SVN-Revision: 32063

package/base-files/Makefile
package/base-files/files/lib/functions.sh

index 41e68703539051bf42ea208feade4eb965720858..a74d83cac6d2d15320515eb2a1fb1ab4b8a47d88 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=108
+PKG_RELEASE:=109
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 02048eab1215bfd667cd77ec7d1b7c94bbb41af0..b3a3885f2d62c0e6ad182351e60a50a25b507047 100755 (executable)
@@ -302,6 +302,7 @@ user_add() {
        [ -f "${IPKG_INSTROOT}/etc/passwd" ] || return 1
        [ -n "$IPKG_INSTROOT" ] || lock /var/lock/passwd
        echo "${name}:x:${uid}:${gid}:${desc}:${home}:${shell}" >> ${IPKG_INSTROOT}/etc/passwd
+       echo "${name}:x:0:0:99999:7:::" >> ${IPKG_INSTROOT}/etc/shadow
        rc=$?
        [ -n "$IPKG_INSTROOT" ] || lock -u /var/lock/passwd
        return $rc