dropbear: fix compile error
authorJohn Crispin <john@phrozen.org>
Wed, 15 Jan 2020 20:31:12 +0000 (21:31 +0100)
committerJohn Crispin <john@phrozen.org>
Wed, 15 Jan 2020 20:31:12 +0000 (21:31 +0100)
Fixes: 0da193ee6943 ("dropbear: move failsafe code out of base-files")
Signed-off-by: John Crispin <john@phrozen.org>
package/network/services/dropbear/Makefile

index 8b5bc17c9de3a94c07d1e77384271fd742f80f60..59b4f5495449b174944999b95aafc5f2878a1267 100644 (file)
@@ -158,7 +158,8 @@ define Package/dropbear/install
        $(INSTALL_BIN) ./files/dropbear.init $(1)/etc/init.d/dropbear
        $(INSTALL_DIR) $(1)/usr/lib/opkg/info
        $(INSTALL_DIR) $(1)/etc/dropbear
-       $(INSTALL_DIR) ./files/dropbear.failsafe $(1)/lib/preinit/99_10_failsafe_dropbear
+       $(INSTALL_DIR) $(1)/lib/preinit
+       $(INSTALL_DATA) ./files/dropbear.failsafe $(1)/lib/preinit/99_10_failsafe_dropbear
        $(if $(CONFIG_DROPBEAR_ECC),touch $(1)/etc/dropbear/dropbear_ecdsa_host_key)
        touch $(1)/etc/dropbear/dropbear_rsa_host_key
 endef