mvebu: clearfog: require uboot-mvebu-clearfog
authorJosua Mayer <josua.mayer97@gmail.com>
Sat, 13 Aug 2016 13:50:54 +0000 (15:50 +0200)
committerFelix Fietkau <nbd@nbd.name>
Fri, 2 Sep 2016 12:43:52 +0000 (14:43 +0200)
The u-boot variant for the clearfog is provided by the uboot-mvebu-clearfog,
and not by the generic uboot-mvebu packae.
Make sure the clearfog variant is selected when building for it.

Signed-off-by: Josua Mayer <josua.mayer97@gmail.com>
Signed-off-by: Felix Fietkau <nbd@nbd.name>
target/linux/mvebu/image/Makefile
target/linux/mvebu/profiles/000-Default.mk

index deab33c9c91e3d1adbc47de39f0bb136e92315bc..a09cf24f1a90adc3a9b00b665c2db6c683ce05bc 100644 (file)
@@ -150,6 +150,7 @@ define Device/armada-388-clearfog
   KERNEL_INSTALL := 1
   KERNEL := dtb | kernel-bin
   DEVICE_TITLE := SolidRun ClearFog
+  DEVICE_PACKAGES := uboot-mvebu-clearfog
   IMAGES := bundle.tar.gz
   IMAGE/bundle.tar.gz := clearfog-bundle
   IMAGE_NAME = $$(IMAGE_PREFIX)-$$(2)
index 7f71f3e01f563bd7a8d153a9f562ea2b4fa063ac..5a03fe9bb4ee5448d0966832a5243c690e1f0f65 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Default
        NAME:=Default Profile (all drivers)
-       PACKAGES:= kmod-mwlwifi wpad-mini swconfig
+       PACKAGES:= kmod-mwlwifi wpad-mini swconfig uboot-mvebu-clearfog
 endef
 
 define Profile/Default/Description