sunxi: build image/uboot for the NanoPi NEO2
authorJasper Scholte <NightNL@outlook.com>
Wed, 19 Sep 2018 20:31:26 +0000 (22:31 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 22 Sep 2018 19:20:55 +0000 (21:20 +0200)
The NanoPi NEO2 is a small Allwinner H5 based board available with
different DRAM configurations.
This board is very similar to the NanoPi NEO PLUS2

Signed-off-by: Jasper Scholte <NightNL@outlook.com>
package/boot/uboot-sunxi/Makefile
target/linux/sunxi/image/cortex-a53.mk

index ce5edfc1b62c4b7833e58e3ac257f9d633bbfed5..b3d9c1eb69a700a3a63fdb7f9b96eae002c367bc 100644 (file)
@@ -182,6 +182,14 @@ define U-Boot/nanopi_neo_plus2
   UENV:=a64
 endef
 
+define U-Boot/nanopi_neo2
+  BUILD_SUBTARGET:=cortexa53
+  NAME:=NanoPi NEO2 (H5)
+  BUILD_DEVICES:=sun50i-h5-nanopi-neo2
+  DEPENDS:=+PACKAGE_u-boot-nanopi_neo2:arm-trusted-firmware-sunxi
+  UENV:=a64
+endef
+
 define U-Boot/pine64_plus
   BUILD_SUBTARGET:=cortexa53
   NAME:=Pine64 Plus A64
@@ -237,6 +245,7 @@ UBOOT_TARGETS := \
        nanopi_m1_plus \
        nanopi_neo \
        nanopi_neo_plus2 \
+       nanopi_neo2 \
        orangepi_r1 \
        orangepi_pc \
        orangepi_plus \
index e40f35cb32674ff1f68ecbac75352a0d4ed31607..65551407cedb3a5d5b0d7b48ddb6ae8bdda47b89 100644 (file)
@@ -17,6 +17,16 @@ endef
 
 TARGET_DEVICES += sun50i-h5-nanopi-neo-plus2
 
+define Device/sun50i-h5-nanopi-neo2
+  DEVICE_TITLE:=Nanopi NEO2 (H5)
+  SUPPORTED_DEVICES:=nanopi-neo2
+  SUNXI_DTS:=allwinner/sun50i-h5-nanopi-neo2
+  KERNEL_NAME := Image
+  KERNEL := kernel-bin
+endef
+
+TARGET_DEVICES += sun50i-h5-nanopi-neo2
+
 define Device/sun50i-a64-pine64-plus
   DEVICE_TITLE:=Pine64 Plus A64
   SUPPORTED_DEVICES:=pine64,pine64-plus