build: move opkg host dependency from package/install to package/compile
authorFelix Fietkau <nbd@nbd.name>
Mon, 20 Feb 2017 11:37:58 +0000 (12:37 +0100)
committerFelix Fietkau <nbd@nbd.name>
Tue, 21 Feb 2017 12:03:20 +0000 (13:03 +0100)
Improves parallel build behavior, since it allows opkg to be built at
the same time as other packages

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/Makefile

index fd0e88ff3816ccc248a831297025d929b088abf8..1ef501736b5db5e243c5371cb9dcb1a633b26724 100644 (file)
@@ -56,7 +56,9 @@ $(curdir)/merge:
 $(curdir)/merge-index: $(curdir)/merge
        (cd $(PACKAGE_DIR_ALL) && $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages; )
 
-$(curdir)/install: $(TMP_DIR)/.build $(curdir)/system/opkg/host/compile $(curdir)/merge $(if $(CONFIG_TARGET_PER_DEVICE_ROOTFS),$(curdir)/merge-index)
+$(curdir)/compile: $(curdir)/system/opkg/host/compile
+
+$(curdir)/install: $(TMP_DIR)/.build $(curdir)/merge $(if $(CONFIG_TARGET_PER_DEVICE_ROOTFS),$(curdir)/merge-index)
        - find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755
        rm -rf $(TARGET_DIR) $(TARGET_DIR_ORIG)
        [ -d $(TARGET_DIR)/tmp ] || mkdir -p $(TARGET_DIR)/tmp