kernel: bump 4.14 to 4.14.108
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 25 Mar 2019 10:40:22 +0000 (11:40 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 27 Mar 2019 09:48:59 +0000 (10:48 +0100)
Refreshed all patches.

Altered patches:
- 950-0033-i2c-bcm2835-Add-debug-support.patch

Compile-tested on: ar71xx, cns3xxx, imx6, x86_64
Runtime-tested on: ar71xx, cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm2708/patches-4.14/950-0033-i2c-bcm2835-Add-debug-support.patch
target/linux/brcm2708/patches-4.14/950-0136-cgroup-Disable-cgroup-memory-by-default.patch
target/linux/ipq806x/patches-4.14/0067-generic-Mangle-bootloader-s-kernel-arguments.patch
target/linux/kirkwood/patches-4.14/200-disable-tso.patch
target/linux/layerscape/patches-4.14/812-flexspi-support-layerscape.patch
target/linux/layerscape/patches-4.14/820-sec-support-layerscape.patch
target/linux/mvebu/patches-4.14/006-mvebu-Mangle-bootloader-s-kernel-arguments.patch
target/linux/oxnas/patches-4.14/996-generic-Mangle-bootloader-s-kernel-arguments.patch
target/linux/ramips/patches-4.14/0031-uvc-add-iPassion-iP2970-support.patch

index d5111758e5443e6a0529f5edf1b3a69b2cf1b03a..b2614af1fb3848e86bbfa6dd26e3b400c37f4e19 100644 (file)
@@ -4,12 +4,12 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .136
 LINUX_VERSION-4.9 = .165
-LINUX_VERSION-4.14 = .107
+LINUX_VERSION-4.14 = .108
 LINUX_VERSION-4.19 = .25
 
 LINUX_KERNEL_HASH-3.18.136 = 48c8775013d23229462134f911bbb14c7935096fcccfb19ce28ecd5f7154f35c
 LINUX_KERNEL_HASH-4.9.165 = 47a0916af54b37028417f365c8938477af00235f4f36c514e9375155772f043c
-LINUX_KERNEL_HASH-4.14.107 = e48d0f01468e399d03e443527fe7fa277d0bc46df4a66fad97df47ee1f9b4ef4
+LINUX_KERNEL_HASH-4.14.108 = b6e33c687f26cd13934f961f48985c17ab3fd0e09aae007a175e3bbf3a8ed454
 LINUX_KERNEL_HASH-4.19.25 = 7ec71d90d6e96e6f741676d157ac06f30c75be4eaf1649143a3c8b7d4f919731
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index f740fb5871de22b04478c35dfb86725a19225b43..47bb41f3d9d3945640ab474a7ef504db054694b7 100644 (file)
@@ -142,8 +142,8 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
 +      bcm2835_debug_add(i2c_dev, ~0);
  }
  
- /*
-@@ -206,6 +289,7 @@ static irqreturn_t bcm2835_i2c_isr(int t
+ static void bcm2835_i2c_finish_transfer(struct bcm2835_i2c_dev *i2c_dev)
+@@ -215,6 +298,7 @@ static irqreturn_t bcm2835_i2c_isr(int t
        u32 val, err;
  
        val = bcm2835_i2c_readl(i2c_dev, BCM2835_I2C_S);
@@ -151,7 +151,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
  
        err = val & (BCM2835_I2C_S_CLKT | BCM2835_I2C_S_ERR);
        if (err) {
-@@ -272,6 +356,13 @@ static int bcm2835_i2c_xfer(struct i2c_a
+@@ -281,6 +365,13 @@ static int bcm2835_i2c_xfer(struct i2c_a
        unsigned long time_left;
        int i, ret;
  
@@ -165,18 +165,19 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
        for (i = 0; i < (num - 1); i++)
                if (msgs[i].flags & I2C_M_RD) {
                        dev_warn_once(i2c_dev->dev,
-@@ -291,6 +382,10 @@ static int bcm2835_i2c_xfer(struct i2c_a
+@@ -301,6 +392,11 @@ static int bcm2835_i2c_xfer(struct i2c_a
        time_left = wait_for_completion_timeout(&i2c_dev->completion,
                                                adap->timeout);
 +      if (debug > 1 || (debug && (!time_left || i2c_dev->msg_err)))
 +              bcm2835_debug_print(i2c_dev);
 +      i2c_dev->debug_num_msgs = 0;
 +      i2c_dev->debug_num = 0;
++
+       bcm2835_i2c_finish_transfer(i2c_dev);
        if (!time_left) {
-               bcm2835_i2c_writel(i2c_dev, BCM2835_I2C_C,
-                                  BCM2835_I2C_C_CLEAR);
-@@ -301,7 +396,9 @@ static int bcm2835_i2c_xfer(struct i2c_a
+@@ -313,7 +409,9 @@ static int bcm2835_i2c_xfer(struct i2c_a
        if (!i2c_dev->msg_err)
                return num;
  
index 6a1bda859efdaa89a819eb1aac7baa4cfb93f368..9011de8b96513930f7a8913a7dfb346e31c00f90 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/kernel/cgroup/cgroup.c
 +++ b/kernel/cgroup/cgroup.c
-@@ -5159,6 +5159,8 @@ int __init cgroup_init_early(void)
+@@ -5162,6 +5162,8 @@ int __init cgroup_init_early(void)
  }
  
  static u16 cgroup_disable_mask __initdata;
@@ -26,7 +26,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  
  /**
   * cgroup_init - cgroup initialization
-@@ -5197,6 +5199,12 @@ int __init cgroup_init(void)
+@@ -5200,6 +5202,12 @@ int __init cgroup_init(void)
  
        mutex_unlock(&cgroup_mutex);
  
@@ -39,7 +39,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        for_each_subsys(ss, ssid) {
                if (ss->early_init) {
                        struct cgroup_subsys_state *css =
-@@ -5577,6 +5585,28 @@ static int __init cgroup_disable(char *s
+@@ -5580,6 +5588,28 @@ static int __init cgroup_disable(char *s
  }
  __setup("cgroup_disable=", cgroup_disable);
  
index c7123eac52c8fa87e5d24f48e6ccb4e51402ec5b..803edfe6f73180bb658f588c32360a124132b8a1 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1938,6 +1938,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1939,6 +1939,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.
  
index 4b0cbeaba2dc55573cb54c6acedf9efb95dc3272..cdd7fc803e2b5861adeaa3b8bd6635acc1a36a4b 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Ezequiel Garcia <ezequiel.garcia <at> free-electrons.com>
 ---
 --- a/drivers/net/ethernet/marvell/mv643xx_eth.c
 +++ b/drivers/net/ethernet/marvell/mv643xx_eth.c
-@@ -3200,11 +3200,11 @@ static int mv643xx_eth_probe(struct plat
+@@ -3205,11 +3205,11 @@ static int mv643xx_eth_probe(struct plat
        dev->watchdog_timeo = 2 * HZ;
        dev->base_addr = 0;
  
index 0738fc7ad139ff63ca2db8adcde5c100e5280d58..0619431211e92eb11f83cf14eb1004d3ecf1f9fe 100644 (file)
@@ -166,7 +166,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
         * or local to this CPU. Furthermore it means its ACTIVE (otherwise
 --- a/sound/soc/soc-dapm.c
 +++ b/sound/soc/soc-dapm.c
-@@ -4012,6 +4012,13 @@ int snd_soc_dapm_link_dai_widgets(struct
+@@ -4036,6 +4036,13 @@ int snd_soc_dapm_link_dai_widgets(struct
                        continue;
                }
  
index d1e75952a0e40ea53acf9a0db1ef47991ab6a4f0..ff0fe8daa4b820a08e61df64a15e4655b020ded8 100644 (file)
@@ -442,7 +442,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
  static int test_cipher(struct crypto_cipher *tfm, int enc,
                       const struct cipher_testvec *template,
                       unsigned int tcount)
-@@ -3518,6 +3753,15 @@ static const struct alg_test_desc alg_te
+@@ -3524,6 +3759,15 @@ static const struct alg_test_desc alg_te
                        .hash = __VECS(tgr192_tv_template)
                }
        }, {
@@ -1828,7 +1828,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
        if (ivsize && ((is_rfc3686 && encrypt) || !alg->caam.geniv))
                append_load_as_imm(desc, req->iv, ivsize,
                                   LDST_CLASS_1_CCB |
-@@ -3203,9 +3247,11 @@ struct caam_crypto_alg {
+@@ -3204,9 +3248,11 @@ struct caam_crypto_alg {
        struct caam_alg_entry caam;
  };
  
@@ -1841,7 +1841,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
  
        ctx->jrdev = caam_jr_alloc();
        if (IS_ERR(ctx->jrdev)) {
-@@ -3213,10 +3259,16 @@ static int caam_init_common(struct caam_
+@@ -3214,10 +3260,16 @@ static int caam_init_common(struct caam_
                return PTR_ERR(ctx->jrdev);
        }
  
@@ -1859,7 +1859,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
        if (dma_mapping_error(ctx->jrdev, dma_addr)) {
                dev_err(ctx->jrdev, "unable to map key, shared descriptors\n");
                caam_jr_free(ctx->jrdev);
-@@ -3244,7 +3296,7 @@ static int caam_cra_init(struct crypto_t
+@@ -3245,7 +3297,7 @@ static int caam_cra_init(struct crypto_t
                 container_of(alg, struct caam_crypto_alg, crypto_alg);
        struct caam_ctx *ctx = crypto_tfm_ctx(tfm);
  
@@ -1868,7 +1868,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
  }
  
  static int caam_aead_init(struct crypto_aead *tfm)
-@@ -3254,14 +3306,15 @@ static int caam_aead_init(struct crypto_
+@@ -3255,14 +3307,15 @@ static int caam_aead_init(struct crypto_
                 container_of(alg, struct caam_aead_alg, aead);
        struct caam_ctx *ctx = crypto_aead_ctx(tfm);
  
index c4ffd0efea986b3c42a0adae9006c00a9e109d7c..d36125ddb5b3621b160b8d1deb4637106cc6e028 100644 (file)
@@ -28,7 +28,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1938,6 +1938,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1939,6 +1939,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.
  
index 85947b1974ea464cef780b827efb069b79531de8..2374818dbb9bb2e212e8a47bc46b7fd108c39a6e 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
 
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -1938,6 +1938,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
+@@ -1939,6 +1939,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
          The command-line arguments provided by the boot loader will be
          appended to the the device tree bootargs property.
  
index 3ef607f14b501d8a3d04cb58285029a34ebaa2f4..ff4c5b17fa07a67d849896f9e2ce6955fe4a6ce0 100644 (file)
@@ -64,7 +64,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  
  #include <media/v4l2-common.h>
  
-@@ -1093,9 +1098,149 @@ static void uvc_video_decode_data(struct
+@@ -1101,9 +1106,149 @@ static void uvc_video_decode_data(struct
        }
  }
  
@@ -214,7 +214,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
        /* Mark the buffer as done if the EOF marker is set. */
        if (data[1] & UVC_STREAM_EOF && buf->bytesused != 0) {
                uvc_trace(UVC_TRACE_FRAME, "Frame complete (EOF found).\n");
-@@ -1510,6 +1655,8 @@ static int uvc_init_video_isoc(struct uv
+@@ -1518,6 +1663,8 @@ static int uvc_init_video_isoc(struct uv
        if (npackets == 0)
                return -ENOMEM;