tools/scons: update to 3.0.1
authorHannu Nyman <hannu.nyman@iki.fi>
Fri, 5 Jan 2018 21:27:17 +0000 (23:27 +0200)
committerJohn Crispin <john@phrozen.org>
Wed, 17 Jan 2018 07:52:54 +0000 (08:52 +0100)
Update scons to 3.0.1

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
tools/scons/Makefile
tools/scons/patches/001-platform_env.patch

index a148a5c9c859054e0bc19f613eea9042b1b4d367..fc325bff02a612996bc861c2cae1adee0e5ccc83 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=scons
-PKG_VERSION:=2.5.1
+PKG_VERSION:=3.0.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/scons \
                http://fossies.org/linux/misc/
-PKG_HASH:=0b25218ae7b46a967db42f2a53721645b3d42874a65f9552ad16ce26d30f51f2
+PKG_HASH:=24475e38d39c19683bc88054524df018fe6949d70fbd4c69e298d39a0269f173
 
 include $(INCLUDE_DIR)/host-build.mk
 
index 8aab9041c773a4d4daf2860a9da29e9d12e0b909..2be31470c27d86d7dda872348d4624e313dfcb7b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/engine/SCons/Platform/__init__.py
 +++ b/engine/SCons/Platform/__init__.py
-@@ -63,6 +63,8 @@ def platform_default():
+@@ -65,6 +65,8 @@ def platform_default():
      care about the machine architecture.
      """
      osname = os.name