ramips: Improve Sanlinking D240 config
authorKristian Evensen <kristian.evensen@gmail.com>
Thu, 2 Mar 2017 12:44:02 +0000 (13:44 +0100)
committerJohn Crispin <john@phrozen.org>
Sat, 11 Mar 2017 07:36:52 +0000 (08:36 +0100)
* The left most mini-PCIe slot (the one attached to SIM2) can be
power-cycled by setting GPIO 0 to high/low.

* The D240 only needs the MT76x2 module, so update makefile to reflect this.
Note that until the default mt7620 target is updated, then kmod-mt76 (and thus
kmod-mt7603) will be selected by default.

v2->v3:
* Indentation error.

v1->v2:
* Rename gpio and remove redundant comment (thanks Piotr Dymacz)

Signed-off-by: Kristian Evensen <kristian.evensen@gmail.com>
target/linux/ramips/dts/D240.dts
target/linux/ramips/image/mt7620.mk

index ef45d38e619f258cf36fdc413366125952db2fd7..46d014126d6784e41e90e8c0b3fd6900fd8c671d 100644 (file)
                bootargs = "console=ttyS0,115200";
        };
 
+       gpio-export {
+               compatible = "gpio-export";
+               #size-cells = <0>;
+
+               power_mpcie2 {
+                       gpio-export,name = "power_mpcie2";
+                       gpio-export,output = <GPIO_ACTIVE_LOW>;
+                       gpios = <&gpio0 0 GPIO_ACTIVE_HIGH>;
+               };
+       };
+
        gpio-leds {
                compatible = "gpio-leds";
 
index ece15397140c54cba756f1e922dd15b51b1832a1..3ecd4ba3a10a17cde9783d5e86761519e44c9b6d 100644 (file)
@@ -471,6 +471,6 @@ define Device/d240
   DTS := D240
   IMAGE_SIZE := $(ralink_default_fw_size_16M)
   DEVICE_TITLE := Sanlinking Technologies D240
-  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-mt76 kmod-sdhci-mt7620
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-mt76-core kmod-mt76x2 kmod-sdhci-mt7620
 endef
 TARGET_DEVICES += d240