openssl: fix build failure on arm, aes asm version is not shipped anymore (closes...
authorNicolas Thill <nico@openwrt.org>
Tue, 2 Mar 2010 04:56:49 +0000 (04:56 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 2 Mar 2010 04:56:49 +0000 (04:56 +0000)
SVN-Revision: 19945

package/openssl/Makefile
package/openssl/patches/310-arm_asm.patch [deleted file]

index 3b99c08684992479e58809b62844ccf90da12680..ef0edb0daf2ff7bf1a8d9216c15d45a9e2984925 100644 (file)
@@ -82,11 +82,7 @@ else
   OPENSSL_OPTIONS += no-engines
 endif
 
-ifdef CONFIG_arm
-OPENSSL_MAKEFLAGS := AES_ASM_OBJ="aes-armv4.o aes_cbc.o"
-else
 OPENSSL_OPTIONS += no-perlasm
-endif
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
diff --git a/package/openssl/patches/310-arm_asm.patch b/package/openssl/patches/310-arm_asm.patch
deleted file mode 100644 (file)
index 9b53a22..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/crypto/aes/Makefile
-+++ b/crypto/aes/Makefile
-@@ -47,6 +47,9 @@ lib: $(LIBOBJ)
- $(LIBOBJ): $(LIBSRC)
-+aes-armv4.s: asm/aes-armv4.pl
-+      $(PERL) $^ > $@
-+
- aes-ia64.s: asm/aes-ia64.S
-       $(CC) $(CFLAGS) -E asm/aes-ia64.S > $@