tools/xz: disable shared library
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 14 Sep 2015 14:03:21 +0000 (14:03 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 14 Sep 2015 14:03:21 +0000 (14:03 +0000)
Force a static build of the xz utilities in order to avoid the dependency on a
shared liblzma.so which might collide with the distro version.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 46907

tools/xz/Makefile

index e266667957852c8f3769ea97e9cb5d5206a2d7a6..d1f10081aebc55d5a877a3295ec61af0ecd32635 100644 (file)
@@ -17,6 +17,10 @@ HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOST_CONFIGURE_ARGS += \
+       --enable-static=yes \
+       --enable-shared=no \
+
 define Host/Install
        +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat"
 endef