ramips: fix Aigale Ai-BR100 dts and profile names
authorJohn Crispin <john@openwrt.org>
Mon, 17 Aug 2015 05:59:36 +0000 (05:59 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 17 Aug 2015 05:59:36 +0000 (05:59 +0000)
The following patch changes dts filename and profile name for Aigale Ai-BR100 (for consistency).

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
SVN-Revision: 46624

target/linux/ramips/dts/AI-BR100.dts [new file with mode: 0644]
target/linux/ramips/dts/AIBR100.dts [deleted file]
target/linux/ramips/image/Makefile
target/linux/ramips/mt7620/profiles/aigale.mk

diff --git a/target/linux/ramips/dts/AI-BR100.dts b/target/linux/ramips/dts/AI-BR100.dts
new file mode 100644 (file)
index 0000000..90195b6
--- /dev/null
@@ -0,0 +1,109 @@
+/dts-v1/;
+
+/include/ "mt7620a.dtsi"
+
+/ {
+       compatible = "AI-BR100", "ralink,mt7620a-soc";
+       model = "Aigale Ai-BR100";
+
+       palmbus@10000000 {
+               gpio2: gpio@660 {
+                       status = "okay";
+               };
+
+               gpio3: gpio@688 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "en25q64";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "en25q64";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x20000>;
+                                       read-only;
+                               };
+
+                               partition@20000 {
+                                       label = "u-boot-env";
+                                       reg = <0x20000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@30000 {
+                                       label = "factory";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@40000 {
+                                       label = "firmware";
+                                       reg = <0x40000 0x7c0000>;
+                               };
+                       };
+               };
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "uartf", "rgmii1", "rgmii2", "ephy", "wled", "nd_sd";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               pinctrl-names = "default";
+               pinctrl-0 = <&ephy_pins>;
+               mtd-mac-address = <&factory 0x4>;
+               ralink,port-map = "llllw";
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               wan {
+                       label = "aigale:blue:wan";
+                       gpios = <&gpio2 4 1>;
+               };
+
+               wlan {
+                       label = "aigale:blue:wlan";
+                       gpios = <&gpio3 0 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 12 1>;
+                       linux,code = <0x198>;
+               };
+       };
+};
diff --git a/target/linux/ramips/dts/AIBR100.dts b/target/linux/ramips/dts/AIBR100.dts
deleted file mode 100644 (file)
index 963e835..0000000
+++ /dev/null
@@ -1,109 +0,0 @@
-/dts-v1/;
-
-/include/ "mt7620a.dtsi"
-
-/ {
-       compatible = "AIBR100", "ralink,mt7620a-soc";
-       model = "Aigale Ai-BR100";
-
-       palmbus@10000000 {
-               gpio2: gpio@660 {
-                       status = "okay";
-               };
-
-               gpio3: gpio@688 {
-                       status = "okay";
-               };
-
-               spi@b00 {
-                       status = "okay";
-
-                       m25p80@0 {
-                               #address-cells = <1>;
-                               #size-cells = <1>;
-                               compatible = "en25q64";
-                               reg = <0 0>;
-                               linux,modalias = "m25p80", "en25q64";
-                               spi-max-frequency = <10000000>;
-
-                               partition@0 {
-                                       label = "u-boot";
-                                       reg = <0x0 0x20000>;
-                                       read-only;
-                               };
-
-                               partition@20000 {
-                                       label = "u-boot-env";
-                                       reg = <0x20000 0x10000>;
-                                       read-only;
-                               };
-
-                               factory: partition@30000 {
-                                       label = "factory";
-                                       reg = <0x30000 0x10000>;
-                                       read-only;
-                               };
-
-                               partition@40000 {
-                                       label = "firmware";
-                                       reg = <0x40000 0x7c0000>;
-                               };
-                       };
-               };
-       };
-
-       ehci@101c0000 {
-               status = "okay";
-       };
-
-       ohci@101c1000 {
-               status = "okay";
-       };
-
-       pinctrl {
-               state_default: pinctrl0 {
-                       gpio {
-                               ralink,group = "i2c", "uartf", "rgmii1", "rgmii2", "ephy", "wled", "nd_sd";
-                               ralink,function = "gpio";
-                       };
-               };
-       };
-
-       ethernet@10100000 {
-               pinctrl-names = "default";
-               pinctrl-0 = <&ephy_pins>;
-               mtd-mac-address = <&factory 0x4>;
-               ralink,port-map = "llllw";
-       };
-
-       wmac@10180000 {
-               ralink,mtd-eeprom = <&factory 0>;
-       };
-
-       gpio-leds {
-               compatible = "gpio-leds";
-
-               wan {
-                       label = "aigale:blue:wan";
-                       gpios = <&gpio2 4 1>;
-               };
-
-               wlan {
-                       label = "aigale:blue:wlan";
-                       gpios = <&gpio3 0 1>;
-               };
-       };
-
-       gpio-keys-polled {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <20>;
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio0 12 1>;
-                       linux,code = <0x198>;
-               };
-       };
-};
index e3ff8e60738ff5a6c1571c463667c9d68157b4c0..ae89d6ccabcf3d5e42a6c3b78c7b74f003cf1bd5 100644 (file)
@@ -856,7 +856,7 @@ Image/Build/Profile/MT7620a_MT7610e=$(call BuildFirmware/Default8M/$(1),$(1),mt7
 Image/Build/Profile/MT7620a_MT7530=$(call BuildFirmware/Default8M/$(1),$(1),mt7620a_mt7530,MT7620a_MT7530)
 Image/Build/Profile/MT7620a_V22SG=$(call BuildFirmware/Default8M/$(1),$(1),mt7620a_v22sg,MT7620a_V22SG)
 br100_mtd_size=8126464
-Image/Build/Profile/AIBR100=$(call BuildFirmware/CustomFlash/$(1),$(1),ai-br100,AIBR100,$(br100_mtd_size),Ai-BR)
+Image/Build/Profile/AI-BR100=$(call BuildFirmware/CustomFlash/$(1),$(1),ai-br100,AI-BR100,$(br100_mtd_size),Ai-BR)
 Image/Build/Profile/RP-N53=$(call BuildFirmware/Default8M/$(1),$(1),rp-n53,RP-N53)
 whr_300hp2_mtd_size=7012352
 Image/Build/Profile/WHR300HP2=$(call BuildFirmware/CustomFlash/$(1),$(1),whr-300hp2,WHR-300HP2,$(whr_300hp2_mtd_size))
@@ -894,7 +894,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/MT7620a_MT7610e,$(1))
        $(call Image/Build/Profile/MT7620a_MT7530,$(1))
        $(call Image/Build/Profile/MT7620a_V22SG,$(1))
-       $(call Image/Build/Profile/AIBR100,$(1))
+       $(call Image/Build/Profile/AI-BR100,$(1))
        $(call Image/Build/Profile/CF-WR800N,$(1))
        $(call Image/Build/Profile/RP-N53,$(1))
        $(call Image/Build/Profile/DIR-810L,$(1))
index 475aac9562a16110c47af4fe28180f3ea105587d..629a378cae071e4b8adaab92ba52f9fc2c4432c4 100644 (file)
@@ -5,12 +5,12 @@
 # See /LICENSE for more information.
 #
 
-define Profile/AIBR100
+define Profile/AI-BR100
        NAME:=Aigale Ai-BR100
        PACKAGES:=kmod-usb-ohci kmod-usb2
 endef
 
-define Profile/AIBR100/Description
+define Profile/AI-BR100/Description
        Default package set for Aigale Ai-BR100.
 endef
-$(eval $(call Profile,AIBR100))
+$(eval $(call Profile,AI-BR100))