ramips: drop AsiaRF AWM003 eval board
authorMathias Kresin <dev@kresin.me>
Sun, 30 Jul 2017 09:16:09 +0000 (11:16 +0200)
committerMathias Kresin <dev@kresin.me>
Wed, 2 Aug 2017 22:11:25 +0000 (00:11 +0200)
Everything is identical to the AWM002 8m eval board. No need to
duplicate it once more.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/AWM003-EVB.dts [deleted file]
target/linux/ramips/image/rt305x.mk

index 7de6377c747be393626f17559785289464183d3f..37984a81af03ff7ed5be9f7e62dd1a0a6c6d4693 100755 (executable)
@@ -153,7 +153,6 @@ ramips_setup_interfaces()
        atp-52b|\
        awm002-evb-4M|\
        awm002-evb-8M|\
-       awm003-evb|\
        c20i|\
        dir-645|\
        f5d8235-v2|\
index cb8031fd82d58f0bfa6e28b358719e21191a5814..1dc1391800ec3021a0c13c4b49a51cb315da9e94 100755 (executable)
@@ -76,9 +76,6 @@ ramips_board_detect() {
        *"AWM002 EVB (8M)")
                name="awm002-evb-8M"
                ;;
-       *"AWM003 EVB")
-               name="awm003-evb"
-               ;;
        *"BC2")
                name="bc2"
                ;;
index 14f5ec2cb3e380728be2ba25c4efbe9098104864..085bf94aacc08bb5bb500bac9c9b2c898a123ae4 100755 (executable)
@@ -27,7 +27,6 @@ platform_check_image() {
        awapn2403|\
        awm002-evb-4M|\
        awm002-evb-8M|\
-       awm003-evb|\
        bc2|\
        broadway|\
        carambola|\
diff --git a/target/linux/ramips/dts/AWM003-EVB.dts b/target/linux/ramips/dts/AWM003-EVB.dts
deleted file mode 100644 (file)
index 7c23f34..0000000
+++ /dev/null
@@ -1,65 +0,0 @@
-/dts-v1/;
-
-#include "AWM002-8M.dtsi"
-
-#include <dt-bindings/input/input.h>
-
-/ {
-       compatible = "AWM003", "ralink,rt5350-soc";
-       model = "AsiaRF AWM003 EVB";
-
-       memory@0 {
-               device_type = "memory";
-               reg = <0x0 0x4000000>;
-       };
-
-       gpio-leds {
-               compatible = "gpio-leds";
-
-               tx {
-                       label = "awm003-evb:green:tx";
-                       gpios = <&gpio0 15 1>;
-               };
-
-               rx {
-                       label = "awm003-evb:green:rx";
-                       gpios = <&gpio0 16 1>;
-               };
-
-               wps {
-                       label = "awm003-evb:green:wps";
-                       gpios = <&gpio0 21 1>;
-               };
-       };
-
-       gpio-keys-polled {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <20>;
-
-               reset_wps {
-                       label = "reset_wps";
-                       gpios = <&gpio0 0 1>;
-                       linux,code = <KEY_RESTART>;
-               };
-
-               mode {
-                       label = "mode";
-                       gpios = <&gpio0 20 1>;
-                       linux,code = <BTN_0>;
-               };
-       };
-};
-
-&m25p80 {
-       compatible = "jedec,spi-nor";
-};
-
-&ethernet {
-       mtd-mac-address = <&factory 0x28>;
-};
-
-&wmac {
-       ralink,mtd-eeprom = <&factory 0>;
-};
index 0735798a879e1a040c66ff18abf4a93e96c86afe..013f6c117892af885ab869df73a761d6c03895d8 100644 (file)
@@ -144,18 +144,12 @@ TARGET_DEVICES += awm002-evb-4M
 
 define Device/awm002-evb-8M
   DTS := AWM002-EVB-8M
-  DEVICE_TITLE := AsiaRF AWM002-EVB (8M)
+  DEVICE_TITLE := AsiaRF AWM002-EVB (8M)/AsiaRF AWM003 EVB
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
                kmod-i2c-core kmod-i2c-gpio
 endef
 TARGET_DEVICES += awm002-evb-8M
 
-define Device/awm003-evb
-  DTS := AWM003-EVB
-  DEVICE_TITLE := AsiaRF AWM003 EVB
-endef
-TARGET_DEVICES += awm003-evb
-
 define Device/awapn2403
   DTS := AWAPN2403
   BLOCKSIZE := 4k