hostapd: recognize option "key" as alias for "auth_secret"
authorJo-Philipp Wich <jo@mein.io>
Fri, 7 Aug 2020 19:19:29 +0000 (21:19 +0200)
committerJo-Philipp Wich <jo@mein.io>
Fri, 7 Aug 2020 19:19:29 +0000 (21:19 +0200)
The hostapd configuration logic is supposed to accept "option key" as
legacy alias for "option auth_secret". This particular fallback option
failed to work though because "key" was not a registered configuration
variable.

Fix this issue by registering the "key" option as well, similar to the
existing "server" nad "port" options.

Ref: https://github.com/openwrt/openwrt/pull/3282
Suggested-by: Michael Jones <mike@meshplusplus.com>
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/network/services/hostapd/Makefile
package/network/services/hostapd/files/hostapd.sh

index b3e93cb77002565a3531874cbb87e567c2de6c74..3aa17b4d3a036bc36a398cf01444bed2de6e4ed4 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_PROTO:=git
index 5cab11022fbcbed834f9831e7e203e42c75f7ad2..fe5b407bc15b47e4ddc894843490e260b40a1c51 100644 (file)
@@ -196,7 +196,7 @@ hostapd_common_add_bss_config() {
        config_add_int eapol_version
 
        config_add_string 'auth_server:host' 'server:host'
-       config_add_string auth_secret
+       config_add_string auth_secret key
        config_add_int 'auth_port:port' 'port:port'
 
        config_add_string acct_server