avr32 build fixes
authorImre Kaloz <kaloz@openwrt.org>
Tue, 17 Jul 2007 10:38:33 +0000 (10:38 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Tue, 17 Jul 2007 10:38:33 +0000 (10:38 +0000)
SVN-Revision: 8017

package/acx/Makefile
package/gmp/patches/001-fat_fix.diff [new file with mode: 0644]
package/hostapd/Makefile
package/madwifi/Makefile
package/wpa_supplicant/files/config.avr32 [new file with mode: 0644]

index 70d394de5d584acd250823fc376e412c6338dbe4..85837cf08c2dc5f9d403424cbb778807c332f99b 100644 (file)
@@ -26,7 +26,7 @@ include $(INCLUDE_DIR)/package.mk
 
 define KernelPackage/acx
   TITLE:=Driver for TI ACX1xx chipset
-  DEPENDS:=@LINUX_2_6 +wireless-tools
+  DEPENDS:=@LINUX_2_6&&!LINUX_2_6_AVR32 +wireless-tools
   DESCRIPTION:=\
        This package contains a driver for TI ACX1xx 802.11a/b/g chipsets.
   URL:=http://acx100.sourceforge.net/
diff --git a/package/gmp/patches/001-fat_fix.diff b/package/gmp/patches/001-fat_fix.diff
new file mode 100644 (file)
index 0000000..3c4d7da
--- /dev/null
@@ -0,0 +1,83 @@
+diff -Nur gmp-4.2.1/configure gmp-4.2.1-owrt/configure
+--- gmp-4.2.1/configure        2006-05-04 18:50:26.000000000 +0200
++++ gmp-4.2.1-owrt/configure   2007-07-17 10:38:53.000000000 +0200
+@@ -3549,8 +3549,10 @@
+       *)                    path="x86" ;;
+     esac
+-    # If the user asked for a fat build, override the path set above
++    # If the user asked for a fat build, override the path and flags set above
+     if test $enable_fat = yes; then
++      gcc_cflags_cpu=""
++      gcc_cflags_arch=""
+       extra_functions="$extra_functions fat fat_entry"
+       path="x86/fat x86"
+       fat_path="x86 x86/fat x86/i486
+diff -Nur gmp-4.2.1/mpn/generic/addsub_n.c gmp-4.2.1-owrt/mpn/generic/addsub_n.c
+--- gmp-4.2.1/mpn/generic/addsub_n.c   2006-03-14 16:57:54.000000000 +0100
++++ gmp-4.2.1-owrt/mpn/generic/addsub_n.c      2007-07-17 10:38:53.000000000 +0200
+@@ -1,6 +1,6 @@
+ /* mpn_addsub_n -- Add and Subtract two limb vectors of equal, non-zero length.
+-Copyright 1999, 2000, 2001 Free Software Foundation, Inc.
++Copyright 1999, 2000, 2001, 2006 Free Software Foundation, Inc.
+ This file is part of the GNU MP Library.
+@@ -58,13 +58,13 @@
+       for (off = 0; off < n; off += PART_SIZE)
+       {
+         this_n = MIN (n - off, PART_SIZE);
+-#if HAVE_NATIVE_mpn_add_nc || !HAVE_NATIVE_mpn_add_n
++#if HAVE_NATIVE_mpn_add_nc
+         acyo = mpn_add_nc (r1p + off, s1p + off, s2p + off, this_n, acyo);
+ #else
+         acyn = mpn_add_n (r1p + off, s1p + off, s2p + off, this_n);
+         acyo = acyn + mpn_add_1 (r1p + off, r1p + off, this_n, acyo);
+ #endif
+-#if HAVE_NATIVE_mpn_sub_nc || !HAVE_NATIVE_mpn_sub_n
++#if HAVE_NATIVE_mpn_sub_nc
+         scyo = mpn_sub_nc (r2p + off, s1p + off, s2p + off, this_n, scyo);
+ #else
+         scyn = mpn_sub_n (r2p + off, s1p + off, s2p + off, this_n);
+@@ -81,13 +81,13 @@
+       for (off = 0; off < n; off += PART_SIZE)
+       {
+         this_n = MIN (n - off, PART_SIZE);
+-#if HAVE_NATIVE_mpn_sub_nc || !HAVE_NATIVE_mpn_sub_n
++#if HAVE_NATIVE_mpn_sub_nc
+         scyo = mpn_sub_nc (r2p + off, s1p + off, s2p + off, this_n, scyo);
+ #else
+         scyn = mpn_sub_n (r2p + off, s1p + off, s2p + off, this_n);
+         scyo = scyn + mpn_sub_1 (r2p + off, r2p + off, this_n, scyo);
+ #endif
+-#if HAVE_NATIVE_mpn_add_nc || !HAVE_NATIVE_mpn_add_n
++#if HAVE_NATIVE_mpn_add_nc
+         acyo = mpn_add_nc (r1p + off, s1p + off, s2p + off, this_n, acyo);
+ #else
+         acyn = mpn_add_n (r1p + off, s1p + off, s2p + off, this_n);
+@@ -97,7 +97,7 @@
+     }
+   else
+     {
+-      /* r1 and r2 are identical to s1 and s2 (r1==s1 and r2=s2 or vice versa)
++      /* r1 and r2 are identical to s1 and s2 (r1==s1 and r2==s2 or vice versa)
+        Need temporary storage.  */
+       mp_limb_t tp[PART_SIZE];
+       acyo = 0;
+@@ -105,13 +105,13 @@
+       for (off = 0; off < n; off += PART_SIZE)
+       {
+         this_n = MIN (n - off, PART_SIZE);
+-#if HAVE_NATIVE_mpn_add_nc || !HAVE_NATIVE_mpn_add_n
++#if HAVE_NATIVE_mpn_add_nc
+         acyo = mpn_add_nc (tp, s1p + off, s2p + off, this_n, acyo);
+ #else
+         acyn = mpn_add_n (tp, s1p + off, s2p + off, this_n);
+         acyo = acyn + mpn_add_1 (tp, tp, this_n, acyo);
+ #endif
+-#if HAVE_NATIVE_mpn_sub_nc || !HAVE_NATIVE_mpn_sub_n
++#if HAVE_NATIVE_mpn_sub_nc
+         scyo = mpn_sub_nc (r2p + off, s1p + off, s2p + off, this_n, scyo);
+ #else
+         scyn = mpn_sub_n (r2p + off, s1p + off, s2p + off, this_n);
index e500b87bd0b508ce3fc775040dc8a929fb77a3d6..7e0f0877f68320b9449615c74de4a82ed94ad82f 100644 (file)
@@ -29,7 +29,7 @@ endef
 
 define Package/hostapd
   $(call Package/hostapd/Default)
-  DEPENDS:=+libopenssl
+  DEPENDS:=+libopenssl @!LINUX_2_6_AVR32
   TITLE+= (full)
   DESCRIPTION:=\
        This package contains a full featured IEEE 802.1x/WPA/EAP/RADIUS \\\
@@ -42,6 +42,7 @@ endef
 
 define Package/hostapd-mini
   $(call Package/hostapd/Default)
+  DEPENDS:=@!LINUX_2_6_AVR32
   TITLE+= (WPA-PSK only)
   DESCRIPTION:=\
        This package contains a minimal IEEE 802.1x/WPA/EAP/RADIUS Authenticator \\\
index 4aa4e0a746bba5ce786c2a5402020cdaf06d8dcc..907f19117992a7eff1dedd40f7f279135d28b46f 100644 (file)
@@ -81,7 +81,7 @@ endif
 define KernelPackage/madwifi
   SUBMENU:=Wireless Drivers
   TITLE:=Driver for Atheros wireless chipsets
-  DEPENDS:=+wireless-tools
+  DEPENDS:=+wireless-tools @!LINUX_2_6_AVR32
   DESCRIPTION:=\
        This package contains a driver for Atheros 802.11a/b/g chipsets.
   URL:=http://madwifi.org/
diff --git a/package/wpa_supplicant/files/config.avr32 b/package/wpa_supplicant/files/config.avr32
new file mode 100644 (file)
index 0000000..4319456
--- /dev/null
@@ -0,0 +1,139 @@
+# Driver interface for Host AP driver
+#CONFIG_DRIVER_HOSTAP=y
+
+# Driver interface for Agere driver
+#CONFIG_DRIVER_HERMES=y
+# Change include directories to match with the local setup
+#CFLAGS += -I../../hcf -I../../include -I../../include/hcf
+#CFLAGS += -I../../include/wireless
+
+# Driver interface for madwifi driver
+#CONFIG_DRIVER_MADWIFI=y
+# Change include directories to match with the local setup
+#CFLAGS += -I../madwifi/wpa
+
+# Driver interface for Prism54 driver
+# (Note: Prism54 is not yet supported, i.e., this will not work as-is and is
+# for developers only)
+#CONFIG_DRIVER_PRISM54=y
+
+# Driver interface for ndiswrapper
+#CONFIG_DRIVER_NDISWRAPPER=y
+
+# Driver interface for Atmel driver
+#CONFIG_DRIVER_ATMEL=y
+
+# Driver interface for Broadcom driver
+# CONFIG_DRIVER_BROADCOM=y
+# Example path for wlioctl.h; change to match your configuration
+# CFLAGS += -I../nvram/include
+
+# Driver interface for Intel ipw2100/2200 driver
+#CONFIG_DRIVER_IPW=y
+
+# Driver interface for generic Linux wireless extensions
+CONFIG_DRIVER_WEXT=y
+
+# Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
+#CONFIG_DRIVER_BSD=y
+#CFLAGS += -I/usr/local/include
+#LIBS += -L/usr/local/lib
+
+# Driver interface for Windows NDIS
+#CONFIG_DRIVER_NDIS=y
+#CFLAGS += -I/usr/include/w32api/ddk
+#LIBS += -L/usr/local/lib
+# For native build using mingw
+#CONFIG_NATIVE_WINDOWS=y
+# Additional directories for cross-compilation on Linux host for mingw target
+#CFLAGS += -I/opt/mingw/mingw32/include/ddk
+#LIBS += -L/opt/mingw/mingw32/lib
+#CC=mingw32-gcc
+
+# Driver interface for development testing
+#CONFIG_DRIVER_TEST=y
+
+# Driver interface for wired Ethernet drivers
+CONFIG_DRIVER_WIRED=y
+
+# Enable IEEE 802.1X Supplicant (automatically included if any EAP method is
+# included)
+CONFIG_IEEE8021X_EAPOL=y
+
+# EAP-MD5 (automatically included if EAP-TTLS is enabled)
+CONFIG_EAP_MD5=y
+
+# EAP-MSCHAPv2 (automatically included if EAP-PEAP is enabled)
+CONFIG_EAP_MSCHAPV2=y
+
+# EAP-TLS
+CONFIG_EAP_TLS=y
+
+# EAL-PEAP
+CONFIG_EAP_PEAP=y
+
+# EAP-TTLS
+CONFIG_EAP_TTLS=y
+
+# EAP-GTC
+CONFIG_EAP_GTC=y
+
+# EAP-OTP
+CONFIG_EAP_OTP=y
+
+# EAP-SIM (enable CONFIG_PCSC, if EAP-SIM is used)
+#CONFIG_EAP_SIM=y
+
+# EAP-PSK (experimental; this is _not_ needed for WPA-PSK)
+#CONFIG_EAP_PSK=y
+
+# EAP-PAX
+#CONFIG_EAP_PAX=y
+
+# LEAP
+CONFIG_EAP_LEAP=y
+
+# EAP-AKA (enable CONFIG_PCSC, if EAP-AKA is used)
+#CONFIG_EAP_AKA=y
+
+# PKCS#12 (PFX) support (used to read private key and certificate file from
+# a file that usually has extension .p12 or .pfx)
+CONFIG_PKCS12=y
+
+# Smartcard support (i.e., private key on a smartcard), e.g., with openssl
+# engine.
+CONFIG_SMARTCARD=y
+
+# PC/SC interface for smartcards (USIM, GSM SIM)
+# Enable this if EAP-SIM or EAP-AKA is included
+#CONFIG_PCSC=y
+
+# Development testing
+#CONFIG_EAPOL_TEST=y
+
+# Replace native Linux implementation of packet sockets with libdnet/libpcap.
+# This will be automatically set for non-Linux OS.
+#CONFIG_DNET_PCAP=y
+
+# Include control interface for external programs, e.g, wpa_cli
+CONFIG_CTRL_IFACE=y
+
+# Include support for GNU Readline and History Libraries in wpa_cli.
+# When building a wpa_cli binary for distribution, please note that these
+# libraries are licensed under GPL and as such, BSD license may not apply for
+# the resulting binary.
+#CONFIG_READLINE=y
+
+# Remove debugging code that is printing out debug message to stdout.
+# This can be used to reduce the size of the wpa_supplicant considerably
+# if debugging code is not needed. The size reduction can be around 35%
+# (e.g., 90 kB).
+#CONFIG_NO_STDOUT_DEBUG=y
+
+# Remove WPA support, e.g., for wired-only IEEE 802.1X supplicant, to save
+# 35-50 kB in code size.
+#CONFIG_NO_WPA=y
+
+# Select configuration backend:
+# file = text file (e.g., wpa_supplicant.conf)
+CONFIG_BACKEND=file