package/boot: update uboot-kirkwood to 2017.03
authorPaul Wassi <p.wassi@gmx.at>
Wed, 15 Mar 2017 06:37:48 +0000 (07:37 +0100)
committerJohn Crispin <john@phrozen.org>
Mon, 20 Mar 2017 07:19:35 +0000 (08:19 +0100)
Bump uboot-kirkwood to upstream release 2017.03

Signed-off-by: Paul Wassi <p.wassi@gmx.at>
package/boot/uboot-kirkwood/Makefile
package/boot/uboot-kirkwood/patches/007-nsa310-uboot-generic.patch
package/boot/uboot-kirkwood/patches/008-nsa325-uboot-generic.patch
package/boot/uboot-kirkwood/patches/110-dockstar.patch
package/boot/uboot-kirkwood/patches/120-iconnect.patch
package/boot/uboot-kirkwood/patches/130-ib62x0.patch
package/boot/uboot-kirkwood/patches/140-pogoplug_e02.patch
package/boot/uboot-kirkwood/patches/150-goflexhome.patch
package/boot/uboot-kirkwood/patches/200-openwrt-config.patch

index e06a680b703888d99dc74a58611170e415eb62a1..c2d8eaa73ce72f6a6122eaabf2dadfe7375ed8bf 100644 (file)
@@ -7,10 +7,10 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_VERSION:=2016.09.01
+PKG_VERSION:=2017.03
 PKG_RELEASE:=1
 
-PKG_HASH:=95728e89dd476d17428f94080752ab48884be477b6a678941582aeef618b70bb
+PKG_HASH:=f54baf3f9325bf444c7905f3a5b6f83680edb1e6e1a4d5f8a5ad80abe885113f
 
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
index 5a2e5d73d7f3647e438629d5ca53ac6fabc40239..3384c5ee28f4989cc1263b8d9d4003556231778a 100644 (file)
@@ -27,7 +27,7 @@ diff --git a/arch/arm/mach-kirkwood/Kconfig b/arch/arm/mach-kirkwood/Kconfig
 index 9205b1e..819bd3b 100644
 --- a/arch/arm/mach-kirkwood/Kconfig
 +++ b/arch/arm/mach-kirkwood/Kconfig
-@@ -49,6 +49,9 @@ config TARGET_GOFLEXHOME
+@@ -53,6 +53,9 @@ config TARGET_GOFLEXHOME
  config TARGET_NAS220
        bool "BlackArmor NAS220"
 
@@ -37,7 +37,7 @@ index 9205b1e..819bd3b 100644
  config TARGET_NSA310S
        bool "Zyxel NSA310S"
 
-@@ -72,6 +75,7 @@ source "board/raidsonic/ib62x0/Kconfig"
+@@ -77,6 +80,7 @@ source "board/raidsonic/ib62x0/Kconfig"
  source "board/Seagate/dockstar/Kconfig"
  source "board/Seagate/goflexhome/Kconfig"
  source "board/Seagate/nas220/Kconfig"
index bb179b95a6270bec975a1f6a73daf0c5766ad8d1..84ea0e709e2313489a0baabf14afdb4939366c41 100644 (file)
@@ -2,7 +2,7 @@ diff --git a/arch/arm/mach-kirkwood/Kconfig b/arch/arm/mach-kirkwood/Kconfig
 index 819bd3b..6a2d578 100644
 --- a/arch/arm/mach-kirkwood/Kconfig
 +++ b/arch/arm/mach-kirkwood/Kconfig
-@@ -55,6 +55,9 @@ config TARGET_NSA310
+@@ -59,6 +59,9 @@ config TARGET_NSA310
  config TARGET_NSA310S
        bool "Zyxel NSA310S"
 
@@ -12,7 +12,7 @@ index 819bd3b..6a2d578 100644
  endchoice
 
  config SYS_SOC
-@@ -77,5 +80,6 @@ source "board/Seagate/goflexhome/Kconfig"
+@@ -82,5 +85,6 @@ source "board/Seagate/goflexhome/Kconfig"
  source "board/Seagate/nas220/Kconfig"
  source "board/zyxel/nsa310/Kconfig"
  source "board/zyxel/nsa310s/Kconfig"
index 07d65de174abf19eb8fda95319112f468b8376dd..46b838f30b99cf7f6249661210ef20f4ecd5b170 100644 (file)
@@ -1,14 +1,14 @@
 --- a/include/configs/dockstar.h
 +++ b/include/configs/dockstar.h
-@@ -31,6 +31,7 @@
-  * Commands configuration
-  */
- #define CONFIG_SYS_NO_FLASH           /* Declare no flash (NOR/SPI) */
+@@ -19,6 +19,7 @@
+ #define CONFIG_KW88F6281      1       /* SOC Name */
#define CONFIG_MACH_DOCKSTAR  /* Machine type */
+ #define CONFIG_SKIP_LOWLEVEL_INIT     /* disable board lowlevel_init */
 +#define CONFIG_SYS_MVFS
- #define CONFIG_CMD_ENV
- #define CONFIG_CMD_NAND
  /*
-@@ -53,29 +54,29 @@
+  * Commands configuration
+@@ -45,29 +46,29 @@
   * it has to be rounded to sector size
   */
  #define CONFIG_ENV_SIZE                       0x20000 /* 128k */
 -      "ubifsload 0x800000 ${kernel}; " \
 -      "ubifsload 0x1100000 ${initrd}; " \
 -      "bootm 0x800000 0x1100000"
+-
+-#define CONFIG_MTDPARTS               "mtdparts=orion_nand:1m(uboot),-(root)\0"
 +      "ubi part ubi; " \
 +      "ubi read 0x800000 kernel; " \
 +      "bootm 0x800000"
--#define CONFIG_MTDPARTS               "mtdparts=orion_nand:1m(uboot),-(root)\0"
++
 +#define CONFIG_MTDPARTS \
 +      "mtdparts=orion_nand:"                          \
 +      "0xe0000@0x0(uboot),"                           \
index 102a147c2f1f0543546380cf1e907dcd46735278..1f1ce75f252a2d6f539dcb44ad41e09af1a67094 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/configs/iconnect.h
 +++ b/include/configs/iconnect.h
-@@ -59,30 +59,29 @@
+@@ -51,30 +51,29 @@
  #define CONFIG_ENV_IS_NOWHERE
  #endif
  #define CONFIG_ENV_SIZE               0x20000
@@ -42,7 +42,7 @@
   * Ethernet driver configuration
 --- a/configs/iconnect_defconfig
 +++ b/configs/iconnect_defconfig
-@@ -7,6 +7,7 @@ CONFIG_SYS_PROMPT="iconnect => "
+@@ -9,6 +9,7 @@ CONFIG_SYS_PROMPT="iconnect => "
  # CONFIG_CMD_FLASH is not set
  CONFIG_CMD_USB=y
  # CONFIG_CMD_SETEXPR is not set
index f2ba8137abc874b2f9d780b4aaa9a01314238bcd..1be0c62517badacab5e660b074d56063bb1f7dda 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/configs/ib62x0.h
 +++ b/include/configs/ib62x0.h
-@@ -62,27 +62,22 @@
+@@ -54,27 +54,22 @@
   */
  #define CONFIG_BOOTCOMMAND \
        "setenv bootargs ${console} ${mtdparts} ${bootargs_root}; "     \
index f803467739e9ea01a13261c24bb65724212d5112..871affc1afebf323b0bf9a73fb92203224995531 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/configs/pogo_e02.h
 +++ b/include/configs/pogo_e02.h
-@@ -54,23 +54,30 @@
+@@ -49,23 +49,30 @@
  #endif
  
  #define CONFIG_ENV_SIZE                       0x20000 /* 128k */
index 46a6ab561f8a6be59baaa910459b8d6c16a68745..a7fa8e6f93b1cf0d9ab9b21b5e7dd72a050ab50d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/configs/goflexhome.h
 +++ b/include/configs/goflexhome.h
-@@ -87,20 +87,18 @@
+@@ -77,20 +77,18 @@
   */
  #define CONFIG_BOOTCOMMAND \
        "setenv bootargs ${console} ${mtdparts} ${bootargs_root}; " \
index 1f5dd84107813c3087c13a8e1891946c1fc74d5e..fdc06d55978168a0c6c5ff515ccf28712b2ffbed 100644 (file)
@@ -1,8 +1,8 @@
 --- a/arch/arm/mach-kirkwood/Kconfig
 +++ b/arch/arm/mach-kirkwood/Kconfig
-@@ -78,4 +78,7 @@ source "board/Seagate/nas220/Kconfig"
- source "board/zyxel/nsa310/Kconfig"
+@@ -87,4 +87,7 @@ source "board/Seagate/nas220/Kconfig"
  source "board/zyxel/nsa310s/Kconfig"
+ source "board/zyxel/nsa325/Kconfig"
 
 +config SECOND_STAGE
 +      bool "OpenWrt second stage hack"
@@ -10,7 +10,7 @@
  endif
 --- a/include/configs/dockstar.h
 +++ b/include/configs/dockstar.h
-@@ -98,4 +98,6 @@
+@@ -89,4 +89,6 @@
  #define CONFIG_CMD_MTDPARTS
  #define CONFIG_LZO
 
@@ -19,7 +19,7 @@
  #endif /* _CONFIG_DOCKSTAR_H */
 --- a/include/configs/ib62x0.h
 +++ b/include/configs/ib62x0.h
-@@ -108,4 +108,6 @@
+@@ -99,4 +99,6 @@
  #define CONFIG_RTC_MV
  #endif /* CONFIG_CMD_DATE */
 
@@ -28,7 +28,7 @@
  #endif /* _CONFIG_IB62x0_H */
 --- a/include/configs/iconnect.h
 +++ b/include/configs/iconnect.h
-@@ -103,4 +103,6 @@
+@@ -94,4 +94,6 @@
  #define CONFIG_MTD_PARTITIONS
  #define CONFIG_CMD_MTDPARTS
 
@@ -80,7 +80,7 @@
 +#endif /* __OPENWRT_KIRKWOOD_COMMON_H */
 --- a/include/configs/pogo_e02.h
 +++ b/include/configs/pogo_e02.h
-@@ -99,4 +99,6 @@
+@@ -93,4 +93,6 @@
  #define CONFIG_CMD_MTDPARTS
  #define CONFIG_LZO
 
@@ -89,7 +89,7 @@
  #endif /* _CONFIG_POGO_E02_H */
 --- a/include/configs/sheevaplug.h
 +++ b/include/configs/sheevaplug.h
-@@ -109,4 +109,6 @@
+@@ -99,4 +99,6 @@
  #define CONFIG_SYS_ATA_IDE1_OFFSET    MV_SATA_PORT1_OFFSET
  #endif /* CONFIG_CMD_IDE */
 
@@ -98,7 +98,7 @@
  #endif /* _CONFIG_SHEEVAPLUG_H */
 --- a/include/configs/goflexhome.h
 +++ b/include/configs/goflexhome.h
-@@ -122,4 +122,6 @@
+@@ -112,4 +112,6 @@
  #define CONFIG_RTC_MV
  #endif /* CONFIG_CMD_DATE */
 
  #endif /* _CONFIG_GOFLEXHOME_H */
 --- a/include/configs/nsa310.h
 +++ b/include/configs/nsa310.h
-@@ -166,4 +166,6 @@
+@@ -165,4 +165,6 @@
  #define CONFIG_CMD_DNS
  #endif /* CONFIG_CMD_DATE */