quilt: make relocatable, search resources relative to STAGING_DIR
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 20 Jan 2012 17:11:37 +0000 (17:11 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 20 Jan 2012 17:11:37 +0000 (17:11 +0000)
SVN-Revision: 29829

tools/quilt/patches/000-fix_compile.patch [deleted file]
tools/quilt/patches/000-relocatable.patch [new file with mode: 0644]
tools/quilt/patches/001-fix_compile.patch [new file with mode: 0644]

diff --git a/tools/quilt/patches/000-fix_compile.patch b/tools/quilt/patches/000-fix_compile.patch
deleted file mode 100644 (file)
index 51a4f5e..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -273,13 +273,10 @@ $(patsubst %.in,%,$(wildcard bin/*.in qu
- lib/backup-files.o :: Makefile
- configure : configure.ac aclocal.m4
--      autoconf
--      @echo "Please run ./configure"
--      @false
-+      @touch $@
- Makefile : Makefile.in configure
--      @echo "Please run ./configure"
--      @false
-+      @touch $@
- compat_leftover := $(filter-out $(COMPAT),$(shell $(FIND) compat -maxdepth 1 -type f -perm +111))
diff --git a/tools/quilt/patches/000-relocatable.patch b/tools/quilt/patches/000-relocatable.patch
new file mode 100644 (file)
index 0000000..19ff5fd
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/bin/quilt.in
++++ b/bin/quilt.in
+@@ -7,9 +7,15 @@
+ #  See the COPYING and AUTHORS files for more details.
+ export TEXTDOMAIN=quilt
+-export TEXTDOMAINDIR=@LOCALEDIR@
+-: ${QUILT_DIR=@QUILT_DIR@} ${QUILT_LIB=@QUILT_LIB@}
++if test -n "$STAGING_DIR"; then
++      export TEXTDOMAINDIR="$STAGING_DIR/../host/share/locale"
++      : ${QUILT_DIR=$STAGING_DIR/../host/share/quilt} ${QUILT_LIB=$STAGING_DIR/../host/lib/quilt}
++else
++      export TEXTDOMAINDIR=@LOCALEDIR@
++      : ${QUILT_DIR=@QUILT_DIR@} ${QUILT_LIB=@QUILT_LIB@}
++fi
++
+ export QUILT_DIR QUILT_LIB
+ if [ -z "$QUILTRC" ]
diff --git a/tools/quilt/patches/001-fix_compile.patch b/tools/quilt/patches/001-fix_compile.patch
new file mode 100644 (file)
index 0000000..51a4f5e
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -273,13 +273,10 @@ $(patsubst %.in,%,$(wildcard bin/*.in qu
+ lib/backup-files.o :: Makefile
+ configure : configure.ac aclocal.m4
+-      autoconf
+-      @echo "Please run ./configure"
+-      @false
++      @touch $@
+ Makefile : Makefile.in configure
+-      @echo "Please run ./configure"
+-      @false
++      @touch $@
+ compat_leftover := $(filter-out $(COMPAT),$(shell $(FIND) compat -maxdepth 1 -type f -perm +111))