rules.mk: provide a LIBGCC_A variable
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 5 Sep 2011 19:29:22 +0000 (19:29 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 5 Sep 2011 19:29:22 +0000 (19:29 +0000)
SVN-Revision: 28175

rules.mk

index af6cf53261bea0bf0cd5a0d981b880f426fef1ad..53891eaa9759669a56192a2bb29ba5f919f07f5a 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -113,8 +113,10 @@ TARGET_LDFLAGS:=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
 ifneq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
 LIBGCC_S_PATH=$(realpath $(wildcard $(call qstrip,$(CONFIG_LIBGCC_ROOT_DIR))/$(call qstrip,$(CONFIG_LIBGCC_FILE_SPEC))))
 LIBGCC_S=$(if $(LIBGCC_S_PATH),-L$(dir $(LIBGCC_S_PATH)) -lgcc_s)
+LIBGCC_A=$(realpath $(wildcard $(dir $(LIBGCC_S_PATH))/gcc/*/*/libgcc.a))
 else
-LIBGCC_S=$(if $(wildcard $(TOOLCHAIN_DIR)/lib/libgcc_s.so),-L$(TOOLCHAIN_DIR)/lib -lgcc_s,$(wildcard $(TOOLCHAIN_DIR)/lib/gcc/*/*/libgcc.a))
+LIBGCC_A=$(wildcard $(TOOLCHAIN_DIR)/lib/gcc/*/*/libgcc.a)
+LIBGCC_S=$(if $(wildcard $(TOOLCHAIN_DIR)/lib/libgcc_s.so),-L$(TOOLCHAIN_DIR)/lib -lgcc_s,$(LIBGCC_A))
 endif
 ifdef CONFIG_USE_UCLIBC
 LIBRPC=-lrpc