ramips: MiWifi-Nano - change gpios to leds, add to default build group
authorJohn Crispin <john@openwrt.org>
Sun, 20 Mar 2016 14:41:33 +0000 (14:41 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 20 Mar 2016 14:41:33 +0000 (14:41 +0000)
1) Use leds to indicate:
Red - Power
Amber - Radio On
Blue - Wifi associated
2) Add profile to default build group for MT7628 subtarget

Signed-off-by: Noble Pepper <openwrtmail@noblepepper.com>
SVN-Revision: 49045

target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/dts/MIWIFI-NANO.dts
target/linux/ramips/image/Makefile

index 6c25c86753d2443752351e814273020c54eafb32..5816e60f662bab1dff22eabd69274d73d1cdae94 100755 (executable)
@@ -185,6 +185,11 @@ miniembplug)
 miwifi-mini)
        ucidef_set_led_default "power" "power" "$board:red:status" "1"
        ;;
+miwifi-nano)
+       ucidef_set_led_default "power" "power" "$board:red:status" "1"
+       ucidef_set_led_wlan "radio_led" "radio" "$board:amber:radio" "phy0radio"
+       ucidef_set_led_wlan "wifi_led" "wifi" "$board:blue:wifi" "phy0assoc"
+       ;;
 mlw221|\
 mlwg2)
        set_wifi_led "$board:blue:wifi"
index ea7b27035a4f2e703ec64dcd7514036f3f59ac5b..363b90d4ff3874b9b59744a2068efe8f6e697cd7 100644 (file)
        pinctrl {
                state_default: pinctrl0 {
                        gpio {
-                               ralink,group = "gpio";
+                               ralink,group = "refclk", "wled", "gpio";
                                ralink,function = "gpio";
                        };
                };
        };
 
-       gpio-export {
-               compatible = "gpio-export";
-               #size-cells = <0>;
+       gpio-leds {
+               compatible = "gpio-leds";
 
-               gpio11 {
-                       /* blue led */
-                       gpio-export,name = "gpio11";
-                       gpio-export,direction_may_change = <1>;
-                       gpio-export,output = <1>;
-                       gpios = <&gpio0 11 0>;
+               wifi {
+                       label = "miwifi-nano:blue:wifi";
+                       gpios = <&gpio0 11 1>;
+                       default-state = "1";
                };
-
-               gpio37 {
-                       /* red led */
-                       gpio-export,name = "gpio37";
-                       gpio-export,direction_may_change = <1>;
-                       gpio-export,output = <1>;
-                       gpios = <&gpio1 5 0>;
+               status {
+                       label = "miwifi-nano:red:status";
+                       gpios = <&gpio1 5 1>;
+                       default-state = "on";
                };
+               radio {
+                       label = "miwifi-nano:amber:radio";
+                       gpios = <&gpio1 12 1>;
+                       default-state = "1";
 
-               gpio44 {
-                       /* yellow led */
-                       gpio-export,name = "gpio44";
-                       gpio-export,direction_may_change = <1>;
-                       gpio-export,output = <1>;
-                       gpios = <&gpio1 12 0>;
                };
        };
 
index 45cb22b09c585e8faab7bda7405b890d9ecbdbb5..0cfb8fbc41bc8387e44b104f3913e65ae433b446 100644 (file)
@@ -1154,6 +1154,7 @@ Image/Build/Profile/WRTNODE2P=$(call BuildFirmware/Default16M/$(1),$(1),wrtnode2
 
 ifeq ($(SUBTARGET),mt7628)
 define Image/Build/Profile/Default
+       $(call Image/Build/Profile/MIWIFI-NANO,$(1))
        $(call Image/Build/Profile/MT7628,$(1))
        $(call Image/Build/Profile/WRTNODE2P,$(1))
 endef