ramips: add support for 16MB VoCore
authorJohn Crispin <john@openwrt.org>
Mon, 5 Oct 2015 10:27:00 +0000 (10:27 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 5 Oct 2015 10:27:00 +0000 (10:27 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
SVN-Revision: 47120

target/linux/ramips/dts/VOCORE-16M.dts [new file with mode: 0644]
target/linux/ramips/dts/VOCORE-8M.dts [new file with mode: 0644]
target/linux/ramips/dts/VOCORE.dts [deleted file]
target/linux/ramips/dts/VOCORE.dtsi [new file with mode: 0644]
target/linux/ramips/image/Makefile

diff --git a/target/linux/ramips/dts/VOCORE-16M.dts b/target/linux/ramips/dts/VOCORE-16M.dts
new file mode 100644 (file)
index 0000000..464c137
--- /dev/null
@@ -0,0 +1,41 @@
+/dts-v1/;
+
+/include/ "VOCORE.dtsi"
+
+/ {
+       palmbus@10000000 {
+               spi@b00 {
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "w25q128";
+                               reg = <0>;
+                               linux,modalias = "m25p80", "w25q128";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "uboot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "uboot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0xfb0000>;
+                               };
+                       };
+               };
+       };
+};
diff --git a/target/linux/ramips/dts/VOCORE-8M.dts b/target/linux/ramips/dts/VOCORE-8M.dts
new file mode 100644 (file)
index 0000000..8a081ed
--- /dev/null
@@ -0,0 +1,41 @@
+/dts-v1/;
+
+/include/ "VOCORE.dtsi"
+
+/ {
+       palmbus@10000000 {
+               spi@b00 {
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "s25fl064k";
+                               reg = <0>;
+                               linux,modalias = "m25p80", "s25fl064k";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "uboot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "uboot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0x7b0000>;
+                               };
+                       };
+               };
+       };
+};
diff --git a/target/linux/ramips/dts/VOCORE.dts b/target/linux/ramips/dts/VOCORE.dts
deleted file mode 100644 (file)
index 5e386e4..0000000
+++ /dev/null
@@ -1,231 +0,0 @@
-/dts-v1/;
-
-/include/ "rt5350.dtsi"
-
-/ {
-       compatible = "VoCore", "ralink,rt5350-soc";
-       model = "VoCore";
-
-       palmbus@10000000 {
-               gpio1: gpio@660 {
-                       status = "okay";
-               };
-
-               i2c@900 {
-                       status = "okay";
-               };
-
-               spi@b00 {
-                       status = "okay";
-
-                       m25p80@0 {
-                               #address-cells = <1>;
-                               #size-cells = <1>;
-                               compatible = "s25fl064k";
-                               reg = <0>;
-                               linux,modalias = "m25p80", "s25fl064k";
-                               spi-max-frequency = <10000000>;
-
-                               partition@0 {
-                                       label = "uboot";
-                                       reg = <0x0 0x30000>;
-                                       read-only;
-                               };
-
-                               partition@30000 {
-                                       label = "uboot-env";
-                                       reg = <0x30000 0x10000>;
-                                       read-only;
-                               };
-
-                               factory: partition@40000 {
-                                       label = "factory";
-                                       reg = <0x40000 0x10000>;
-                                       read-only;
-                               };
-
-                               partition@50000 {
-                                       label = "firmware";
-                                       reg = <0x50000 0x7b0000>;
-                               };
-                       };
-
-                       spidev@1 {
-                               compatible = "linux,spidev";
-                               spi-max-frequency = <10000000>;
-                               reg = <1>;
-                       };
-               };
-       };
-
-       pinctrl {
-               state_default: pinctrl0 {
-                       gpio {
-                               ralink,group = "jtag", "uartf", "led";
-                               ralink,function = "gpio";
-                       };
-               };
-       };
-
-       ethernet@10100000 {
-               mtd-mac-address = <&factory 0x4>;
-       };
-
-       esw@10110000 {
-               ralink,portmap = <0x17>;
-       };
-
-       wmac@10180000 {
-               ralink,mtd-eeprom = <&factory 0>;
-       };
-
-       ehci@101c0000 {
-               status = "okay";
-       };
-
-       ohci@101c1000 {
-               status = "okay";
-       };
-
-       gpio-export {
-               compatible = "gpio-export";
-               #size-cells = <0>;
-
-               gpio0 {
-                       gpio-export,name = "gpio0";
-                       gpio-export,direction_may_change = <1>;
-                       gpios = <&gpio0 0 0>;
-               };
-
-               /* UARTF */
-               gpio7 {
-                       /* UARTF_RTS_N */
-                       gpio-export,name = "gpio7";
-                       gpio-export,direction_may_change = <1>;
-                       gpios = <&gpio0 7 0>;
-               };
-
-               gpio8 {
-                       /* UARTF_TXD */
-                       gpio-export,name = "gpio8";
-                       gpio-export,direction_may_change = <1>;
-                       gpios = <&gpio0 8 0>;
-               };
-
-               gpio9 {
-                       /* UARTF_CTS_N */
-                       gpio-export,name = "gpio9";
-                       gpio-export,direction_may_change = <1>;
-                       gpios = <&gpio0 9 0>;
-               };
-
-               gpio12 {
-                       /* UARTF_DCD_N */
-                       gpio-export,name = "gpio12";
-                       gpio-export,direction_may_change = <1>;
-                       gpios = <&gpio0 12 0>;
-               };
-
-               gpio13 {
-                       /* UARTF_DSR_N */
-                       gpio-export,name = "gpio13";
-                       gpio-export,direction_may_change = <1>;
-                       gpios = <&gpio0 13 0>;
-               };
-
-               gpio14 {
-                       /* UARTF_RIN */
-                       gpio-export,name = "gpio14";
-                       gpio-export,direction_may_change = <1>;
-                       gpios = <&gpio0 14 0>;
-               };
-
-               /* JTAG */
-               gpio17 {
-                       /* JTAG_TDO */
-                       gpio-export,name = "gpio17";
-                       gpio-export,direction_may_change = <1>;
-                       gpios = <&gpio0 17 0>;
-               };
-
-               gpio18 {
-                       /* JTAG_TDI */
-                       gpio-export,name = "gpio18";
-                       gpio-export,direction_may_change = <1>;
-                       gpios = <&gpio0 18 0>;
-               };
-
-               gpio19 {
-                       /* JTAG_TMS */
-                       gpio-export,name = "gpio19";
-                       gpio-export,direction_may_change = <1>;
-                       gpios = <&gpio0 19 0>;
-               };
-
-               gpio20 {
-                       /* JTAG_TCLK */
-                       gpio-export,name = "gpio20";
-                       gpio-export,direction_may_change = <1>;
-                       gpios = <&gpio0 20 0>;
-               };
-
-               gpio21 {
-                       /* JTAG_TRST_N */
-                       gpio-export,name = "gpio21";
-                       gpio-export,direction_may_change = <1>;
-                       gpios = <&gpio0 21 0>;
-               };
-
-               /* ETH LEDs */
-               gpio22 {
-                       /* ETH0_LED */
-                       gpio-export,name = "gpio22";
-                       gpio-export,direction_may_change = <1>;
-                       gpios = <&gpio1 0 0>;
-               };
-
-               gpio23 {
-                       /* ETH1_LED */
-                       gpio-export,name = "gpio23";
-                       gpio-export,direction_may_change = <1>;
-                       gpios = <&gpio1 1 0>;
-               };
-
-               gpio24 {
-                       /* ETH2_LED */
-                       gpio-export,name = "gpio24";
-                       gpio-export,direction_may_change = <1>;
-                       gpios = <&gpio1 2 0>;
-               };
-
-               gpio25 {
-                       /* ETH3_LED */
-                       gpio-export,name = "gpio25";
-                       gpio-export,direction_may_change = <1>;
-                       gpios = <&gpio1 3 0>;
-               };
-
-               gpio26 {
-                       /* ETH4_LED */
-                       gpio-export,name = "gpio26";
-                       gpio-export,direction_may_change = <1>;
-                       gpios = <&gpio1 4 0>;
-               };
-       };
-
-       gpio-leds {
-               compatible = "gpio-leds";
-
-               status {
-                       /* UARTF_RXD */
-                       label = "vocore:green:status";
-                       gpios = <&gpio0 10 0>;
-               };
-
-               eth {
-                       /* UARTF_DTR_N */
-                       label = "vocore:orange:eth";
-                       gpios = <&gpio0 11 0>;
-               };
-       };
-};
diff --git a/target/linux/ramips/dts/VOCORE.dtsi b/target/linux/ramips/dts/VOCORE.dtsi
new file mode 100644 (file)
index 0000000..ff031fa
--- /dev/null
@@ -0,0 +1,197 @@
+/include/ "rt5350.dtsi"
+
+/ {
+       compatible = "VoCore", "ralink,rt5350-soc";
+       model = "VoCore";
+
+       palmbus@10000000 {
+               gpio1: gpio@660 {
+                       status = "okay";
+               };
+
+               i2c@900 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+
+                       spidev@1 {
+                               compatible = "linux,spidev";
+                               spi-max-frequency = <10000000>;
+                               reg = <1>;
+                       };
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "jtag", "uartf", "led";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+       };
+
+       esw@10110000 {
+               ralink,portmap = <0x17>;
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+
+       gpio-export {
+               compatible = "gpio-export";
+               #size-cells = <0>;
+
+               gpio0 {
+                       gpio-export,name = "gpio0";
+                       gpio-export,direction_may_change = <1>;
+                       gpios = <&gpio0 0 0>;
+               };
+
+               /* UARTF */
+               gpio7 {
+                       /* UARTF_RTS_N */
+                       gpio-export,name = "gpio7";
+                       gpio-export,direction_may_change = <1>;
+                       gpios = <&gpio0 7 0>;
+               };
+
+               gpio8 {
+                       /* UARTF_TXD */
+                       gpio-export,name = "gpio8";
+                       gpio-export,direction_may_change = <1>;
+                       gpios = <&gpio0 8 0>;
+               };
+
+               gpio9 {
+                       /* UARTF_CTS_N */
+                       gpio-export,name = "gpio9";
+                       gpio-export,direction_may_change = <1>;
+                       gpios = <&gpio0 9 0>;
+               };
+
+               gpio12 {
+                       /* UARTF_DCD_N */
+                       gpio-export,name = "gpio12";
+                       gpio-export,direction_may_change = <1>;
+                       gpios = <&gpio0 12 0>;
+               };
+
+               gpio13 {
+                       /* UARTF_DSR_N */
+                       gpio-export,name = "gpio13";
+                       gpio-export,direction_may_change = <1>;
+                       gpios = <&gpio0 13 0>;
+               };
+
+               gpio14 {
+                       /* UARTF_RIN */
+                       gpio-export,name = "gpio14";
+                       gpio-export,direction_may_change = <1>;
+                       gpios = <&gpio0 14 0>;
+               };
+
+               /* JTAG */
+               gpio17 {
+                       /* JTAG_TDO */
+                       gpio-export,name = "gpio17";
+                       gpio-export,direction_may_change = <1>;
+                       gpios = <&gpio0 17 0>;
+               };
+
+               gpio18 {
+                       /* JTAG_TDI */
+                       gpio-export,name = "gpio18";
+                       gpio-export,direction_may_change = <1>;
+                       gpios = <&gpio0 18 0>;
+               };
+
+               gpio19 {
+                       /* JTAG_TMS */
+                       gpio-export,name = "gpio19";
+                       gpio-export,direction_may_change = <1>;
+                       gpios = <&gpio0 19 0>;
+               };
+
+               gpio20 {
+                       /* JTAG_TCLK */
+                       gpio-export,name = "gpio20";
+                       gpio-export,direction_may_change = <1>;
+                       gpios = <&gpio0 20 0>;
+               };
+
+               gpio21 {
+                       /* JTAG_TRST_N */
+                       gpio-export,name = "gpio21";
+                       gpio-export,direction_may_change = <1>;
+                       gpios = <&gpio0 21 0>;
+               };
+
+               /* ETH LEDs */
+               gpio22 {
+                       /* ETH0_LED */
+                       gpio-export,name = "gpio22";
+                       gpio-export,direction_may_change = <1>;
+                       gpios = <&gpio1 0 0>;
+               };
+
+               gpio23 {
+                       /* ETH1_LED */
+                       gpio-export,name = "gpio23";
+                       gpio-export,direction_may_change = <1>;
+                       gpios = <&gpio1 1 0>;
+               };
+
+               gpio24 {
+                       /* ETH2_LED */
+                       gpio-export,name = "gpio24";
+                       gpio-export,direction_may_change = <1>;
+                       gpios = <&gpio1 2 0>;
+               };
+
+               gpio25 {
+                       /* ETH3_LED */
+                       gpio-export,name = "gpio25";
+                       gpio-export,direction_may_change = <1>;
+                       gpios = <&gpio1 3 0>;
+               };
+
+               gpio26 {
+                       /* ETH4_LED */
+                       gpio-export,name = "gpio26";
+                       gpio-export,direction_may_change = <1>;
+                       gpios = <&gpio1 4 0>;
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               status {
+                       /* UARTF_RXD */
+                       label = "vocore:green:status";
+                       gpios = <&gpio0 10 0>;
+               };
+
+               eth {
+                       /* UARTF_DTR_N */
+                       label = "vocore:orange:eth";
+                       gpios = <&gpio0 11 0>;
+               };
+       };
+};
index 372fe3b166c3ac073d1b4367a465c28ab122697f..117e07d4ef75f4d9b90becc2bd3d893308d6e59b 100644 (file)
@@ -598,7 +598,17 @@ Image/Build/Profile/SL-R7205=$(call BuildFirmware/Default4M/$(1),$(1),sl-r7205,S
 
 Image/Build/Profile/V22RW-2X2=$(call BuildFirmware/Default4M/$(1),$(1),v22rw-2x2,V22RW-2X2)
 
-Image/Build/Profile/VOCORE=$(call BuildFirmware/Default8M/$(1),$(1),vocore,VOCORE)
+vocore_8mb_mtd_size=8060928
+vocore_16mb_mtd_size=16449536
+define BuildFirmware/VOCORE/squashfs
+       $(call BuildFirmware/CustomFlash/$(1),$(1),$(2)-8M,$(3)-8M,$(vocore_8mb_mtd_size))
+       $(call BuildFirmware/CustomFlash/$(1),$(1),$(2)-16M,$(3)-16M,$(vocore_16mb_mtd_size))
+endef
+define BuildFirmware/VOCORE/initramfs
+       $(call BuildFirmware/OF/initramfs,$(1),$(2)-8M,$(3)-8M)
+       $(call BuildFirmware/OF/initramfs,$(1),$(2)-16M,$(3)-16M)
+endef
+Image/Build/Profile/VOCORE=$(call BuildFirmware/VOCORE/$(1),$(1),vocore,VOCORE)
 
 Image/Build/Profile/W150M=$(call BuildFirmware/CustomFlashFactory/$(1),$(1),w150m,W150M,$(ralink_default_fw_size_4M),W150M Kernel Image,factory)