image.mk: introduce Image/Build/UbinizeImage make target
authorJohn Crispin <john@openwrt.org>
Tue, 24 Jun 2014 18:12:47 +0000 (18:12 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 24 Jun 2014 18:12:47 +0000 (18:12 +0000)
paramters:
$(1) board name
$(2) ubinize-image options (e.g. --no-kernel and/or --uboot-env)
$(3) rootfstype (e.g. squashfs or ubifs)
$(4) kernel image file
$(5) options to pass-through to ubinize (i.e. $($(PROFILE)_UBI_OPTS)))

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
SVN-Revision: 41311

include/image.mk

index 66ac497849f4e4b0a2c5c20a06410b0adb4468e8..a77de2723866b3af503a794ed7be688be7ec5a96 100644 (file)
@@ -141,6 +141,13 @@ ifneq ($(CONFIG_NAND_SUPPORT),)
        (cd $(KDIR_TMP); $(TAR) cvf \
                $(BIN_DIR)/$(IMG_PREFIX)-$(1)-ubi-sysupgrade.tar sysupgrade-$(1))
    endef
+   define Image/Build/UbinizeImage
+       sh $(TOPDIR)/scripts/ubinize-image.sh $(2) \
+               "$(KDIR)/root.$(3)" "$(4)" \
+               "$(BIN_DIR)/$(IMG_PREFIX)-$(1)-$(3)-ubinized.bin" \
+               $(5)
+   endef
+
 endif
 
 ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)