Fix compilation failures with spca5xx-le (#2735)
authorFlorian Fainelli <florian@openwrt.org>
Thu, 10 Jan 2008 18:15:45 +0000 (18:15 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 10 Jan 2008 18:15:45 +0000 (18:15 +0000)
SVN-Revision: 10158

package/spca5xx-le/Makefile
package/spca5xx-le/patches/100-compile_pud_shift.patch [new file with mode: 0644]

index 7c1ffbbbcf55e2ec81e763845a7cd0e06a4c79e0..08312b126ae21c8a1ab85404895c7d641b894c94 100644 (file)
@@ -25,7 +25,7 @@ define KernelPackage/video-spca5xx-le
   SUBMENU:=Video Support
   TITLE:=SPCA5xx based USB webcam support (Light Edition)
   URL:=http://mxhaard.free.fr/
-  DEPENDS:=@LINUX_2_6 @USB_SUPPORT @BROKEN +kmod-usb-core kmod-video-core
+  DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-core kmod-video-core
   FILES:=$(PKG_BUILD_DIR)/spca5xx.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,90,spca5xx)
 endef
diff --git a/package/spca5xx-le/patches/100-compile_pud_shift.patch b/package/spca5xx-le/patches/100-compile_pud_shift.patch
new file mode 100644 (file)
index 0000000..91913a7
--- /dev/null
@@ -0,0 +1,21 @@
+diff -Naur spca5xx-le/spca_core.c spca5xx-le-new/spca_core.c
+--- spca5xx-le/spca_core.c     2007-06-03 21:30:29.000000000 +0100
++++ spca5xx-le-new/spca_core.c 2008-01-06 12:48:08.000000000 +0000
+@@ -535,7 +535,7 @@
+   if (!pgd_none (*pgd))
+     {
+-#if PUD_SHIFT
++#ifdef PUD_SHIFT
+       pud_t *pud = pud_offset (pgd, adr);
+       if (!pud_none (*pud))
+       {
+@@ -552,7 +552,7 @@
+             ret = (unsigned long) page_address (pte_page (pte));
+             ret |= (adr & (PAGE_SIZE - 1));
+           }
+-#if PUD_SHIFT
++#ifdef PUD_SHIFT
+       }
+ #endif
+     }