perf: fix parallel build support, explicitly disable more library dependencies
authorFelix Fietkau <nbd@openwrt.org>
Sat, 2 Jan 2016 14:47:48 +0000 (14:47 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 2 Jan 2016 14:47:48 +0000 (14:47 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 48066

package/devel/perf/Makefile

index c03b9330f4a7e9af499c23b26c5b8cc0926f012a..d6db053173bbb4b6f1ba563386a3dac8c3b2731d 100644 (file)
@@ -13,6 +13,7 @@ PKG_VERSION:=$(LINUX_VERSION)
 PKG_RELEASE:=2
 
 PKG_USE_MIPS16:=0
+PKG_BUILD_PARALLEL:=1
 
 # Perf's makefile and headers are not relocatable and must be built from the
 # Linux sources directory
@@ -43,15 +44,26 @@ MAKE_FLAGS = \
        NO_LIBPYTHON=1 \
        NO_NEWT=1 \
        NO_LZMA=1 \
+       NO_BACKTRACE=1 \
+       NO_LIBNUMA=1 \
+       NO_GTK2=1 \
+       NO_LIBAUDIT=1 \
        CROSS_COMPILE="$(TARGET_CROSS)" \
        CC="$(TARGET_CC)" \
        LD="$(TARGET_CROSS)ld" \
        CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
        LDFLAGS="$(TARGET_LDFLAGS)" \
+       $(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='') \
        WERROR=0 \
-       V=1 \
        prefix=/usr
 
+define Build/Compile
+       +$(MAKE_FLAGS) $(MAKE) $(PKG_JOBS) \
+               -C $(PKG_BUILD_DIR) \
+               -f Makefile.perf \
+               --no-print-directory
+endef
+
 define Package/perf/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/perf $(1)/usr/bin/