ath79: add support for TP-Link TL-WDR4900 v2
authorChuanhong Guo <gch981213@gmail.com>
Thu, 9 Aug 2018 04:29:28 +0000 (12:29 +0800)
committerMathias Kresin <dev@kresin.me>
Sat, 11 Aug 2018 19:36:27 +0000 (21:36 +0200)
Specification:
- SoC: Qualcomm Atheros QCA9558
- Flash: 8 MB
- RAM: 128 MB
- Ethernet: AR8327N with 5 GE ports.
- Wireless radio: QCA9558 for 2.4G and AR9580 for 5G.

Flash instruction:
  Upload the generated factory firmware on web interface.

Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
target/linux/ath79/dts/qca9558_tplink_tl-wdr4900-v2.dts [new file with mode: 0644]
target/linux/ath79/image/generic-tp-link.mk

index bbb30aa0cc615ae7d3376b408ea0a1b9d712c0ae..79b39b22f4a44abcf47a256ea298d7bc8496d6a1 100755 (executable)
@@ -69,7 +69,8 @@ ath79_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth0" "3:lan:1" "5:lan:2" "4:wan"
                ;;
-       tplink,archer-c7-v2)
+       tplink,archer-c7-v2|\
+       tplink,tl-wdr4900-v2)
                ucidef_add_switch "switch0" \
                        "0@eth1" "2:lan" "3:lan" "4:lan" "5:lan" "6@eth0" "1:wan"
                ;;
index e8adcf613ae964e52d33454b96adf3ac8d76405e..5d52af71fbc7e88a3a040f0c132c291927d68ff5 100644 (file)
@@ -52,7 +52,8 @@ case "$FIRMWARE" in
                ;;
        ocedo,raccoon|\
        tplink,tl-wdr3600|\
-       tplink,tl-wdr4300)
+       tplink,tl-wdr4300|\
+       tplink,tl-wdr4900-v2)
                ath9k_eeprom_extract "art" 20480 1088
                ;;
        netgear,wnr612-v2|\
diff --git a/target/linux/ath79/dts/qca9558_tplink_tl-wdr4900-v2.dts b/target/linux/ath79/dts/qca9558_tplink_tl-wdr4900-v2.dts
new file mode 100644 (file)
index 0000000..412cf2b
--- /dev/null
@@ -0,0 +1,232 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9557.dtsi"
+
+/ {
+       compatible = "tplink,tl-wdr4900-v2", "qca,qca9558";
+       model = "TP-Link TL-WDR4900 v2";
+
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       aliases {
+               led-status = &led_system;
+       };
+
+       gpio_leds: leds {
+               compatible = "gpio-leds";
+
+               led_system: system {
+                       label = "tp-link:blue:system";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               usb1 {
+                       label = "tp-link:green:usb1";
+                       gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+                       trigger-sources = <&hub_port1>;
+                       linux,default-trigger = "usbport";
+               };
+
+               usb2 {
+                       label = "tp-link:green:usb2";
+                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+                       trigger-sources = <&hub_port0>;
+                       linux,default-trigger = "usbport";
+               };
+
+               wlan2g {
+                       label = "tp-link:blue:wlan2g";
+                       gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               qss {
+                       label = "tp-link:blue:qss";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+       };
+
+        ath9k-leds {
+               compatible = "gpio-leds";
+
+               wlan5g {
+                       label = "tp-link:blue:wlan5g";
+                       gpios = <&ath9k 0 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+                       linux,default-trigger = "phy1tpt";
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "Reset button";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       gpio-export {
+               compatible = "gpio-export";
+
+               gpio_usb1_power {
+                       gpio-export,name = "tp-link:power:usb1";
+                       gpio-export,output = <1>;
+                       gpios = <&gpio 21 GPIO_ACTIVE_HIGH>;
+               };
+
+               gpio_usb2_power {
+                       gpio-export,name = "tp-link:power:usb2";
+                       gpio-export,output = <1>;
+                       gpios = <&gpio 22 GPIO_ACTIVE_HIGH>;
+               };
+
+       };
+};
+
+&pcie1 {
+       status = "okay";
+
+       ath9k: wifi@0,0 {
+               compatible = "pci168c,0033";
+               reg = <0x0000 0 0 0 0>;
+               mtd-mac-address = <&uboot 0x1fc00>;
+               mtd-mac-address-increment = <(-2)>;
+               qca,no-eeprom;
+               #gpio-cells = <2>;
+               gpio-controller;
+       };
+};
+
+&uart {
+       status = "okay";
+};
+
+&usb_phy0 {
+       status = "okay";
+};
+
+&usb0 {
+       #address-cells = <1>;
+       #size-cells = <0>;
+       status = "okay";
+
+       hub_port0: port@1 {
+               reg = <1>;
+               #trigger-source-cells = <0>;
+       };
+};
+
+&usb_phy1 {
+       status = "okay";
+};
+
+&usb1 {
+       #address-cells = <1>;
+       #size-cells = <0>;
+       status = "okay";
+
+       hub_port1: port@1 {
+               reg = <1>;
+               #trigger-source-cells = <0>;
+       };
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       uboot: partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x020000>;
+                               read-only;
+                       };
+
+                       partition@20000 {
+                               label = "firmware";
+                               reg = <0x020000 0x7d0000>;
+                       };
+
+                       art: partition@7f0000 {
+                               label = "art";
+                               reg = <0x7f0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy0: ethernet-phy@0 {
+               reg = <0>;
+
+               qca,ar8327-initvals = <
+                       0x04 0x00080080 /* PORT0 PAD MODE CTRL */
+                       0x0c 0x07600000 /* PORT6 PAD MODE CTRL */
+                       0x50 0xc737c737 /* LED_CTRL0 */
+                       0x54 0x00000000 /* LED_CTRL1 */
+                       0x58 0x00000000 /* LED_CTRL2 */
+                       0x5c 0x0030c300 /* LED_CTRL3 */
+                       0x7c 0x0000007e /* PORT0_STATUS */
+                       0x94 0x0000007e /* PORT6 STATUS */
+               >;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       mtd-mac-address = <&uboot 0x1fc00>;
+       mtd-mac-address-increment = <1>;
+       phy-handle = <&phy0>;
+       pll-data = <0x56000000 0x00000101 0x00001616>;
+
+       gmac-config {
+               device = <&gmac>;
+               rgmii-enabled = <1>;
+       };
+};
+
+&eth1 {
+       status = "okay";
+
+       mtd-mac-address = <&uboot 0x1fc00>;
+       pll-data = <0x03000101 0x00000101 0x00001616>;
+
+       fixed-link {
+               speed = <1000>;
+               full-duplex;
+       };
+};
+
+&wmac {
+       status = "okay";
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&uboot 0x1fc00>;
+       mtd-mac-address-increment = <(-1)>;
+};
index 623252ee7d0d90cc8c9ec061758d510a920fa2b0..0f8bfff8ad5b5d2b91fd26631bd6e5935693cc74 100644 (file)
@@ -49,6 +49,15 @@ define Device/tplink_tl-wdr4300
 endef
 TARGET_DEVICES += tplink_tl-wdr4300
 
+define Device/tplink_tl-wdr4900-v2
+  $(Device/tplink-8mlzma)
+  ATH_SOC := qca9558
+  DEVICE_TITLE := TP-LINK TL-WDR4900 v2
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
+  TPLINK_HWID := 0x49000002
+endef
+TARGET_DEVICES += tplink_tl-wdr4900-v2
+
 define Device/tplink_tl-wr1043nd-v1
   $(Device/tplink-8m)
   ATH_SOC := ar9132